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Overview
The purpose of the Quick Start Guide is to step you quickly and easily through the update 
of a Data Appliance 5.1 collection. This Quick Start Guide is for use with ArcGIS® 10.1 for 
Server. The update consists of the following steps:

Step 1 Unpack the Components
Step 2 Delete ArcGIS Services
Step 3 Shut Down Data Appliance for ArcGIS
Step 4 Remove Old/Install New Data Collection
Step 5 Power On Data Appliance for ArcGIS
Step 6 Verify New Data Collection
Step 7 Create Shares
Step 8 Con� gure ArcGIS Server to Use Cache Directory
Step 9 Publish Services
Step 10 Use Services

Before Starting
ArcGIS Server 10 SP5 or higher is required for Data Appliance 5.1. If you are planning to 
upgrade to ArcGIS 10.1 for Server, Esri recommends you do so prior to installing your new 
collection. If you are using ArcGIS Server 10, please refer to the Quick Start Guide Data 
Appliance for ArcGIS 10 Data Collection Update for Windows. Services for Data Appliance 
for ArcGIS data collections installed on your Data Appliance for ArcGIS server will be 
unavailable during the installation process. This update should take approximately two 
hours to complete.

Note: If you are using locators and routing services from Data Appliance 5.0 for ArcGIS, 
since locators and routing services are no longer included as part of the Data Appliance with 
the 5.1 release, you need to migrate to StreetMap™ Premium for ArcGIS for your regions of 
interest prior to upgrading to Data Appliance 5.1 for ArcGIS. Additionally, if you were using 
the World Places Locator from Data Appliance 5.0, you need to upgrade to the World Places 
Locator that shipped with Data Appliance 5.1 on a separate DVD before upgrading to Data 
Appliance 5.1 for ArcGIS. 

Important: It is imperative that care and precautions be taken when handling the data 
collection hard drives. The hard drives are sensitive to shock as well as electrostatic 
discharge. Make sure precautions are taken to eliminate any built-up static. The use of a 
grounding strap is highly recommended while handling the hard drives.

Your shipment contains one of the following Data Appliance for ArcGIS 
collections: World Premier Collection, World Small-Scale Collection, North 
America Collection, or Europe Collection; a collection consists of two or more 
drives that make up a single RAID volume. Each drive is labeled with the 
collection name and version.

To update the Data Appliance for ArcGIS collections, ArcGIS Services that 
utilize the Data Appliance 5.0 services must be deleted from ArcGIS Server 
before you disconnect the Data Appliance 5.0.

A. Log in to ArcGIS Server using the Data Appliance for ArcGIS data account 
with administrative privileges.

B. Start ArcGIS Server Manager and log in using your account.
C. Click Services > Manage Services.
D. Check each service to select the services to stop.
E. Locate the service in the Services module and click Delete. The service is 

deleted from your server.

Although Data Appliance for ArcGIS has hot-swappable hard drive bays, hot 
swapping an entire data collection is not supported. 

A. Log in to Data Appliance for ArcGIS using the Administrator account. 
B. Click the Start menu, expand the Shutdown menu, and select Shut down.

C. Allow Data Appliance for ArcGIS to completely shut down.
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Delete ArcGIS Services2
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Basemap Collection Services World Imagery Collection Services World Collection Services

Map Services
World_Boundaries_and_Places
World_Street_Map
World_Topo_Map
World_Transportation

Geocode services
TA_Address_EU
TA_Address_NA_10

Routing Services
ESRI_Route_EU
ESRI_Route_NA

Map Services
World_Imagery
USA_Topo_Maps

Map Services
DeLorme_World_Base_Map
Ocean_Basemap
World_Boundaries_and_Places
World_Boundaries_and_Places_Alternate
World_Imagery
World_Navigation_Charts
World_Physical_Map
World_Shaded_Relief
World_Street_Map
World_Transportation

Globe Services
ESRI_Elevation_World
USGS_Elevation_US
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A. With Data Appliance for ArcGIS powered off, remove the existing data col-
lection hard drives from the Data Appliance for ArcGIS system.

B. Place the removed hard drives in a secure and static-free location.
C. Continue removing all hard drives for the collection to be updated. Do 

not leave any hard drive from the old data collection in Data Appliance 
for ArcGIS.

Depending on the con� guration being serviced, use the above illustrations as guides, with 
1U on the left and 4U on the right.

With Data Appliance for ArcGIS still powered off, install the new data 
collection hard drives into Data Appliance for ArcGIS. Note that the 
new hard drives are labeled as to what collection they belong to as 
well as the number of drives in the set, for example, World Premier 
Collection Drive 00 1 of 22.

Although it does not matter which slot a drive is installed in, it is recom-
mended that drives be installed in order, starting from the top left, � lling in 
the drive bays across a row, then proceeding to the row below.

D. Note the label of the hard drive that is to be installed into Data Appliance 
for ArcGIS to � nd its position. Make sure all drives from each set are pres-
ent. If you � nd that a drive is missing, immediately stop the installation 
procedure and contact Cutting Edge Networked Storage technical 
support.

E. Insert the replacement drive tray into the chassis. Make sure to press the 
drive carrier handle closed until it clicks in place.

F. Make sure all drives from all the data collections are installed in Data 
Appliance for ArcGIS.
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To turn on Data Appliance for ArcGIS, press the power button located on the 
front of the computer equipment rack. 

Note: While booting up, the Windows 2008 Storage Server operating system 
performs a number of system checks to verify the integrity of the � le system. 
During this time, the hard drive activity LEDs on Data Appliance for ArcGIS will 
blink. Please do not interrupt the system by powering it off or rebooting it.  
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Verify New Data Collection6
Before utilizing the data collection, the health of the RAID arrays must be 
veri� ed. Data Appliance for ArcGIS ships with the LSI/3ware 3DM2 utility pre-
installed. This utility will be used to verify the status of the datasets.

A. Log in to Data Appliance for ArcGIS as Administrator. 
B. Click the Start menu, expand All Programs, and expand the 3ware folder.
C. Click Connect to 3DM2 to start the 3DM2 utility.
D. Disregard the security warning and click Continue to website (not 

recommended).
E. In the Login drop-down menu, select Administrator.

F. Enter the password “3ware” and click Login.
G. The 3DM2 summary screen is displayed. Note the Status column.

H. If the status for all collections is OK and green, the arrays are healthy and 
ready to use. If something other than OK is displayed, click Information and 
click Unit Information. This displays the status of each RAID array (unit). 
1. If the status is Verifying, the datasets are ready to use. (Verify 

procedures are run on schedules to preemptively correct any errors.)
2. If the status is Degraded or Of� ine, immediately stop and contact 

Cutting Edge Networked Storage technical support.
I. Click Logout to log out of the 3DM2 utility. Once you have logged out, exit 

the web browser.
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Data Appliance for ArcGIS must be con� gured to share the data collections. 

A. Log in to Data Appliance for ArcGIS as Administrator. 
B. Click Start > Administrative Tools > Computer Management.
C. In the Computer Management application, click Shared Folders to expand 

the tree and right-click the Shares folder. Select New Share.
D. In the Create A Shared Folder wizard, click Next to begin.
E. For Folder path, click Browse and navigate to the hard drive with the 

data collection (usually drive E). Select the cache directory and click OK. 

F. Click Next.
G. In the Name, Description, and Settings dialog box, enter the Share name 

for cache or source documents and enter the Share path for the appropri-
ate directory.

H. Click Next.
I. Select the Customize Permissions option and click Custom.
J. In the Customize Permissions window, click Add.
K. Add the following users and groups if needed: Administrator and arcgis.
L. Make sure the permissions for the users and groups are set to Full 

Control.
M. Repeat steps 7C through 7L for the source documents share.
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Con� gure ArcGIS Server to Use Cache Directory8
ArcGIS 10.1 for Server maintains a list of directories in which it can � nd map and 
globe cache tiles. You need to explicitly add the Data Appliance cache directory 
to this list.

A. Log in to ArcGIS Server using the Data Appliance for ArcGIS data account 
with administrative privileges.

B. Start ArcGIS Server Manager and log in using your ArcGIS for Server account.
C. Click the Site tab. 
D. In the View menu on the left, click Directories. 
E. Click Add Directory on the right below the Directories description.
F. Enter a Name, for example, Cache. From the Type drop-down list, 

choose Cache.
G. For Location, enter the path to the cache folder on the ArcGIS Data 

Appliance data collection you made when you created shares, for example, 
\\ARCGISDATAAPP\cache.

H. You do not need to specify a Description, Cleaning Mode, or Maximum 
File Age.

I.  Click Add to add the directory. 

Publish Services9
The following instructions apply to map services. Information about globe ser-
vices can be found in the help � le on the Data Appliance 5.1 for ArcGIS Help 
Documentation DVD by opening arcgis_data_appliance.pdf.

Using ArcGIS Server Manager, you can publish a service de� nition � le (.sd) as 
a service. To publish a service de� nition using Manager, follow these steps for 
each map service that you want to create:

A. Open ArcGIS Server Manager and log in.
B.  Click Services > Manage Services > Publish Service.
C.  Click the browse button to navigate to the source_documents > service_

de� nitions folder on the Data Appliance data collection, for example,
 \\ARCGISDATAAPP\source_documents\service_de� nitions.

D.  Select the service de� nition you want to publish, for example, Ocean_
Basemap.sd. See the Services Reference Guide for 5.1 at the end of this 
document for a list of the Data Appliance map services.
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E.  Click Next.
F.  By default, the service de� nition is published to the server folder speci� ed in 

the service de� nition con� guration. You must publish the service de� nition 
to this root folder.

G.  Optionally, choose the GIS server cluster that will host the published 
service de� nition. Click Next.

H.  Optionally, choose to enable or disable capabilities for your 
service de� nition.

I.  Click Publish to publish the service de� nition as a service. The new map 
service appears in the list of available services.

The publish process uses the � rst directory in the server’s list of cache 
directories. You need to change it to the data appliance cache directory 
created previously.

J.  Click the Stop button to the right of the service name to stop the service.
K.  Click the Edit button to edit the service properties.
L.  Click Caching and change the cache directory setting to reference the data 

appliance collection.

Services Reference Guide for 5.1
Map Services Globe Services Geocode Services

DeLorme_World_Base_Map
NatGeo_World_Map¹
Ocean_Basemap
USA_Topo_Maps
World_Boundaries_and_Places
World_Boundaries_and_Places_Alternate
World_Imagery
World_Light_Gray_Base¹
World_Light_Gray_Reference¹
World_Physical_Map
World_Shaded_Relief
World_Street_Map
World_Topo_Map
World_Transportation

EESRI_Elevation_World
USGS_Elevation_US

ESRI_Places_World2

1 New Services—Refer to the Data Appliance 5.0 for ArcGIS Help Documentation DVD for more information.
2 Now available on a separate DVD included with Data Appliance 5.1 for ArcGIS. 

Resources
Cutting Edge Networked Storage provides several reference documents. These are available 
at cuttedge.com/contact/DAWindows.html.

The Data Appliance 5.1 for ArcGIS Help Documentation DVD is included in the box with your 
data collection drives. Refer to the help for additional details.

For an up-to-date online help system, system requirements, information on licensing, and 
more, visit links.esri.com/data-appliance/5.1/tech-docs.

Support
Esri Support
For information regarding the con� guration and setup of ArcGIS services and usage, visit 
support.esri.com/en/phoneSupport.

For the most current information for all ArcGIS products, visit the ArcGIS Resources website 
at resources.arcgis.com.

Cutting Edge Networked Storage Support
For information and support regarding the Data Appliance for ArcGIS hardware, contact 
Cutting Edge Networked Storage using the following contact options:

Phone: 800-257-1666
E-mail: support@cuttedge.com
Website: cuttedge.com/contact/technical_support.html
Hours: Monday–Friday, 8:00 a.m.–5:00 p.m. (Paci� c time)

For speci� c instructions on how to connect to and use the services, see the 
appropriate user guide for the ArcGIS application you are using. 

Additional information can be found in the help � le on the Data Appliance 5.1 for 
ArcGIS Help Documentation DVD by opening arcgis_data_appliance.pdf.
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M.  Click Save to save your changes and click the Restart button to restart 
the service.

N.  Repeat this process for any other map services you want to publish.


