Data Appliance 5.1 for ArcGIS

ArcGIS 10.1 for Server | Windows®

Quick Start Guide

S PWCUTTING
Powered by ArcGIS @ esrl 'E‘TD%B:KEE

132178 Esri11/12kq

Overview

The purpose of the Quick Start Guide is to step you quickly and easily through the setup of a
Data Appliance 5.1 collection. This Quick Start Guide is for use with ArcGIS® 10.1 for Server.
The setup consists of the following steps:

Step 1 Unpack the Components

Step 2 Install Appliance into an Equipment Rack
Step 3 Cable the Data Appliance

Step 4 Power On Data Appliance

Step 5 System Licensing and Activation

Step 6 Apply Windows Updates

Step 7 Verify the Data Collection

Step 8 Create ArcGIS Users on Data Appliance
Step 9 Create Shares

Step 10 Configure ArcGIS Server to Use Cache Directory
Step 11 Publish Services

Step 12 Use Services

Before Starting

ArcGIS Server 10 SP5 or higher is required for all Data Appliance 5.1 for ArcGIS data
collections. If you purchased Data Appliance for ArcGIS Server 10, refer to the instructions
provided in your Data Appliance for ArcGIS Server 10 box before performing the steps in this
Quick Start Guide.

Important: It is imperative that care and precautions be taken when handling the data
collection hard drives. The hard drives are sensitive to shock as well as electrostatic
discharge. Make sure that precautions are taken to eliminate any built-up static. The use of a
grounding strap is highly recommended while you handle the hard drives.

@ Unpack the Components

Within each Data Appliance for ArcGIS box, there is a removable front bezel for
the server to cover and lock the hard drives; keys are included. This is to prevent
unauthorized persons from removing hard disks. Also included in the box are
the adjustable sliding rails to mount your Data Appliance for ArcGIS server into

a standard computer equipment rack. The mounting kit is located within the
smaller box that is packed toward the front of the server. The contents of the box
can be unpacked by a single person, but it is recommended that two people
remove the server from the box. The server weight is approximately 90 pounds.

Install Appliance into an Equipment Rack

Data Appliance for ArcGIS ships with side rails attached that slide into the ad-
justable rails installed in the computer equipment rack. Depending on the depth
of your rack cabinet, adjustments to the sliding rails may be required. Use the
mounting screws provided to attach the sliding rails to your cabinet. Additional
details can be found in the Data Appliance 5.1 for ArcGIS Windows® Hardware
Quick Reference that is included in the box.

Cable the Data Appliance

Data Appliance for ArcGIS hardware requires two AC power sources. Two power
cords are included in the smaller box that contains the mounting kit for the rails.
Connect both power cords. Connect a monitor to the video port as well as a key-
board and mouse to their respective PS/2 ports. Network connectivity is required
during the operation of Data Appliance for ArcGIS. Plug an RJ-45 Ethernet cable
into the Ethernet port of the Data Appliance hardware. Additional details can be
found in the Data Appliance 5.1 for ArcGIS Windows Hardware Quick Reference
that is included in the box.

@ Power On Data Appliance

To turn on Data Appliance for ArcGIS, press the power button located on the
front of the computer equipment rack.

Note: While booting up, the Windows 2008 Storage Server operating system
performs a number of system checks to verify the integrity of the file system.
During this time, the hard drive activity LEDs on Data Appliance for ArcGIS will
blink. Please do not interrupt the system by powering it off or rebooting it.
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System Licensing and Activation

After Windows setup is complete, the system will boot into the final section of
Windows Setup. Follow the on-screen instructions.

A. Select the appropriate settings and click Next.

B. Type the product key found on the Microsoft® COA label located on
the front left corner of the system and click Next. Check Automatically
activate Windows when I'm online if the system has Internet access.

C. Accept the Microsoft Software License Terms and click Start.

D. Follow the instructions to change the administrative password for the system.

Note: Refer to the Data Appliance for ArcGIS User Guide for Windows on the
Cutting Edge Networked Storage website for information on activating Win-
dows without Internet access or for additional details on system setup.

Apply Windows Updates

Read the following before continuing: Data Appliance for ArcGIS ships with
the Windows 2008 Storage Server operating system. Microsoft routinely releases
updates and patches to improve stability and security. Any updates released
after Data Appliance for ArcGIS has shipped need to be applied.

Verify the Data Collection

Before utilizing the data collection, the health of the RAID arrays must be
verified. Data Appliance for ArcGIS ships with the LSI/3ware 3DM2 utility pre-
installed. This utility will be used to verify the status of the datasets.

A. Login to Data Appliance for ArcGIS as Administrator.

B. Click the Start menu, expand All Programs, and expand the 3ware folder.

C. Click Connect to 3DM2 to start the 3DM2 utility.

D. Disregard the security warning and click Continue to website (not
recommended).

E. Inthe Login drop-down menu, select Administrator.
Please Login
Login Administrator 'I
Password I\

F. Enter the password “3ware” and click Login.
G. The 3DM2 summary screen is displayed. Note the Status column.
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H. If the status for all collections is OK and green, the arrays are healthy and
ready to use. If something other than OK is displayed, click Information and
click Unit Information. This displays the status of each RAID array (unit).

1. If the status is Verifying, the datasets are ready to use. (Verify
procedures are run on schedules to preemptively correct any errors.)

2. If the status is Degraded or Offline, immediately stop and contact
Cutting Edge Networked Storage technical support.

I. Click Logout to log out of the 3DM2 utility. Once you have logged out, exit
the web browser.

Create ArcGIS Users on Data Appliance

The ArcGIS user on ArcGIS 10.1 for Server must be created on Data Appliance
for ArcGIS.

A. Log in to Data Appliance for ArcGIS as Administrator.

B. Click Start > Administrative Tools > Computer Management.

C. Inthe Computer Management application, on the left pane, click Local Users
and Groups to expand the tree, and click the Users folder. On the main pane,
right-click and select New User. The New User wizard is displayed.

D. Use the New User wizard to create the following user. The password must
be configured to match the password for the respective account on
ArcGIS 10.1 for Server, and the password must be set to never expire:

User Name Full Name Description

arcgis ArcGIS Server Account Account to perform a variety of functions in
support of the GIS server

E. Click Create to create each new user on Data Appliance for ArcGIS.

Create Shares

Data Appliance for ArcGIS must be configured to share the data collections.

A. Login to Data Appliance for ArcGIS as Administrator.

B. Click Start > Administrative Tools > Computer Management.

C. Inthe Computer Management application, click Shared Folders to expand
the tree, and right-click the Shares folder. Select New Share.

D. In the Create A Shared Folder wizard, click Next to begin.

E. For Folder path, click Browse and navigate to the hard drive with the data
collection (usually drive E). Select the cache folder (or the source_documents
folder) and click OK.
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Click Next.

In the Name, Description, and Settings dialog box, enter the Share name
and Description for your data collection as indicated in the following
table. For Offline setting, accept the default.

Folder Share Name Description

\cache cache Data Appliance Cache

\source_documents ‘ source_documents ‘ Data Appliance Source Documents
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Click Next.

Select the Customize permissions option and click Custom.

In the Customize Permissions dialog box, click Add.

In the Select Users or Groups dialog box, click Advanced. The Select Users
or Groups dialog box expands.

Click Find Now to display a list of all local users. Press the Ctrl key and
click the Administrator user and the arcgis user to highlight them. Then,
with both users highlighted, click OK above the Search results area. The
dialog box reverts to a smaller size.

[Select Users or Groups
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. The two users you just selected should be listed under Enter the object

names to select. Click OK.

. Make sure the permissions for the users and groups are set to Full Control.
. Repeat steps 9C through 9N for the source documents folder.

ArcGIS 10.1 for Server maintains a list of directories in which it can find map and
globe cache tiles. You need to explicitly add the Data Appliance cache directory
to this list.

A.
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Publish Services

Log in to ArcGIS Server using the Data Appliance for ArcGIS data account
with administrative privileges.

Start ArcGIS Server Manager and log in using your ArcGlIS for Server account.
Click the Site tab.

In the View menu on the left, click Directories.

Click Add Directory on the right below the Directories description.

Enter a Name, for example, Cache. From the Type drop-down list,

choose Cache.

. For Location, enter the path to the cache folder on the ArcGIS Data

Appliance data collection you made when you created shares, for example,
\\ARCGISDATAAPP\cache.

. You do not need to specify a Description, Cleaning Mode, or Maximum

File Age.
Click Add to add the directory.

The following instructions apply to map services. Information about globe ser-
vices can be found in the help file on the Data Appliance 5.1 for ArcGIS Help
Documentation DVD by opening arcgis_data_appliance.pdf.

Using ArcGIS Server Manager, you can publish a service definition file (.sd) as

a service. To publish a service definition using Manager, follow these steps for

each map service that you want to create:

A

B.

C.

Open ArcGIS Server Manager and log in.

Click Services > Manage Services > Publish Service.

Click the browse button to navigate to the source_documents > service_
definitions folder on the Data Appliance data collection, for example,
\\ARCGISDATAAPP\source_documents\service_definitions.

Select the service definition you want to publish, for example, Ocean_
Basemap.sd. See the Services Reference Guide for 5.1 at the end of this
document for a list of the Data Appliance map services.
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Click Next.

By default, the service definition is published to the server folder specified
in the service definition configuration. You must publish the service defini-
tion to this root folder.

. Optionally, choose the GIS server cluster that will host the published

service definition. Click Next.

. Optionally, choose to enable or disable capabilities for your

service definition.
Click Publish to publish the service definition as a service. The new map
service appears in the list of available services.

Ocean Basemap # (Map Service) 5a drm S Xx
bathymetry, marine water body names, undersea feature names

Status: Started

Instances Running: 1

Instances in Use: u]

Magimum Instances: 2
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The publish process uses the first directory in the server’s list of cache directories.
You need to change it to the data appliance cache directory created previously.

J. Click the Stop button to the right of the service name to stop the service.

K. Click the Edit button to edit the service properties.

L. Click Caching and change the cache directory setting to reference the
data appliance collection.

Fditing: Ocean_Dasemap Helo |65V €5l

M. Click Save to save your changes and click the Restart button to restart
the service.
N. Repeat this process for any other map services you want to publish.

Use Services

For specific instructions on how to connect to and use the services, see the
appropriate user guide for the ArcGIS application you are using.

Additional information can be found in the help file on the Data Appliance 5.1 for
ArcGIS Help Documentation DVD by opening arcgis_data_appliance.pdf.

Services Reference Guide for 5.1

Map Services Globe Services Geocode Services'
Delorme_World_Base_Map ESRI_Elevation_World ESRI_Places_World'
NatGeo_World_Map USGS_Elevation_US

Ocean_Basemap
USA_Topo_Maps
World_Boundaries_and_Places
World_Boundaries_and_Places_Alternate
World_Imagery
World_Light_Gray_Base
World_Light_Gray_Reference
World_Physical_Map
World_Shaded_Relief
World_Street_Map
World_Topo_Map
World_Transportation

TAvailable on a separate DVD included with Data Appliance 5.1 for ArcGIS

Resources

Cutting Edge Networked Storage provides several reference documents. These are available
at cuttedge.com/contact/DAWindows.html.

The Data Appliance 5.1 for ArcGIS Help Documentation DVD is included in the box with your
data collection drives. Refer to the help for additional details.

For an up-to-date online help system, system requirements, information on licensing, and
more, visit links.esri.com/data-appliance/5.1/tech-docs.

Support

Esri Support
For information regarding the configuration and setup of ArcGIS services and usage, visit
support.esri.com/en/phoneSupport.

For the most current information for all ArcGIS products, visit the ArcGIS Resources website
at resources.arcgis.com.

Cutting Edge Networked Storage Support
For information and support regarding the Data Appliance for ArcGIS hardware, contact
Cutting Edge Networked Storage using the following options:

Phone:  800-257-1666

E-mail: support@cuttedge.com

Website: cuttedge.com/contact/technical_support.html
Hours: Monday-Friday, 8:00 a.m.-5:00 p.m. (Pacific time)
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