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Updated for Service Pack 4

This document describes the main enhancements to 9.2 added by the service packs. It does not cover the bug fixes
and quality improvements which are the main purpose of our service packs. A full list of the quality issues that have
been addressed is available on the download page for the latest service pack.
Our service packs are cumulative, so 9.2 Service Pack 4 contains all the enhancements from the previous 9.2 service
packs. So if you've not installed a 9.2 service pack yet, you only need to install the most recent one.
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General
Support for 64-bit processors
Starting at Service Pack 3, ArcGIS is now certified to run on the Intel and AMD 64-bit processor families, such as
the Xeon64 and AMD64. Note that the Intel Itanium processor is not supported. At Service Pack 3, the supported 64bit Windows operating systems are Windows XP 64-bit and Windows 2003 Server 64-bit. ArcGIS 9.2 Service Pack 3
runs as a 32-bit application on these 64-bit Windows platforms, and so can take advantage of some of the
performance benefits of the 64-bit environment.
ArcGIS Desktop, ArcInfo, ArcEditor, ArcView, and ArcReader on 64-bit
ArcGIS Desktop is a native 32-bit application and runs as a 32-bit application on 64-bit (x64) Microsoft Windows. In
addition to Windows, ArcReader is also supported on Linux and Solaris. ArcReader on Solaris is supported in a 64bit environment. ArcReader on 64-bit Linux has not been fully certified yet, but testing so far has been successful.
ArcGIS Server and ArcIMS on 64-bit
ArcGIS Server and ArcIMS are native 32-bit applications. They have both been certified running as a 32-bit
application on 64-bit (x64) Microsoft Windows. Web server support is based on the web server vendor’s support of
64-bit Microsoft Windows. Check with your web server vendor if the web server is supported on 64-bit Microsoft
Windows. In addition to Windows, ArcGIS Server and ArcIMS are supported on Solaris and Linux. ArcGIS Server
and ArcIMS are both supported in a Solaris 64-bit environment. ArcGIS Server and ArcIMS on 64-bit Linux are not
completely tested, however test results so far has been successful. ArcIMS is also supported on IBM AIX and HP
HPUX. ArcIMS has not been certified with either operating system in a 64-bit environment.
ArcGIS Engine on 64-bit
ArcGIS Engine is a native 32-bit application and is has been certified running as a 32-bit application on 64-bit (x64)
Microsoft Windows. In addition to Windows, ArcGIS Engine is supported on Solaris and Linux. ArcGIS Engine is
supported in a Solaris 64-bit environment but has not yet been fully certified in a Linux 64-bit environment.
ArcSDE on 64-bit
ArcSDE is available as a native 64-bit application for Sun Solaris (Oracle and DB2), HP HPUX (Oracle and DB2), HP
Tru64 (Oracle), and IBM AIX (Oracle and DB2). On Windows, ArcSDE is a native 32-bit application and has now
been certified running as a 32-bit application on 64-bit Microsoft Windows. DBMS support is based on the DBMS
vendor’s support of 64-bit Microsoft Windows. Check with your DBMS vendor if the DBMS is supported on 64-bit
Microsoft Windows. ArcSDE is a 32-bit application on Linux for both Oracle and DB2. ArcSDE for Oracle on Red Hat
Linux is only supported on a 64-bit chip set if the Linux OS and Oracle DBMS are both 32-bit. ArcSDE for DB2 has
not been tested on a 64-bit Linux environment.
The existing License Manager and associated hardware key used for concurrent use licenses of ArcView, ArcEditor
and ArcInfo does not work on 64-bit machines running Windows XP Professional 64-bit. You can obtain new Sentinel
drivers and a License Manager patch that adds support for that 64-bit environment. For more information, and to get
the patch, please see ESRI Knowledge Base article 30385:
http://support.esri.com/index.cfm?fa=knowledgebase.techArticles.articleShow&d=30385

Initial support for Microsoft Windows Vista ( New in SP4 )
Starting at Service Pack 4, the following ArcGIS 9.2 products now support Vista: ArcReader, ArcView, ArcEditor,
ArcInfo Desktop, ArcGIS Desktop Extensions, ArcInfo Workstation, and ArcGIS Engine. However, there are some
serious known issues that users should be aware of before deploying any of these products on Windows Vista. In the
testing of ArcGIS 9.2 Service Pack 4 a number of issues were discovered that appear to be specific to the Windows
Vista platform. Some of these issues are known issues with Windows Vista, some are fixed in currently available
Microsoft patches, and others will be fixed by future patches available from Microsoft. For complete information about
Vista support, please be sure to read ESRI Knowledge Base article 34020:
http://support.esri.com/index.cfm?fa=knowledgebase.techArticles.articleShow&d=34020
The following products are not supported on Vista at Service Pack 4. ArcGIS Server 9.2 (including ArcSDE 9.2) Image
Server 9.2, and ArcIMS 9.2. They will be fully supported on Vista in the ArcGIS 9.3 release. ArcGIS Explorer is not yet
supported on Windows Vista and will be supported in an update available in early 2008.
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ArcGIS Desktop
Use the ArcMap viewer window to work with multiple data frames
Service Pack 2 introduces the ability to work with multiple data frames side-by-side on-screen in the same map
document. Previously, if your map document contained more than one data frame, the only way to work with the
contents of multiple data frames simultaneously was to switch to Layout view and arrange the data frames on the
layout page, or to open two or more map documents on screen.
The viewer window is a new window that was introduced at 9.2 to enable you to work with one data frame at multiple
scales. In the 9.2 release if you opened a viewer window and then activated a different data frame in your map
document, the viewer window was automatically closed. In Service Pack 2, we have enhanced viewer windows so that
you can use them to view inactive data frames. Now if you activate a different data frame while a viewer window is
open, that viewer window remains on-screen, enabling you to work with multiple data frames side by side.
In this example, a viewer window is being used to compare two data frames showing different data for the same area:

When you work with an inactive data frame in a viewer window, you can easily make the viewer show the same
location that is currently displayed in the active data frame in the main ArcMap window. Similarly, you can update the
location shown in the active data frame in the main ArcMap window to match the location shown in any of your viewer
windows. Commands in the viewer window's menu let you pan or zoom the viewer or the main ArcMap window so that
both displays show the same location:
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There are some restrictions on which operations you can perform inside a viewer window that is displaying an inactive
data frame. You can generally perform map navigation, query, and selection, but you can't edit graphics or features. If
a tool can't be used on an inactive data frame displayed in a viewer window, the cursor will change when you hover
over the viewer to show you that the tool is not available. There are no restrictions on the operations that can be
performed inside a viewer window displaying the active data frame.
In this example, four viewer windows have been arranged on-screen so that four different sources of street data for the
same area can be compared. Each viewer window is showing the contents of one data frame in the map document:
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The ability to work with multiple data frames side-by-side in ArcMap can be useful for analysis, historical change
assessment, data evaluation, and other applications where you want to be able to see different datasets for the same
area side by side, as opposed to working with all the data in one data frame, or working with multiple map documents.
In the photo below, two different map services in separate data frames in a map document are being compared for the
same location. A viewer window showing the inactive data frame has been maximized on the second monitor:

Tip: There are two shortcuts that make it easy to work with multiple data frames:
CTRL + TAB switches between the data frames making each one active in turn. (If you want to be able to do the
same thing by pressing a button on-screen, add the Activate Next Data Frame command into any toolbar from the
View category in the Tools > Customize dialog).
ALT + click on the name of a data frame in the Table Of Contents activates that data frame.
If you use the Schematics extension, you can use a viewer window to work with a schematic side-by-side with the
geography it represents without having to work in Layout view. ( See the 'Schematics' section of this document).
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Share places defined in the My Places dialog in ArcMap, ArcGlobe & ArcReader
In the dialog launched by the My Places command
in the Tools pulldown menu, you now have the option to save
a subset of your places into a separate file. In Service Pack 2, the Save button has been changed to be a menu button
containing two commands, one for saving the currently selected places, and the other for saving all the places:

By using the option to save just the selected places, you can save a subset of places as a file you can share with
others or move between different machines.

Option for rolling mouse wheel in ArcMap to scroll instead of zoom
By default, rolling the mouse wheel in ArcMap 9.2 zooms in and out. However, some users prefer the pre-9.2
behaviour where rolling the mouse wheel scrolls the map up and down. For example, some people were using ArcMap
9.1 with a mouse with a 'tilt' wheel that can be tilted from side to side in addition to being rolled forward and back,
enabling them to pan in four directions. Using a tilt wheel mouse to pan to doesn't work as expected in ArcMap at 9.2
because rolling the mouse wheel zooms instead of scrolling up and down. In 9.2 Service Pack 3, we have therefore
introduced a new registry setting that you can specify to override the default mouse wheel behaviour introduced at 9.2.
You won't see this setting in the registry after installing the service pack: You have to create the registry setting
manually yourself:
HKEY_CURRENT_USER\Software\ESRI\ArcMap\Settings\MouseWheelScroll
Giving this DWORD registry key a value of 1 tells ArcMap to scroll the map when you roll the mouse wheel. When this
registry setting has not been specified, or when it has a value of 0, rolling the mouse wheel will zoom in/out, the default
behaviour at 9.2. Behaviour involving single-clicking or holding down the mouse wheel is unaffected by this registry
setting. So irrespective of the value of this registry setting, you can still drag with the mouse wheel held down to pan,
drag and hold down CTRL to zoom to a box, single-click the mouse wheel to re-center, and CTRL+single-click to zoom
in. This registry setting is not recognized by ArcMap 9.2 prior to Service Pack 3. This registry settings is documented
in the final section of the ArcGIS Desktop Advanced Settings Registry Keys.doc document in your arcgis/utilties folder.
That document has been updated at Service Pack 3 and its final section contains information about registry settings
that are not set inside the application's user interface or in the AdvancedArcMapSettings.exe program.
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Transformations tab added back into CAD layer properties
In Service Pack 3, the Transformations tab has been fully restored to the Layer Properties dialog for CAD feature
class layers and CAD drawing layers. The tab was removed in 9.2 with the introduction of CAD support in the
Georeferencing toolbar, but this made it hard to specify certain transformations like scaling by entering the parameters.

Easier to specify proxy server information in ArcCatalog
The Tools > Options dialog Proxy Server tab has been renamed to be the Connections tab. Starting with 9.2
Service Pack 2, you use the Internet Options in the Windows Control Panel to specify proxy server and https/SSL
connection information, and ArcCatalog automatically uses these settings for all your GIS Server connections. You
only need to enter information into the Tools > Options dialog Connections tab if your proxy server requires
authentication, in which case you simply specify the user name and password in those two fields in the tab.

Measure tool units persisted between your sessions
In Service Pack 3, when you use the Measure tool
in the Tools toolbar, it now remembers the units you choose
for measuring distances and areas between your ArcMap sessions. So for example, if you choose to measure
distances in miles, this setting will be the default the next time you use the Measure tool, and you won't have to set it
again. This applies to ArcMap, ArcReader, and ArcGIS Engine applications that use the Measure tool.
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Option for setting the amount of densification for graticules ( New in SP4 )
Graticule lines have vertices added every 1 degree by default to allow the lines to bend to better fit the curvature of
the graticule. In some cases, such as large scale maps or precise data the amount of densification needs to be
increased to better fit the graticule to the data. In 9.2 Service Pack 4, we have therefore introduced a new registry
setting that you can specify to increase the amount of densification. You won't see this setting in the registry after
installing the service pack. You have to create the registry setting manually yourself.
HKEY_CURRENT_USER\Software\ESRI\ArcMap\Settings\Graticule\DensificationDistanceInDegrees

Giving this REG_SZ registry key a value of 0.1, for example, tells ArcMap to place vertices every 10th of a degree.
Valid values are from 0.01 to 5. 0.01 means the graticule gets vertices placed every 100th of a degree and can
seriously impact performance when working with a map that covers a large area, such as a world map. For this reason
we recommend that you use finer levels of densification only when you can see on the map that the graticule doesn’t
quite line up with your data. When this registry setting has not been specified, or when it has a value of 1, graticules
will appear the same as they do in 9.2. This registry setting is not recognized by ArcMap 9.2 prior to Service Pack 4.

Zoom To Layer command now respects definition queries ( New in SP4 )
When you use the Zoom To Layer command in 9.2 Service Pack 4 on a layer containing a definition query, you
now get taken to the actual extent of the data defined by that query. Previously Zoom To Layer didn't respect definition
queries and always took you to the full extent of the layer.
Similarly, when you use the Zoom To Layer command on a selection layer in 9.2 Service Pack 4, you now get taken to
the extent of the data in that selection layer. Previously zooming to the extent of a selection layer took you to the full
extent of the data source referenced by the layer and didn't take into account the subset of features represented by the
layer.
Tip: In the Table Of Contents, hold down ALT and click on the name of any layer in the active data frame to zoom to
that layer's extent. This shortcut was added in 9.2.
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ArcGIS Server
Improved documentation for ArcGIS Server
ArcGIS Server 9.2 was released with comparatively basic documentation, particularly for developers. Since the
release of ArcGIS Server 9.2, our goal has been to incrementally release more help content. We have been making a
large number of improvements and additions to the ArcGIS Server help, and continue to add new topics every week.
When you install a service pack, it updates your local ArcGIS Server documentation with the new content. But be sure
to check the documentation resources online to get the very latest material.
- For a sampling of the key topics that have been added to the ArcGIS Server documentation since 9.2, see this ESRI
KnowledgeBase article:
http://support.esri.com/index.cfm?fa=knowledgebase.documentation.viewDoc&PID=66&MetaID=1294
- ArcGIS Server Help Online at: http://support.esri.com/index.cfm?fa=knowledgebase.webHelp.agServer
- The developer documentation and examples for customizing ArcGIS Server with both .NET and Java on the ESRI
Developer Network (EDN) website:
Start page for .NET developers:
http://edndoc.esri.com/arcobjects/9.2/NET_Server_Doc/developer/getting_started.htm
Start page for Java developers:
http://edndoc.esri.com/arcobjects/9.2/Java/java/server/getting_started_oview.htm
- Check out the new ArcGIS Server Development blog. It includes tips and best practices that will help you become
more effective using and customizing ArcGIS Server: http://blogs.esri.com/Dev/blogs/arcgisserver
- We have also enhanced the topics on how to publish ArcGIS services using ArcCatalog and ArcMap in the ArcGIS
Desktop Help Online: http://webhelp.esri.com/arcgisdesktop/9.2/index.cfm?TopicName=welcome under the 'GIS
Servers and services' section.

Support for caching maps in PNG8, PNG32 and JPG formats
Service Pack 1 introduced the option to create your map cache in PNG8, PNG32, and JPG formats in addition to
the default format of PNG24. You can select the image format for your cache when you generate it in ArcCatalog. Use
the Cache Tile Format dropdown when you fill out the caching tool’s parameters.
Since Internet Explorer 6 had known limitations displaying PNG24 transparency, PNG8 may now be a better option for
caching overlay features such as boundaries and roads. The JPG format is a good way to greatly reduce the size of
your base map caches, especially if they contain raster imagery. The smaller cache tile size has more than a storage
benefit; the tiles load faster inside Web applications, providing for a more seamless navigation experience.

.NET Web ADF: Improved support for blending cached services
Prior to Service Pack 2, overlaying two cached map services in the .NET Web ADF required that both caches be
created with the exact same tiling scheme. At Service Pack 2, the criteria is less rigid: caches can be overlaid if they
have the same coordinate system, tile size, and tile origin. All scale levels do not need to match, although it’s a good
idea to match as many as possible. Also, cached map services included in the Web Mapping Application are
automatically disabled in the Table Of Contents if they have not been cached at the scale at which you are currently
viewing your map. For details about what’s required to overlay two caches, see the topic 'Overlaying map caches in
the .NET Web ADF' in the ArcGIS Server Online Help.
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.NET Web ADF: The Editor task can now edit pooled resources
Service Pack 2 contains the option to edit pooled resources inside the Editor task. When you use pooled services,
your server can support a larger number of concurrent users because the server does not have to create a dedicated
service instance for each user during his or her application session. Instead, users can share service instances from a
pool. When you configure the Editor Task, the Web ADF will determine if you are using a pooled or non-pooled service
and will provide the appropriate options for configuring the task. Pooled editing is for non-versioned geodatabases.
Your edits are committed directly to the geodatabase.

.NET Web ADF: The Editor task can now be customized
When the Editor task was released at version 9.2 of the Web ADF for the .NET Framework, a common question
was "How can I customize the Editor task?". Service Pack 2 provides an answer to this question. You can now
customize the Editor task with custom tools and Editor Panels and more events have been added that allow you to
hook into the Editor task. The ArcGIS Server Developer Help contains instructions to get you started with customizing
the task: http://edndoc.esri.com/arcobjects/9.2/NET_Server_Doc/developer/ADF/control_editortask.htm

Other ArcGIS Server enhancements
Service Pack 1 also added:
- Full support for Internet Explorer 7.
- Improved performance for ArcWeb Services, ArcGIS Services, and the display of task results.
Service Pack 2 also added:
- Client side JavaScript is now supported by the Java Web ADF.
- Improved support for Microsoft Visual Web Express.
- Support for Web ADF application deployment inside WebSphere 6.1 on UNIX platforms

Enterprise ArcSDE geodatabases: ST_Transform SQL function for Oracle
In 9.2 SP1, the ST_Transform function has been implemented for the spatial type for Oracle. ST_Transform lets you
change the ST_Geometry of a layer into a different spatial reference using SQL by specifying a Spatial Reference ID.
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ArcGIS Engine Developer kit
Engine's Add Data dialog now supports ArcSDE geodatabases
Starting with 9.2 Service Pack 2, the Add Data dialog in ArcGIS Engine supports connections to ArcSDE
geodatabases. This enables users of your ArcGIS Engine applications to connect to any ArcSDE geodatabase
(including Personal ArcSDE, Workgroup ArcSDE and Enterprise ArcSDE) to access data.
With the Geodatabases tab on the left hand side of the Add Data dialog selected, choose the 'Database Connections'
folder from the dropdown list and the two new buttons on the dialog will become enabled, the first for making an
ArcSDE connection, the other for editing the properties of an existing connection. The dialog that appears to let you
make a connection is the same one that Desktop users see when they make a connection to ArcSDE in ArcCatalog:
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Improved dynamic display capabilities
The dynamic display capabilities added in 9.2 have been considerably enhanced with Service Pack 3. With these
enhancements, pan, zoom, roaming, and tracking moving objects are much smoother in Engine applications. Dynamic
display is only available via ArcGIS Engine, which is part of the ESRI Developer Network (EDN). It can be used and
configured using ArcObjects by developers on all supported ArcGIS Engine development environments.
For updated information on implementing dynamic display, along with sample code, see the ESRI Developer
Network (EDN) SDK documentation and look under Building solutions with ArcGIS Engine using .NET > Working with
ArcGIS Components > Mapping and Visualization > Working with the map display > Dynamic Display.
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Extensions
Survey Analyst extension: New Cadastral Editor and cadastral fabric data model
The goal of the Survey Analyst extension is to improve the spatial accuracy of GIS data and to provide information
about the accuracy of this data. At 9.2 Service Pack 3 we introduce a major enhancement to this extension. With
Service Pack 3, the Survey Analyst includes the existing Survey Editor, but now also includes a new Cadastral Editor
and new cadastral fabric data model.
- The Survey Editor is the same technology as was available at 9.1. The Survey Editor includes a set of focused tools
for defining and maintaining accurately measured coordinates based on field observations from total station
equipment.
- The Cadastral Editor includes the functionality, standard data model, and common workflows you need for building
and maintaining a cadastral land records system (a cadastral fabric).
Many geographic information systems use cadastral records to build the base map for the other layers within the GIS.
Parcel and cadastral databases are built through coordinate geometry and plan data entry. The accurate coordinate
data available from new technologies and techniques can be combined with recorded land descriptions to improve
spatial accuracy in the geodatabase. The new Cadastral Editor provides a framework and data model for efficiently
performing these workflows.
The Survey Analyst product license covers both the existing Survey Editor and the new Cadastral Editor. They can
be installed separately or together, and can also be used separately or together as complementary survey
technologies. You will see the name of the editor(s) you install listed under the Survey Analyst entry in the Tools >
Extensions dialog. Checking the box next to the Survey Analyst extension in that dialog enables whichever editors
have been installed. In the example below, both editors have been installed:

The Cadastral Editor works with a new type of parcel dataset, called a cadastral fabric. A cadastral fabric is a
continuous integrated surface of connected parcels, representing the complete survey record for an area of land.
Dimensions in the cadastral fabric are edited in response to a change in the survey record, for example, a parcel split
or resurvey. Parcel boundary line dimensions in the cadastral fabric match the dimensions on the survey record.
Parcels that are edited or replaced by new survey records are retained as historic, thus always preserving the original
survey record. Parcel polygons are also linked to each other by connection lines, for example, connection lines across
roads. Because each and every parcel is either linked or connected, a seamless network of connected parcel
boundaries, or cadastral fabric, is formed. Parcel lines have endpoints, which are the parcel corners. Parcel corner
points are common between adjacent parcel boundaries, establishing connectivity and maintaining topological integrity
in the network. In the geodatabase, topology is the arrangement that defines how point, line, and polygon features
share coincident geometry.
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Cadastral fabrics are stored in feature datasets:

The cadastral fabric acts as a basemap for overlying GIS feature classes. Feature classes such as building polygons
and utility lines are constructed in relation to parcel boundaries. The result is that GIS features are correctly aligned
with the cadastral fabric.
Here are the key elements of the new cadastral technology:
- Provides a base-map for parcels as recorded by cadastral surveyors through deeds and subdivisions.
- Improves the spatial accuracy of the fabric by processing the legal record information from parcels using a least
squares algorithm designed by surveyors.
- Spatially update GIS feature layers that coincide with the fabric on demand.
- Extensible data model familiar to ArcGIS users.
- Provides a COGO coverage equivalent in the geodatabase
- Tracks the lineage of parcels based on their legal record end & start dates.
- Manage subsets of the data as cadastral jobs.
- New set of interactive tools, including parcel construction tools:
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In the Desktop Help, see: Extensions > Survey Analyst > Cadastral Editor
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Schematics extension: Work with geography and schematics side by side in ArcMap
As described above, in 9.2 Service Pack 2 the viewer windows introduced in 9.2 have been enhanced so that you
can use them to work with the contents of inactive data frames side-by-side on-screen with the active data frame
shown in the main ArcMap window. This enables you to work with a schematic diagram side-by-side with the
geography it represents without having to work in Layout view.
In the example below, two schematic diagrams have been created to represent the features in the data frame called
Geography shown in the main ArcMap window. Each schematic is in its own separate data frame displayed inside a
viewer window:

The Schematics commands and tools have been updated in Service Pack 2 so that you can use them to perform
operations on schematics displayed inside inactive data frames in viewer windows.
To work with geography and a schematic side-by-side, first activate the data frame containing the data you want to see
in a viewer window. Now choose the Viewer command from the Window pulldown menu to open a viewer window.
Finally, activate the data frame you want to work with in the main ArcMap window. The viewer window you opened will
remain on-screen, allowing you to work with both data frames. (In the Desktop Help, see: Extensions > Schematics >
Working with ArcGIS Schematics > Viewing schematic diagrams > Viewing schematic diagrams in ArcMap).
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Schematics extension: Improved diagram to feature export ( New in SP4 )
When you export a schematic diagram as shapefiles or feature classes at 9.2 Service Pack 4, it will now
automatically export all the attributes of the features. Previously it only exported a small subset of attributes for
Schematics to track internally. This allows you to link the exported diagram features back to the original geographic
features to access other field information.

Schematics extension: Additional enhancements
New layout algorithm: Geo-Partial Overlapping Links. Added in 9.2 SP3. As shown in the figure below, this new
layout algorithm is used when links are organized in a set of parallel routes and when the offsets are too small
resulting in a lack of visibility related to the scale:

Before

After

In 9.2 SP3, the Geo-Linear Dispatch layout algorithm has been enhanced by moving leaves with one link. To get
the clearest diagrams, the layout is enhanced to include the leaves having one link in the repositioning process. This
function is useful to manage secondary networks in the field of water, gas and electrical distribution:

Before

After (9.2)

After (Starting with 9.2 SP3)
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Spatial Analyst extension: Improved performance for the Combine geoprocessing tool
Beginning with Service Pack 2, the performance of the Spatial Analyst extension's Combine geoprocessing tool has
been improved so it is up to 40 times faster than before. The Combine tool, in the Spatial Analyst Tools > Local toolset,
lets you combine multiple rasters together. For example, a use of Combine on 250,000 combinations that used to take
1 hr, and now only takes 1.5 minutes. It can now also handle millions of combinations.
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