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IN THIS CHAPTER

1

Introducing ArcCatalog 1
• What can you do with ArcCatalog?

• Tips on learning ArcCatalog
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2 USING ARCCATALOG
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Browse for maps and data
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What can you do with ArcCatalog?
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Explore the data
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Thumbnails provide an overview of data in the selected folder. Explore an image before adding it to a map.
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View and create metadata
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Browse through a shapefile’s attributes.

Metadata can help you decide whether or not to use the data.
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4 USING ARCCATALOG

Use data in ArcMap and ArcToolbox
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Manage data sources
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Search for data within your area of interest.

Add an attribute to a shapefile.
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Tips on learning ArcCatalog
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Exercise 1: Building a catalog of geographic data
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Look in a folder connection
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Create a working copy of the tutorial data
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The Contents tab
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Explore the contents of the Yellowstone folder
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Exercise 2: Exploring data and adding it to a map

Large Icons Thumbnails

DetailsList
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Search for items
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Exercise 3: Managing shapefiles
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Define a shapefile’s coordinate system
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Add the vegetation type layer to the map
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Set a coverage’s coordinate system
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Exercise 4: Managing coverages
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Modify attributes in coverages and INFO tables
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Create a layer using the related attributes

)����
����
��
��������
����
��!�������
�����
��
�����
�����
����
����!������������"��F���
��
!����
�<�������
!����
��
���!
��%������"����
��
���
"��
��&����
������

-� 	��������� ���
���
����
������������	
�
�
�������

.� 	���������������������
�����
�3���������������;
����

/� +����
��
����
�������
���������
��9"����
��
������:�

0� 	���������6�
����!���
����
"��
����
����� ���
���
��
�
����������������"����
��
���
"��
�������������������

?� 	�������
������
��"���
����
���������������)G�����
��"�
�
���
���������
���
������������������
�����"���
����
�
"����
�����
��������� ���
���
����
�����

B� �����#����������"����
��
��������
����
���������4�
���#
�����

ArcInfo

Ch02.p65 02/06/2001, 11:23 AM41



42 USING ARCCATALOG

C� 	���������V
����W����
�����
!��������;
����4�
�������
��
�
��!
$�

D� 	�������������!���
����$���
�����V
���������

E� 	�����������������
��
���
��
���
�����������
���
�
�
����
�'
����
�������
����������������V
����
�
�!
����
��

��������������
��
��������
���

-I� 	�����)G��������V
���8
�
���
�
��!
$��+���"��F���

�
!������
������
����������
���
!������
���
"��!����'
����
�
������
"��
���

--� 	������������!
�
����
!�

-.� 	�����	
���
��������������
�������

-/� 	���������1
������������
��
���
��
��
��������
"��F���
>+ 4��

-0� 	���������	
�
�����������
��
���
��
��
���������

�����������
�
���
������������������

-?� 	�������������1
�����

+
���
���������
�
��
������"���
��"
����K�
���$
�����
�
��
��������
�����
���
���!���K�
�!��#���������
�
����
���
�
���
����������
������"
������������������
��

��������
�
�������������!
��������
����
�
��!
$�
��
������)G�

-B� 	�����)G��������;
����4�
����������
�
��!
$�

+���"����
��
��������
����'
����
����!������������"��F���

�
!����
������
���
����������"����
��
���
"��
��������
���
��
��
����
������"����
��
�F
����!��������
��
�����
��
����+�����������!
��%�������������������
!��&��"
��������
����������������
��������
�������������
���
"
��
!��
���
���
�������������
��
�

ArcInfo

Ch02.p65 02/06/2001, 11:23 AM42



QUICK-START TUTORIAL 43

Add the vegetation type layer to the map
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Starting
ArcCatalog
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1. Click the Start button on the
Windows taskbar.

2. Point to Programs.

3. Point to ArcGIS.

4. Click ArcCatalog.

Tip

Starting ArcCatalog from
ArcMap
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The ArcCatalog window

The title bar displays the
selected item’s location.

The Catalog tree
lets you access all

of the Catalog’s
contents. Select an

item in the tree to
view its contents.

The status bar describes what a button
or menu command does and also

reports on which items are selected.

Move this bar to resize
the Catalog tree.

Each tab displays
the contents of the
selected item in a
different way.
Within each tab,
several different
views let you
change how you
see the selected
item’s contents.

Click the buttons on the active
toolbars to explore the current view.
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Browsing through
the Catalog
#�
������ ���
���� ��
������

�����������������
����������
���������
������

 �����
�
�
�����������
���
�
��������
���������������������$��������
�
����������������������������������
�����
���������������������
������
���������
����������

�����%����"�����
������
����
�����������������
�����������
�
�����������������������������


��������#���������������&�����
'
������
�� ����
���
��
 ���
������
��
���(��
 �������
�
����������������������
���
�
���
������
�������������
��������
������������
��������$���&��!��
)���������
��
��������������
�

���������
�������������������
������������
���������������
���

�
������������������
���������
���
�
�������

�������������
�����
�
�����
��������
�����

������*�
�
����������������
����
����������
�������+���������
�����������
�
��������������
������,
��
��
��������
��������������������
���
�����
�������
�������

���������
����
����������
�����������
�����
��������
��
 ��������-���
������ �����
��
 ����.�������

"���� �
��  �
�� ���
�������
�
������
��������
��
� ���������
������������

�����������(��
 ����

����
�������������������������������
��
���������
�������������
�����

Selecting items in the
Catalog tree and the
Contents list

1. Click the Contents tab.

2. Click an item in the Catalog
tree that contains a subset of
items (such as a folder or
feature dataset).

The items it contains are
listed in the Contents tab.

3. Double-click an item in the
Contents list that contains a
subset of items.

The items it contains are
listed in the Contents tab.

4. Double-click an item that
contains a subset of items in
the Catalog tree.

The items it contains are
listed in the Catalog tree.

5. Double-click an item that
does not contain other items
(such as a shapefile or table)
either in the Contents list or in
the Catalog tree.

Maps open in ArcMap, and
XML documents and file
types open in the appropriate
application. A Properties
dialog box will appear for all
other items.

6. Click an item that doesn’t
contain other items in the
Catalog tree.

Its properties and thumbnail
are listed in the Contents tab.
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Selecting an item by
typing its path

1. Type the path to the item you
want to select in the Location
text box.

2. Press Enter.

The Catalog tree expands to
show the item you’ve se-
lected. Or a new folder
connection is added to the
Catalog and it is selected in
the Catalog tree.

�

The Catalog tree expands to
show the selected item.

Moving up the Catalog
tree

1. Click the Up One Level
button.

The next item up in the
Catalog tree’s hierarchy is
selected.

Tip

Selecting a path from the
Location list
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The next item up in the
heirarchy is selected; if
Hydrants was selected
before, Water would be
selected after clicking the
Up One Level button.
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Making it easier to find
geographic data on disk

1. Click the Tools menu and
click Options.

2. Click the General tab.

3. Check Use a special icon for
folders containing GIS data.

4. Click OK.

Folders that directly contain
GIS data will have a special
folder icon to make your data
easier to find.
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With the option turned on,
folders that directly contain
GIS data have a different
appearance.

By default, all folders have
the same appearance.

Tip

Returning to your last
location
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Tip

Hiding file extensions
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Repositioning the
Catalog tree
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Undocking the Catalog
tree

1. Click and drag the bar at the
top of the Catalog tree with
your mouse pointer to a
location outside the
ArcCatalog window.

A rectangle with a thick line
indicates where the Catalog
tree will be placed.

2. Drop the panel.

The Catalog tree is floating
on the desktop but is still
working with the application.

Tip

Moving the Catalog tree
without docking it
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The Catalog tree is floating on
the desktop.
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Hiding and showing the
Catalog tree

1. Click the Close button on the
bar at the top of the Catalog
tree to hide it.

The Catalog tree no longer
appears in the ArcCatalog
window.

2. Click the View menu and
check Catalog tree to show it
again.

�

The Catalog tree no longer appears in
the ArcCatalog window.
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Getting help
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Getting help in the
ArcCatalog window

1. Click the What’s This? button
on the Standard toolbar.

2. Click the Help pointer on the
element in the ArcCatalog
window you want to learn
more about.

3. Click anywhere on the screen
to close the Help description
box.

Getting help in a dialog
box

1. Click the What’s This? button
on the upper-right corner of
the dialog box.

2. Click the Help pointer on the
element in the dialog box you
want to learn more about.

3. Click anywhere on the
screen to close the Help
description box.

� �

The Help description box shows information about the button.
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Using the Contents tab to
get help

1. Click the Help menu and click
ArcGIS Help.

2. Click the Contents tab.

3. Click the plus sign next to a
book to see a list of topics in
it.

4. Click the topic you want to
read.

5. View the topic in the topic
pane on the right.

6. Click the minus sign next to a
book to close it.
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Tip

Working with Help topics
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Using the Index tab to get
help

1. Click the Help menu and click
ArcGIS Help.

2. Click the Index tab.

3. In the text box, type one or
more keywords representing
the topic you want to find.

4. Click the keyword that
interests you from the list
below, then click Display.

5. If several topics are related to
the keyword you selected, the
Topics Found dialog box
appears. Click the keyword
that interests you and click
Display.

6. View the topic in the topic
pane on the right.

�
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Finding Help topics
containing specific words

1. Click the Help menu and click
ArcGIS Help.

2. Click the Search tab.

3. Type the word or words that
should be contained in the
topics you want to find.

Your word expression may
include an asterisk (*) to
represent several characters,
or a question mark (?) to
represent one character. It
may also use Boolean
operators such as AND, OR,
NOT, and NEAR.

4. Click List Topics.

5. Double-click the topic you’re
interested in.

6. View the topic in the topic
pane on the right.

The word or words you
specified are highlighted in
the topic.
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Tip

Searching for words within
a topic
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Stopping
ArcCatalog
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1. Click the Close button in the
ArcCatalog window. �
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59

What’s in the Catalog? 4
• Folders and file types

• Maps, layers, and graphs

• Shapefiles, dBASE tables, and
text files

• Coverages and INFO tables

• Geodatabases

• Raster and TIN datasets

• CAD drawings

• VPF data

• XML documents

• Internet servers

• Geocoding services

• Search results

• Coordinate systems
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Folders and file types

�������
��-������	��������%��������!��
�	�>�/������-��	
�!
���
������	�
������
��������
�	���	������������	������������	���
�����

��!���	
:%����	�����	��	�8��
���
�����������	�>���
������!�8�
�	
����	�����
����������
����	��
��-������
�����
���	
���%���������
�
!.���	���	������	�����	�����
�8>�9	��%��-��
�����
��	��
	���	

�
��������
�����������������������
�����������	�����������	�8>

��������	�����	������	����������������	
�!������2���.���
�	�����
	��-�*�	�	�
���'��%
���-��	�����
	����	�/�������
'��%���-�����'������)��
���>���	������	������	��!����
��
�		��
�����'����!��
���
�����.������
��>������������
��
�����
�
������������
��������
�������������>�?	
������
����������	������
�
�	
��	�:��
������!>

����������
!���	
���������������	�-����	!�
����	����������	�8-��
����.���-�	�����/�����������%���!���.��
��%�
��.��>�������	

�������
���������G�:�	������
�	���	���	
���	����-�����.���-�	��/�������
���%����	�����
	�-�
��
���
��	�������H�
��
���	
���	�����
	��
�
������.�
����-����
�������
��
�������
.��>

Folders represent folders on disk.

Folders containing geographic data may have a different appearance.

Folder connections let you access data on local and networked disks.

File types are files whose extensions have been added to the Catalog.

Folder connections are unavailable when their icon shows a little red ‘x’.
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Maps, layers, and graphs
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Layers include shortcuts to geographic data and symbology.

Map documents are printed maps stored on disk.

Group layers combine several layers but have one entry when added to a map.

Map templates let you create a series of maps with the same layout.

Graphs give you a dynamic view that compares the attributes of selected features.
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Shapefiles, dBASE tables, and text files
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dBASE tables may also contain geographic data or attributes describing geographic features.

Shapefiles represent geographic features as points, lines, or polygons (areas) and their
attributes.

File types are files whose extensions have been added to the Catalog. A file type for an
ArcView GIS 3 project has the extension .apr.

Text files may contain feature attributes. All text files appear in the Catalog even though only
some may contain tabular data.
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Coverages and INFO tables
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ArcInfo coverages represent geographic features using several feature classes.

Coverage feature classes contain points, lines (arcs), polygons, or annotation (text); they may
also have attributes.

You can add a file type to the Catalog for accessing AMLs.

PC ARC/INFO coverages represent geographic features using several feature classes.

INFO tables may contain attributes that can be joined to a feature class.

A relationship class defines the association between a coverage and an INFO table.
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Geodatabases
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Creating and accessing geodatabases
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Personal geodatabases let you manage your own data.

Objects in a database are owned by the user who created them; these feature classes
are owned by the user named “admin”.

Feature datasets contain a collection of feature classes that share the same coordinate
system and whose features are located in the same geographic area.

Tables may contain geographic data or attributes of geographic features.

Geometric networks establish topological relationships among several feature classes
that together form a linear network.

Relationship classes define the association between two items in a geodatabase.

Wizards let you create database connections.

Database connections let you use data stored in a central database; the data is retrieved
using ArcSDE or an OLE DB provider.

Feature classes can contain points, lines, polygons, annotation, or dimensions.
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Raster and TIN datasets
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Raster datasets contain a rectangular grid of data cells. By showing file extensions, a
raster’s format is apparent.

A raster dataset can contain one or more raster bands.

TIN datasets can be used as an alternative to rasters when representing surfaces.

Raster catalogs appear as tables, but you can see them in Geography view.

Raster datasets can also be stored in ArcSDE geodatabases.
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CAD drawings
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A CAD feature class contains all points, lines, polygons, or annotation in the drawing.

The CAD dataset represents a drawing’s features with individual feature classes.

Tables can contain additional feature attributes.

The CAD drawing lets you draw all features using the symbology stored in the drawing.

With a layer file created from a CAD drawing, as opposed to a CAD feature class, you can choose
which features you want to draw.
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VPF data
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A database contains one folder for each VPF library, which in turn contains one folder for each coverage.
Tables describing a library or a coverage can be found in its folder.

A connection to a folder that is a VPF database.

There are many VPF coverages in each library; the coverage’s name follows the library’s name.

A VPF feature class contains a set of points, lines, polygons, or annotation and their attributes.

VPF tables describe the contents of databases, libraries, coverages, and feature classes. The tables that
reside in the database’s folder describe the database’s contents. Tables describing other items in the VPF
database reside in the appropriate folder.
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XML documents
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XML documents contain structured data defined with custom tags.
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Internet servers
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The Internet Servers folder lets you manage connections to Internet servers.

ArcIMS Internet Servers provide access to many services.

An ArcIMS Image Service is a raster representation of a complete map.

An ArcIMS Feature Service provides access to vector data.

You can work with ArcIMS Feature Classes in the same manner as other vector data sources.
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Geocoding services
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Geocoding services let you create spatial features from textual information that
describes a geographic location such as an address.

Geocoding services can reside either on your computer or in an ArcSDE
geodatabase.

The Geocoding Services folder lets you manage existing geocoding services on your
computer as well as create new ones.
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Search results
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The Search Results folder contains your previous searches.

Each search represents a set of criteria defining the data you want to find.

A search’s results consist of shortcuts to items that satisfy the search criteria.
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Coordinate systems
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You can place your custom coordinate systems within the Coordinate Systems folder.

The Coordinate Systems folder lets you manage coordinate system files; this folder is
hidden in the Catalog tree by default.

A coordinate system defines how feature coordinates relate to the earth’s surface.

Many commonly used coordinate systems are provided with ArcCatalog; you’ll find them in
the Geographic and Projected Coordinate Systems folders.
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Adding folder
connections
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Connecting to a folder

1. Click the Connect To Folder
button.

2. Navigate to the folder or disk
that you want to add to the
Catalog.

3. Click OK.

A new folder connection
appears in the Catalog tree.

�

�

Disconnecting from a
folder

1. Click the folder connection
that you want to remove from
the Catalog.

2. Click the Disconnect From
Folder button.

The folder connection is
removed from the Catalog
tree.

�

�

�

A new folder
connection appears in
the Catalog tree.
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Connecting to a spatial
database

1. Click the Database Connec-
tions folder in the Catalog
tree.

2. Double-click Add Spatial
Database Connection.

3. Type the name or IP address
of the server to which you
want to connect.

4. Type the name or port
number of the service to
which you want to connect.

5. If the data is stored in a
Sybase®, SQL Server™, IBM
DB2, or Informix RDBMS,
type the name of the data-
base to which you want to
connect.

If the data is stored in
another RDBMS, skip this
step.

6. Type your username and
password for accessing the
data.

7. Click Test Connection.

If the test was successful, the
button becomes unavailable.
If the test fails, you won’t be
able to retrieve data until
you’ve provided the correct
information or the database
problem has been resolved.

8. Uncheck Save Name/
Password if you don’t want �

�

�

	

�

�

�

Adding spatial
database
connections
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Connecting to a specific
version of the database

1. Follow steps 1 through 8 for
connecting to a spatial
database.

You must provide complete
connection information for the
database including your
username and password.

2. Click Change.

3. Click the Version dropdown
arrow and click the version of
the database that you want to
access.

4. Click OK.

5. Uncheck Save Version if you
don’t want to connect to the
same version of the database
each time.

6. Click OK.

7. Type a new name for the
database connection.

8. Press Enter.
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this information saved with
the connection.

9. Click OK.

10. Type a new name for the
database connection.

11. Press Enter.
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Adding OLE DB
connections
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1. Double-click Database
Connections in the Catalog
tree.

2. Double-click Add OLE DB
Connection.

3. Click the OLE DB provider
you want to use for accessing
data.

4. Click Next or click the
Connection tab.

5. Provide the required connec-
tion information.

The Connection tab is
different for each provider;
most require that you identify
the database to which you
want to connect and type
your username and pass-
word. Click the Help button
for assistance.

6. Click Test Connection.

7. Click OK if the connection
test was successful.

8. Type a new name for the
connection.

9. Press Enter.
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Connecting to a database

1. Click the database connec-
tion you want to use.

2. If your login information isn’t
saved with the database
connection, a login dialog box
will appear. Type the required
information, then click OK.

The red ‘x’ disappears from
the database connection’s
icon.
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Working with
database
connections
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When connected,
a database
connection’s icon
doesn’t have a
red ‘x’.

Disconnecting from a
database

1. Right-click the database
connection that you want to
disconnect.

2. Click Disconnect.

A red ‘x’ appears on the
database connection’s icon.

�
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Repairing a database
connection

1. Right-click the database
connection you want to fix
and click Connection Proper-
ties.

The appropriate dialog box
appears for spatial or OLE
DB database connections.

2. Change the connection
properties. For example,
change your username and
password.

3. Click OK.
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Tip

Working with Internet
servers
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Connecting to
Internet servers
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Adding an Internet server

1. Double-click Internet Servers
and double-click Add Internet
Server.

2. Type the URL of the Internet
server to which you want to
connect. For example, type
“http://
www.geographynetwork.com”.

3. If you don’t want to connect
to all services, click Just the
following service(s) and click
Get List. A list of all services
that are freely available on
the server appears below,
and Get List is dimmed out.
Check the services you want
to use.

4. Click OK.

5. Type a new name for the
Internet server.

6. Press Enter.

�
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Accessing secure
services

1. Double-click Internet Servers
and double-click Add Internet
Server.

2. Type the URL of the Internet
server to which you want to
connect.

3. Check Show secure services.

4. Type the username and
password for accessing the
secure services that are
available to you.

5. If you don’t want to connect to
all services, click Just the
following service(s) and click
Get List.

The list of services that
appears below includes all
free services provided by the
Internet server as well as the
secure services that you have
permission to access.

6. Check the services you want
to use.

Uncheck the services you
don’t want to use.

7. Click OK.

8. Type a new name for the
Internet server.

9. Press Enter.
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Hiding folders
and items
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1. Click the Tools menu and
click Options.

2. Click the General tab.

3. Uncheck the items and
folders you want to hide in the
Catalog.

Check the items and folders
you want to show in the
Catalog.

4. Click OK.

�
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Changing an
item’s properties
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1. Click the Tools menu and
click Options.

2. Click the General tab.

3. Click the item whose proper-
ties you want to change.

4. Click Properties.

5. Modify the appropriate
properties for this item.

6. Click OK.

7. Click OK.
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�

Choosing which
raster formats
appear in the
Catalog
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Displaying specific raster
formats

1. Click the Tools menu and
click Options.

2. Click the Raster tab.

3. Click the option to Search
only files that match the
following file extensions to
find valid raster formats.

4. Uncheck the formats you
don’t want to see as rasters in
the Catalog.

Check the formats you want
to see in the Catalog.

5. Click OK.

�

�

Displaying all raster
formats

1. Click the Tools menu and
click Options.

2. Click the Raster tab.

3. Click Search all files to find
valid raster formats.

4. Click OK.

�
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Changing a raster
format’s file extensions

1. Click the Tools menu and
click Options.

2. Click the Raster tab.

3. Scroll down until you see the
appropriate raster format in
the list.

4. Click in the File Extensions
column to the right of the
raster format’s name.

5. Move the cursor to the end of
the file extensions list.

6. Type a semicolon (;) and then
type the letters that comprise
the file extension.

For example, if you add the
file extension “jpeg” into the
File Extensions column to the
right of JFIF (JPEG), both
.jpg and .jpeg files will be
recognized as JFIF images in
ArcCatalog.

7. Press Return.

8. Click OK.
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Adding file types
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Defining a file type

1. Click the Tools menu and
click Options.

2. Click the File Types tab.

3. Click New Type.

4. Type the file extension.

5. Type a description of the new
file type.

6. Click Change Icon.

7. Click an icon.

Or click Browse, then
navigate to and click the
application whose icon you
want to use for the file type,
and click Open.

8. Click OK in the Change Icon
dialog box.

9. Click OK.

The new file type is added to
the list.

10. Click OK.
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Importing a file type

1. Click the Tools menu and
click Options.

2. Click the File Types tab.

3. Click New Type.

4. Click Import File Type From
Registry.

5. Scroll down until you see the
file type you want to use and
click it in the list.

6. Click OK.

The file type’s properties
appear in the File Type dialog
box.

7. Click OK.

The file type is added to the
list.

8. Click OK.
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Tip

Editing a file type
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The file type is
added to the
list.
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• Viewing an item’s contents

• Working in Details view

• Changing the columns you see

• Exploring an item’s properties

• Organizing your data

• Converting data to a different
format
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Managing the Catalog’s contents
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Listing an item’s contents
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Large Icons view
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Viewing an item’s contents

List view
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Large Icons Thumbnails
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Details view
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Thumbnails view
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Viewing the contents of individual items
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Working in
Details view
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Changing a column’s
width

1. Click the item whose contents
you want to list in the Catalog
tree.

2. Click the Contents tab.

3. Click the Details button on the
Standard toolbar.

4. Position the mouse over the
edge of the column you want
to resize.

The pointer’s icon changes.

5. Drag the column’s edge to
the desired width and drop it.

The column is resized.

�

The column has
been resized.
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Sorting the Contents list
by a property

1. Click the item whose contents
you want to list in the Catalog
tree.

2. Click the Contents tab.

3. Click the Details button on the
Standard toolbar.

4. Click the heading of the
column whose values will be
used to sort the list.

The first time you click the
column heading, its values
are sorted in ascending order.

5. Click the column heading
again to sort the list in
descending order.

�

The Contents list is sorted
by the property’s values.
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Changing the
columns you see
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Showing and hiding
standard and metadata
columns

1. Click the Tools menu and
click Options.

2. Click the Contents tab.

3. Check the properties and
metadata elements you want
to show in Details view.

Uncheck the properties and
metadata elements you want
to hide in Details view.

4. Click OK.

All the checked properties
and metadata elements
appear in Details view and
Individual Item view.

�

The checked properties and metadata
elements appear in Details view and
Individual Item view.

�
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Adding columns to the
list

1. Click the Tools menu and
click Options.

2. Click the Contents tab.

3. Under the list of standard or
metadata columns, click Add.

4. In the Caption text box, type
the column name as it should
appear in Details view. In the
Property text box, type the
name of the property or the
metadata element’s path.

Or click the Caption or
Property dropdown arrow and
click the property or metadata
element that you want to add
to the list.

5. If you wish, type an appropri-
ate default width for this
column in pixels.

6. Click OK.

The new column is added to
the bottom of the appropriate
list.

7. Click OK.

�

�

	

�

The new column is added to
the appropriate list.
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Removing columns

1. Click the Tools menu and
click Options.

2. Click the Contents tab.

3. Click the column that you
want to remove from the list.

4. Click Remove.

The column no longer
appears in the list.

5. Click OK.

�

�

�

Rearranging columns

1. Click the Tools menu and
click Options.

2. Click the Contents tab.

3. Click the property or
metadata column whose
position you want to change
in the list.

4. Click the Up and Down
arrows to change the
column’s position.

5. Click OK.

�

�

Tip

Changing the order of
columns
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1. Right-click the item whose
properties you want to see.

2. Click Properties.

3. Examine the properties using
the tabs and buttons in the
Properties dialog box.

4. Click Cancel to dismiss the
Properties dialog box.

�

�

Exploring an
item’s properties
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Organizing your
data
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Creating a new folder

1. Click the folder connection or
folder in which you want to
create a new folder.

2. Click the File menu.

3. Point to New and click Folder.

4. Type a new name for the
folder.

5. Press Enter.

�

�

Creating a new personal
geodatabase

1. Click the folder connection or
folder in which you want to
create a new personal
geodatabase.

2. Click the File menu.

3. Point to New and click
Personal Geodatabase.

4. Type a new name for the
personal geodatabase.

5. Press Enter.

�

�
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Copying an item

1. Click the item you want to
copy.

2. Click the Copy button.

3. Click the folder or
geodatabase to which you
want to copy the item.

4. Click the Paste button.

� �

Renaming an item

1. Click the item you want to
rename.

2. Click File and click Rename.

3. Type the new name.

4. Press Enter.

Deleting an item

1. Click the item you want to
delete.

2. Click the Delete button.

�

�

�

Tip

Renaming coverage feature
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Converting data to a different format
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Click Change
Settings to set
which attributes
are exported from
the selected table.
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Previewing an item’s geographic data

Full ExtentZoom Out

Zoom In Pan Identify

Create Thumbnail
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Zooming in on a data
source

1. Click the Zoom In button on
the Geography toolbar.

2. Drag a box over an area to
see it in detail or click an area
to center it in the display; it
will zoom in by 10 percent.

After you zoom in, the scale
of the displayed features is
larger.

Exploring
geographic data
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Zooming out
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The scale of the geographic data is larger.
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Stop drawing
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Panning around a data
source

1. Click the Pan button on the
Geography toolbar.

2. Drag the geographic data in
the display and drop it in a
new location.

After panning, you’ll see the
features in a new geographic
area.

� �Tip

Seeing the entire dataset
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The display now shows data
in a new geographic area.
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Identifying geographic
data

1. Click the Identify button on
the Geography toolbar.

2. Click the feature, raster cell,
or TIN triangle whose
attributes you want to see.

The feature flashes or the cell
or triangle is singled out, and
its attributes appear in the
Identify Results window.

�

The attributes of the feature, raster
cell, or triangle appear in the
Identify Results window.

�
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1. In the Catalog tree, click the
layer for which you want to
create a thumbnail.

2. Click the Preview tab.

3. Click the Preview dropdown
arrow on the Preview tab and
click Geography.

4. Click the Zoom In button on
the Geography toolbar and
zoom to the area that best
represents the layer’s
contents.

5. Click the Create Thumbnail
button.
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Creating
thumbnails
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Changing raster
previewing
properties
������	
����%
������
����B
.������������������-�����%��
��	�
����������
��������������	�	��	�
��������	�������������
���	�
��������>�������	
����%
����
!
��
.������������������-������
	��
���.����������	!.
�����	
�	�!����	!�	�
���
!���-�
�
��
��������.�����
���
����
����
�������-������-�	��.�
���
�����
%��
�>�+�	!�����)��������.�
�
����1��
	����
��	��.	�-��	
����
��		�����
���.�����
�����	%
��
��
���%��
�>�?	
���������
����
�
������������	������
���-
!���
���.������	����-������-
����.�
��C)*�D��
������%��
��
�	������������
���������	��!	��
.����>

1. Click the Tools menu and
click Options.

2. Click the Raster tab.

3. Under 3 band data source,
type the number of the band
that will provide the red
display values.

Type the number of the band
that will provide the green
values.

Type the number of the band
that will provide the blue
values.

4. Repeat step 3 for raster
datasets with four or more
bands.

5. Click OK.

�

��
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1. Click the Tools menu and
click Options.

2. Click the Raster tab.

3. Click the appropriate choice
describing when pyramids
should be created.

4. Click OK.

Creating raster
pyramids
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• Previewing the values in a table

• Changing how tables look

• Calculating statistics

• Sorting records in a table

• Finding values in a table

• Adding and deleting columns

• Creating new data sources from
the values in a table
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Exploring the values in a table
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Previewing the values in a table
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Current Record
button

Beginning of table
Total records in the table. An asterisk means
the total hasn’t yet been determined.

Previous record

Type a number in the Current
Record text box and press Enter to

make it the current record. The
number of the first record is zero.

End of table

Next record

From the Options menu
you can reload the
table’s values.

By default, an asterisk
next to the column
name indicates the
values in that column
are indexed.
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Setting the font, highlight
color, and index
character

1. Click the Tools menu and
click Options.

2. Click the Tables tab.

3. Click the Selection color
dropdown arrow. In the color
palette, click the color you
prefer to use for selected
columns.

4. Click the Table Font
dropdown arrow and click the
font you prefer. Type the font
size you want to use or pick a
size from the dropdown list. If
you want to set the font’s
color, click the font color
dropdown arrow and click the
text color you prefer.

5. Type the character to use
when indicating whether or
not a column has an index
associated with it. Uncheck
Show index fields with if you
prefer not to see which
columns are indexed.

6. Click OK.

The appearance of all tables
in the Catalog will change
according to the settings in
the Options dialog box.

Changing how
tables look
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The appearance of all tables changes
according to the settings in the Options
dialog box.
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Changing a column’s
width

1. Position the mouse over the
right edge of the column you
want to resize.

The pointer’s icon changes.

2. Drag the column’s edge to
the desired width.

A black line indicates where
the right edge of the column
will be located.

3. Drop the edge of the column.

The column is resized.
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The column has been resized.
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Repositioning a table’s
columns

1. Click the heading of the
column you want to move.

2. Click the column’s heading
again, but hold down the
mouse button.

The pointer’s icon changes.

3. Drag the column heading to
where you want the column to
appear.

A red line indicates where the
column will be located.

4. Drop the column.

The column appears in the
new position.

��

The column has been moved
to a new position.
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Freezing a column

1. Press the Ctrl key on the
keyboard and click the
headings of the columns that
you want to freeze.

2. Right-click the heading of one
of the selected columns and
click Freeze/Unfreeze
Column.

The columns are frozen.

�

The column has been frozen.

Tip

Unfreezing columns
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1. Right-click the heading of a
column that contains numeric
data.

2. Click Statistics.

In the Statistics dialog box,
you’ll see information about
the values in the column
whose heading you clicked.

3. If you want to see statistics
for another numeric column,
click the Field dropdown
arrow and click the column’s
name.

4. Click the Close button when
you are finished exploring the
statistics.

Calculating
statistics
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Sorting records by one
column

1. Click the heading of the
column whose values you
want to use to sort the
records.

2. Right-click the selected
column’s heading and click
Sort Ascending or Sort
Descending.

The table’s records are
sorted.

�

The records have been sorted
according to the selected
column’s values.

Sorting records in
a table
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Sorting records by more
than one column

1. Rearrange the table’s
columns so that the column
whose values will be used to
sort the records first appears
to the left of the column
whose values will be used
second, and so on.

2. Click the heading of the first
column you want to use to
sort the records.

3. Press the Ctrl key on the
keyboard and click the
second column’s heading.

4. Repeat step 3 until all
columns that will be used to
sort the table’s records have
been selected.

5. Right-click the heading of one
of the selected columns and
click Sort Ascending or Sort
Descending.

The table’s records are
sorted.
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Selecting adjacent col-
umns
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The records have been sorted first by
the left column’s values and then by the
right column’s values.
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Finding text in a column

1. Click the heading of the
column that contains the text
for which you want to search.

2. Click Options and click Find.

3. Type the text you want to find
in the Find what text box.

4. Click Find Next.

The first record found
containing your text is
selected.

5. If you want to find another
record containing the same
text, click Find Next again.

6. Repeat step 5 until you are
finished looking for values in
the table.

7. Click Cancel.

Finding values in
a table
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The first record found containing
your text is selected.

�

Ch08.p65 02/06/2001, 12:36 PM122



EXPLORING THE VALUES IN A TABLE 123

Finding text in any
column in the table

1. Click Options and click Find.

2. Type the text you are looking
for in the Find what text box.

3. Uncheck Search Only
Selected Field(s).

4. Click Find Next.

The first record found which
contains your text is selected.

5. If you want to find another
record containing the same
text, click Find Next again.

6. Repeat step 5 until you are
finished looking for values in
the table.

7. Click Cancel.
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Matching the case
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The first record found containing
your text is selected.
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124 USING ARCCATALOG

Adding a column to a
table

1. Click Options and click Add
Field.

2. Type the name of the new
column.

3. Click the Type dropdown
arrow and click the appropri-
ate data type for the new
column.

The properties that are
appropriate to the new
column’s data type appear in
the Field Properties list
below.

4. Set the properties for the new
column. For example, type
the maximum number of
characters that Text values
can have.

5. Click OK.

The new column appears to
the right of all other columns
in the table.

Adding and
deleting columns
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The new column appears to the right of
all other columns in the table.
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Deleting a column from a
table

1. Click the heading of the
column that you want to
delete.

2. Right-click the selected
column’s heading and click
Delete Field.

A warning message appears
indicating that deleting
columns cannot be undone.

3. Click Yes to delete the
column.

The column is removed from
the table.

�

The column is removed
from the table.
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Exporting records

1. Click Options and click
Export.

2. In the Export Data dialog box,
click the Browse button.

3. Click the Save as type
dropdown arrow and click the
format to which you want to
export the data. For example,
click Personal Geodatabase
tables.

4. Navigate to the folder or
geodatabase in which you
want to place the exported
data.

5. Type a name for the new data
source.

6. Click Save.

7. Click OK.

Creating new
data sources
from the values in
a table
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Creating point features
from coordinate values

1. Right-click a table in the
Catalog tree that has col-
umns containing x,y coordi-
nates. The table may also
have a column containing
z-coordinates.

2. Point to Create Feature Class
and click From XY Table.

3. Click the X Field dropdown
arrow and click the name of
the column that contains the
x-coordinates.

4. Click the Y Field dropdown
arrow and click the name of
the column that contains the
y-coordinates.

5. If appropriate, click the Z
Field dropdown arrow and
click the name of the column
that contains the z-coordi-
nates.

6. Click Spatial Reference of
Input Coordinates to define
the coordinate system for the
input values.

7. Follow the steps for ‘Defining
a shapefile’s coordinate
system’ in Chapter 12 to
define the spatial reference of
the coordinates.

8. Click the Browse button. �
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128 USING ARCCATALOG

9. Click the Save as type
dropdown arrow and click the
format in which to create the
new point features. For
example, click Shapefile.

10. Navigate to the folder or
geodatabase in which you
want to store the new
features.

11. Type a name for the new
data source.

12. Click Save.

13. If the output features should
have a different coordinate
system from the input values,
click Output Geometry.

Otherwise, skip to step 16.

14. Click the ellipses (...) button
to the right of the Spatial
Reference property and
define the spatial reference
of the output features.

15. Click OK, then click OK in the
Define Output Geometry
dialog box.

16. Click OK.

A new point data source is
created in the appropriate
location.

�

�

�

A new point shapefile is
created in the folder.
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130 USING ARCCATALOG

1. Click the item in the Catalog
tree for which you want to see
metadata.

2. Click the Metadata tab.

3. Click a tab on the metadata
page to see a different group
of metadata elements.

4. Click a group heading to hide
its contents.

Click the heading again to
show its contents.
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Exploring an
item’s metadata
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WORKING WITH METADATA 131

Changing the current
stylesheet

1. Click the Stylesheet
dropdown arrow on the
Metadata toolbar and click a
different stylesheet.

The metadata’s appearance
changes according to the
rules of the new stylesheet.

�

The metadata’s appearance changes
according to the new stylesheet’s rules.

Changing the
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Setting the default
stylesheet

1. Click the Tools menu and
click Options.

2. Click the Metadata tab.

3. Click the Default Stylesheet
dropdown arrow and click the
stylesheet that should be the
default.

4. Click OK.

The next time you start
ArcCatalog, the stylesheet
you’ve chosen will be used
as the default.
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Writing documentation
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The ESRI profile of the FGDC standard
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How metadata is stored
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Metadata for folders and geodatabases
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Defining when
metadata is
created and
updated
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Choosing how metadata
is created and updated

1. Click the Tools menu and
click Options.

2. Click the Metadata tab.

3. Check the appropriate boxes
to have the Catalog automati-
cally create or update
metadata.

Uncheck the appropriate
boxes if you prefer to manu-
ally create or update
metadata.

4. Click OK.
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136 USING ARCCATALOG

Turning off automatic
updates for individual
items

1. In the Catalog tree, click the
item for which metadata
should not be updated
automatically.

2. Click the Metadata tab.

3. Click the Metadata Properties
button on the Metadata
toolbar.

4. Click the Options tab.

5. Check Do not automatically
update metadata.

6. Click OK.

	

�

Creating and updating
metadata manually

1. In the Catalog tree, click the
item whose metadata you
want to create or update.

2. Click the Metadata tab.

3. Click the Create/Update
Metadata button on the
Metadata toolbar.
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Editing metadata
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�Adding documentation

1. Click the item whose
metadata you want to edit in
the Catalog tree.

2. Click the Metadata tab.

3. Click the Edit Metadata
button on the Metadata
toolbar.

4. Document your data using
the metadata editor.

5. Close the metadata editor.

Choosing a metadata
editor

1. Click the Tools menu and
click Options.

2. Click the Metadata tab.

3. Click the Metadata Editor
dropdown arrow and click the
editor you want to use.

4. Click OK.
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Using the FGDC metadata editor
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Click a tab to edit the
elements in that
subsection.

Click a section title to edit the
elements in that section. The

selected Section Title has bold text.

Type information for a metadata element
or choose a value from a dropdown list.

Status line

Move last

Move nextMove previous

Add

Move first

Delete
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The Entity Type tab contains a
group of elements describing

the current feature class. With
the toolbar, you can manage

metadata for each feature
class in a coverage.

This toolbar lets you
manage metadata for each
attribute in the current
feature class. All elements
on the Attribute tab describe
the current attribute.
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Getting Help in the editor
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Adding
enclosures
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Enclosing documentation
files

1. In the Catalog tree, click the
item to which you want to
attach a file.

2. Click the Metadata tab.

3. Click the Metadata Properties
button on the Metadata
toolbar.

4. Click the Enclosures tab.

5. Click the Add button.

6. Click the Browse button.

7. Navigate to and click the file
you want to attach. Click OK.

8. Type a description of the file.

9. If the enclosed file is an
image, such as a Windows
Bitmap file, check Image.

10. Click OK. �

�
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Viewing an enclosed file

1. Click the Metadata Proper-
ties button on the Metadata
toolbar.

2. Click the Enclosures tab.

3. Double-click the enclosed
file whose contents you want
to see.

The file opens in the appro-
priate application.

� �

Tip

Viewing enclosures
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The ESRI stylesheet lists enclosed files and
shows thumbnails of image enclosures.

Tip

Saving an enclosure to a
separate file
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11. Click OK.

Enclosed files are listed in
the ESRI stylesheet. You can
also see thumbnails of
enclosed files that are
images.
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Importing and
exporting
metadata
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Importing metadata

1. In the Catalog tree, click the
item for which you want to
import metadata.

2. Click the Metadata tab.

3. Click the Import Metadata
button on the Metadata
toolbar.

4. Click the Format dropdown
arrow and click the format of
the metadata that you will be
importing.

5. Click the Browse button.

6. Navigate to and click the
metadata file whose contents
you want to import. Click
Open.

7. If you don’t want ArcCatalog
to update the metadata with
the current properties of the
data, uncheck Enable
automatic update of
metadata.

8. Click OK.

The imported metadata
appears in the Metadata tab.

�

�

�

�

The imported metadata appears
in the Metadata tab.

�
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�Exporting metadata

1. In the Catalog tree, click the
item for which you want to
export metadata.

2. Click the Metadata tab.

3. Click the Export Metadata
button on the Metadata
toolbar.

4. Click the Browse button.

5. Navigate to the folder in
which the exported metadata
should reside, type a name
for the new metadata file,
then click Save.

6. Click the Format dropdown
arrow and click the format in
which you want to export the
metadata.

7. Click OK.

A new file containing a copy
of the item’s metadata is
created in the appropriate
format.
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A new file is created
containing a copy of
the item’s metadata.
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• Searching for items

• Searching with geographic criteria

• Searching with temporal criteria

• Searching with keywords

• Exploring the results of your
search

• Modifying the search results
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Searching for
items
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Defining the name, type,
and location of the items
you want to find

1. Click the Search button on
the Standard toolbar.

2. Click the Name & location
tab.

3. If you want to search by
name, type all or part of the
name you’re looking for into
the Name text box. Use an
asterisk (*) to represent one
or more letters. Otherwise,
type an asterisk in the Name
text box.

4. If you want to search by type,
press the Ctrl key while
clicking the items you want to
find in the Type list. Other-
wise, click Clear.

5. Click the Search dropdown
arrow and click where you
want to search.

6. Click the Browse button.

7. Navigate to and click the
folder, database connection,
or Internet server in which to
start searching. Click Open.

8. Type a name for your search
in the Save as text box.

9. Click Find Now. �
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As items are found that satisfy your search criteria, shortcuts
to those items are added to the search results list.

The Search is saved in the
Search Results folder and is
selected in the Catalog tree.
As items are found that
satisfy the search criteria,
shortcuts to those items are
added to the search results
list.

10. Click the Close button in the
upper-right corner of the
Search dialog box.
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Stopping an ongoing
search

1. Click the Search button on
the Standard toolbar or right-
click the ongoing search and
click Properties.

The Search dialog box
reappears.

2. Click Stop.
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Searching with
geographic
criteria
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Defining your area of
interest

1. Click the Search button on
the Standard toolbar.

2. Click the Name & location tab
to define the name, type, and
location criteria for your
search.

3. Click the Geography tab in
the Search dialog box.

4. Check Use geographic
location in search.

5. Draw a box on the map
outlining your area of interest.

Or click a place name in the
Choose a location dropdown
list. A box will be drawn on
the map around that location.

Or type the North, South,
East, and West coordinates
that define your area of
interest. The box on the map
changes accordingly.

6. If you wish, modify the box
using the Selection tool or
remove the box and start
again.

7. Click Find data entirely within
location or Find data overlap-
ping location—whichever is
appropriate for your search.

8. Type a name for your search
in the Save as text box.

9. Click Find Now.

10. Click the Close button.
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Using your own data as a
map

1. Click the Map dropdown
arrow and click “<Other...>”.

2. Navigate to and click the
appropriate data source.
Click Add.

The data source is added to
and selected in the Map
dropdown list. The geo-
graphic data is drawn in the
map, and a box that encloses
the data appears.

3. Modify the box so that it
contains your area of interest.

�

Your data source appears in the map along
with a box that encloses the data.
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Searching with
temporal criteria
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Defining a specific date

1. Click the Search button on
the Standard toolbar.

2. Click the Name & location tab
to define the name, type, and
location criteria for your
search.

3. Click the Date tab in the
Search dialog box.

4. Click Find and click the Find
dropdown arrow. Click the
type of date on which you
want to search.

5. Click the dropdown arrow and
click Before, Equal to, or
After.

6. To use a date other than
today, click the first date
dropdown arrow. Navigate to
and click the appropriate
date.

Or click the month, day, or
year and type a new value.
The new date appears in both
date text boxes. When
specifying the year, you can
either type a two- or four-
digit date.

7. Type a name for your search
in the Save as text box.

8. Click Find Now.

9. Click the Close button to
close the Search dialog box.
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Defining a range of dates

1. Click the Search button on
the Standard toolbar.

2. Click the Name & location tab
to define the name, type, and
location criteria for your
search.

3. Click the Date tab in the
Search dialog box.

4. Click Find and click the Find
dropdown arrow. Click the
type of date for which you
want to search.

5. Click the dropdown arrow and
click During.

6. Define the beginning date.

7. Define the ending date.

8. Type a name for your search
in the Save as text box.

9. Click Find Now.

10. Click the Close button to
close the Search dialog box.
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Tip

Today’s date
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Defining a general range
of time

1. Click the Search button on
the Standard toolbar.

2. Click the Name & location tab
to define the name, type, and
location criteria for your
search.

3. Click the Date tab in the
Search dialog box.

4. Click Find and click the Find
dropdown arrow. Click the
type of date for which you
want to search.

5. Click during the previous.

6. Click the dropdown arrow and
click the appropriate period of
time.

7. Type the appropriate duration
into the text box.

8. Type a name for your search
in the Save as text box.

9. Click Find Now.

10. Click the Close button to
close the Search dialog box.
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Searching with
keywords
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1. Click the Search button.

2. Click the Name & location tab
to define the name, type, and
location criteria for your
search.

3. Click the Advanced tab in the
Search dialog box.

4. Click the Metadata element
dropdown arrow and click the
appropriate keyword to use
from the metadata.

5. Click the Condition dropdown
arrow and click the appropri-
ate condition.

6. Click in the Value text box
and then type the words for
which you want to search. Or
click the Value dropdown
arrow and click the appropri-
ate Value in the list.

7. Click Add to List.

8. Repeat steps 4 through 7 to
add additional criteria to the
list.

9. If you don’t want to search on
a criterion, click it and click
Delete to remove it from the
list.

10. Check Match case to return
items whose metadata
contains the values exactly
as they have been typed.

11. Type a name for your search
in the Save as text box.

12. Click Find Now.

13. Click the Close button.
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Exploring the results of your search
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Modifying the
search results
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Updating the search
results

1. Right-click a Search and click
Properties.

The Search dialog box
appears containing the
Search’s criteria.

2. Modify the Search’s criteria, if
appropriate.

3. Click Find Now.

All shortcuts are removed
from the search’s current list
of results. As the Catalog
finds items that satisfy the
new search criteria, shortcuts
to those items are added to
the search results list.

4. Click the Close button to hide
the Search dialog box.

�

Deleting a shortcut

1. Click a shortcut in the
Catalog tree.

2. Click the Delete button.

The shortcut is removed from
the search results list.

�
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Selecting a shortcut’s
original item

1. Right-click a shortcut in the
Catalog tree and click Go To
Target.

The original item is selected
in the Catalog tree.

�

The shortcut’s target is selected
in the Catalog tree.
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Working with maps and layers
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Opening a map
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Opening an existing map

1. Navigate to the map you want
to open.

2. Double-click the map either in
the Contents list or in the
Catalog tree.

The map opens in ArcMap.

�

Creating a new map

1. Click Launch ArcMap on the
Standard toolbar.

2. Click A new empty map and
click OK.

See Also
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Launching ArcToolbox
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Adding data to
maps
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1. In ArcMap, open the map to
which you want to add data.

2. In the Catalog, navigate to
the data source you want to
add to the map.

3. Drag the data from the
Catalog.

4. Drop the data on the data
view or layout view or in the
map’s table of contents.

The new data appears in the
map.

�

The new geographic data
source appears in the map.

�

Ch11.p65 02/06/2001, 1:09 PM159



160 USING ARCCATALOG

Creating layers
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Saving a layer outside a
map

1. In ArcMap, open the map
containing the layer that you
want to save as a layer file.

2. Right-click the layer in the
map’s table of contents.

3. Click Save As Layer File.

4. Navigate to the folder in
which you want to save the
layer.

5. Type a name for the layer file.

6. Click Save.

7. In the Catalog, navigate to
the folder in which you saved
the layer.

The layer is now an item in
the folder. If the layer doesn’t
appear in the Contents list,
click the folder in which it
should appear in the Catalog
tree, click the View menu,
then click Refresh to update
the list.

�

�

	

The layer file is now an
item in the folder.
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Creating a new layer

1. Select the folder in which you
want to store the new layer in
the Catalog tree.

2. Click the File menu, point to
New, then click Layer.

3. Type a name for the new
layer.

4. Click the Browse button.

5. Navigate to and click the
geographic data source for
which you want to create the
layer.

6. Click Add.

7. If you don’t want the Catalog
to create a thumbnail repre-
senting the entire layer,
uncheck Create thumbnail.

8. If you don’t want the layer to
store the full pathname
identifying the location of the
data, check Store relative
path name. The location of
the data will be recorded in
relation to where the layer
itself is stored.

9. Click OK.

The new layer appears in the
folder’s contents.

�

�

The new layer appears
in the folder’s contents.
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Creating a layer from the
data

1. Right-click the data source
from which you want to
create a layer.

2. Click Create Layer.

3. Navigate to the folder in
which you want to save the
layer.

4. Type a name for the layer file.

5. Click Save.

The layer file appears in the
folder’s contents.

�

�

�

The layer file
appears in the
folder’s contents.
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Creating a new group
layer

1. Select the folder in which you
want to place the new group
layer in the Catalog tree.

2. Click the File menu, point to
New, then click Group Layer.

3. Type a name for the new
group layer.

4. Press Enter.

Adding layers to a new
group layer

1. Right-click a group layer, click
Properties, then click the
Group tab.

2. Click Add.

3. Navigate to and click the
geographic data source or
layer that you want to add to
the group. Click Open.

4. Repeat step 3 until all layers
have been added.

5. Layers are drawn in order
from the bottom to the top of
the list. Click a layer and then
click the arrow buttons to
reorder the list.

6. Click a layer and click
Properties to set the proper-
ties of individual layers.

7. Click OK.

�

�

�

�

Ch11.p65 02/06/2001, 1:09 PM163



164 USING ARCCATALOG

Creating a group layer
from the data

1. Hold down the Shift or Ctrl
key and click the appropriate
geographic data sources in
the Contents tab. The data
sources must all have the
same format—for example,
select three raster datasets.

2. Right-click one of the se-
lected data sources.

3. Click Create Layer.

4. Navigate to the folder in
which you want to save the
group layer.

5. Type a name for the group
layer file.

6. Click Save.

The new group layer appears
in the folder’s contents.

� �

The group layer appears in
the folder’s contents.

�
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Setting a layer’s
properties
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Setting a layer’s
properties

1. Right-click the layer whose
properties you want to set.

2. Click Properties.

3. Set the layer’s properties in
the Layer Properties dialog
box.

4. Click OK.

�
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Repairing a layer

1. Right-click the layer you want
to fix and click Properties.

2. Click the Source tab.

When a layer can’t find its
data source, you’ll see
information about the data it’s
looking for but no extent or
coordinate system informa-
tion.

3. Click Set Data Source.

4. Navigate to and click the
layer’s data source in the
Browse dialog box. Click Add.

The Source tab now shows
the path to the data source as
well as its extent and the
properties of its coordinate
system.

5. Click OK.
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When the layer can access its
data source, you will see extent
and coordinate system
information in the Source tab.
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��

Joining attributes to the
layer’s data

1. Right-click the layer to which
you want to join attributes and
click Properties.

2. Click the Joins & Relates tab.

3. Click Add next to the Joins
list.

4. Click the dropdown arrow and
click Join attributes from a
table.

5. Click the dropdown arrow and
click the attribute that will be
used to join the layer’s data
to an external data source.

6. Click the Browse button.
Navigate to and click the data
source whose attributes will
be joined to the layer, then
click Add.

7. Click the dropdown arrow and
click the attribute in the
external data source that
contains the same values as
the attribute chosen in step 5.

8. Click OK.

The data source’s name is
added to the list of those that
have been joined to the layer.
You can now label, query, and
symbolize the layer’s data
using attributes in the joined
data source.

9. Click OK.
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Joining attributes using a
relationship class

1. Right-click the layer to which
you want to join attributes.
Click Properties.

2. Click the Joins & Relates tab.

3. Click Add next to the Joins
list.

4. Click the dropdown arrow and
click Join data based on a
pre-defined relationship
class.

5. Click the dropdown arrow
and click the name of the
relationship on which the join
will be based.

6. Click OK.

The data source’s name is
added to the list of those that
have been joined to the layer.
You can now label, query, and
symbolize the layer’s data
using attributes in the joined
data source.

7. Click OK.

	

�
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You can symbolize the layer’s data using joined attributes.
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Working with shapefiles
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Creating new
shapefiles and
dBASE tables
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Creating a new shapefile

1. Select a folder or folder
connection in the Catalog
tree.

2. Click the File menu, point to
New, and click Shapefile.

3. Click in the Name text box
and type a name for the new
shapefile.

4. Click the Feature Type
dropdown arrow and click the
type of feature the shapefile
will contain.

5. Click Edit to define the
shapefile’s coordinate
system.

6. In the Spatial Reference
Properties dialog box, click
Select and choose a
predefined coordinate
system.

Or click Import and choose
the data source whose
coordinate system you want
to copy.

Or click New and define a
new, custom coordinate
system.

7. Click OK. �
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8. If the shapefile will store
polylines representing
routes, check Coordinates
will contain M values.

9. If the shapefile will store
three-dimensional features,
check Coordinates will
contain Z values.

10. Click OK.

The new shapefile appears
in the folder’s Contents.

Creating a new dBASE
table

1. Select a folder or folder
connection in the Catalog
tree.

2. Click the File menu, point to
New, and click dBASE Table.

A new dBASE table appears
in the folder’s Contents.

3. Type a new name for the
table and press Enter.
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Adding and
deleting
attributes
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Adding an attribute

1. Click the shapefile or dBASE
table to which you want to
add an attribute.

2. Click the File menu and click
Properties.

3. Click the Fields tab.

4. Scroll down until you see the
last attribute.

5. Click in the empty row below
the last attribute under Field
Name and type the name of
the new attribute.

6. Click under Data Type next to
the new attribute name. A
dropdown list appears with
the Text data type selected by
default. Click the appropriate
data type in the list for the
new attribute.

The properties that are
appropriate to the new
attribute’s data type appear
in the Field Properties list
below.

7. Click in the Field Properties
list and type the properties
for the new attribute.

For example, if the data type
is a real number, set the
precision (the total number of
digits the values can have)
and scale (the total number
of decimal places the values
can have) properties.

8. Click OK.
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Deleting an attribute

1. Click the shapefile or dBASE
table whose columns you
want to delete.

2. Click the File menu and click
Properties.

3. Click the Fields tab.

4. Position the mouse pointer
over the gray button to the
left of the column you want to
delete. The pointer’s icon
changes to an arrow.

5. Click the gray button to select
the column.

The column is selected and
its properties appear in the
Field Properties list below.

6. Press the Delete key on the
keyboard.

The selected attribute is
removed from the list of
columns.

7. Click OK.

�

�

The attribute
no longer
appears in the
list of columns.
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Creating and
updating indexes
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Indexing an attribute

1. Click the shapefile or dBASE
table to which you want to
add an attribute index.

2. Click the File menu and click
Properties.

3. Click the Index tab.

4. Check an attribute to index its
values.

Uncheck an attribute to
delete its index.

5. Click OK.
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Adding a spatial index

1. Click the shapefile for which
you want to create a spatial
index.

2. Click the File menu and click
Properties.

3. Click the Index tab.

4. Click Add.

5. Click OK.

Updating a spatial index

1. Click the shapefile to which
you want to add a spatial
index.

2. Click the File menu and click
Properties.

3. Click the Index tab.

4. Click Update.

5. Click OK.
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Defining a
shapefile’s
coordinate
system
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Defining a shapefile’s
coordinate system

1. Click the shapefile whose
coordinate system you want
to define.

2. Click the File menu and click
Properties.

3. Click the Fields tab.

4. Click the Shape column in
the column list.

5. In the Field Properties list
below, click the ellipses
button (...) next to the Spatial
Reference property.

6. In the Spatial Reference
Properties dialog box, click
Select and then choose a
predefined coordinate
system.

Or click Import and then
choose the data source
whose coordinate system
parameters you want to copy.

Or click New, click Geo-
graphic or Projected, and
then define a new, custom
coordinate system.

7. Click OK in the Spatial
Reference Properties dialog
box. �
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Selecting an existing
coordinate system

1. In the Spatial Reference
Properties dialog box, click
Select. �
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In the Shapefile Properties
dialog box, the name of the
coordinate system appears
next to the Spatial Reference
property in the Field Proper-
ties list.

8. Click OK in the Shapefile
Properties dialog box.

Tip

Defining coordinate sys-
tems of other data sources
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The coordinate
system’s name
appears next to
the Spatial
Reference
property.
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2. Navigate to the coordinate
system you want to use. For
example, you can use one of
the predefined coordinate
systems in the Coordinate
Systems folder that was
provided with ArcCatalog. Or
you can use a projection file
that was created with ArcInfo
Workstation.

3. Click the coordinate system.

4. Click Add.

The coordinate system’s
parameters are listed in the
Spatial Reference Properties
dialog box.

5. If you wish, click Modify to
change the coordinate
system parameters. Or click
Clear and repeat steps 1
through 4.

6. Click OK in the Spatial
Reference Properties dialog
box.

�

�

The coordinate
system’s
parameters are
listed.
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Importing a coordinate
system

1. In the Spatial Reference
Properties dialog box, click
Import.

2. Navigate to the data source
whose coordinate system
parameters you want to copy.
For example, you can get
coordinate system informa-
tion from coverages, rasters,
or feature datasets and
feature classes in a
geodatabase.

3. Click the data source.

4. Click Add.

The coordinate system’s
parameters are listed in the
Spatial Reference Properties
dialog box.

5. If you wish, click Modify to
change the coordinate
system parameters. Or click
Clear and repeat steps 1
through 4.

6. Click OK in the Spatial
Reference Properties dialog
box.
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Defining a new
geographic coordinate
system

1. In the Spatial Reference
Properties dialog box, click
New and click Geographic.

2. Type a name for the custom
coordinate system.

3. Type the appropriate semi-
major and semiminor or
inverse flattening values and
type a name for your custom
Spheroid and Datum.

Or click the Datum or Spher-
oid Name dropdown arrow
and click a predefined datum
or spheroid.

4. Type the appropriate Radi-
ans per unit and type a name
for your custom units.

Or click the Angular Unit
dropdown arrow and click a
predefined unit of measure.

5. Type the appropriate de-
grees, minutes, and seconds
defining the prime meridian
and type a name for this line
of longitude.

Or click the Prime Meridian
dropdown arrow and click a
predefined line of longitude.

6. Click OK.

7. Click OK in the Spatial
Reference Properties dialog
box.

Tip

Modifying default param-
eters
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Defining a new projected
coordinate system

1. In the Spatial Reference
Properties dialog box, click
New and click Projected.

2. Type a name for the custom
coordinate system.

3. Click the Projection Name
dropdown arrow and click
one of the supported projec-
tions.

4. Type the appropriate param-
eter values for the projection.

5. Click the Linear Unit
dropdown arrow and click a
predefined unit of measure.

Or click “<custom>” in the
dropdown list, type the
appropriate meters per unit,
then type a name for your
custom units.

6. Define the projection’s datum
by selecting a predefined
geographic coordinate
system or defining a new
geographic coordinate
system. Afterwards, you can
modify the geographic
coordinate system’s param-
eters if you wish.

7. Click OK.

8. Click OK in the Spatial
Reference Properties dialog
box.
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182 USING ARCCATALOG

Modifying a coordinate
system’s parameters

1. In the Spatial Reference
Properties dialog box, click
Modify.

The Geographic or Projected
Coordinate System Proper-
ties dialog box appears.

2. Follow the steps for defining
either a new geographic or a
new projected coordinate
system to change the
appropriate parameters.

3. Click OK.

4. Click OK.

Saving a coordinate
system to a file

1. In the Spatial Reference
Properties dialog box, click
Save As.

2. Navigate to the location
where you want to place the
coordinate system file. For
example, place it in a shared
folder on the network.

3. Type a name for the coordi-
nate system file and click
Save.

4. Click OK.

The coordinate system file
appears in the folder’s
Contents list.

The
coordinate
system
appears in
the folder’s
Contents list.
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ArcInfo and ArcEditor

Working with coverages

• Creating a new coverage

• Creating a new INFO table

• Generating topology

• Defining a coverage’s coordinate
system

• Modifying a coverage’s tics and
extent

• Setting a coverage’s tolerances

• Maintaining attributes

• What is a relationship class?

• Creating a coverage relationship
class
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Creating a new
coverage
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1. In the Catalog tree, click the
folder in which the new
coverage will be created.

2. Click the File menu, point to
New, and click Coverage.

3. Type a name for the new
coverage.

4. Check the box to use another
coverage as a template.

5. Click the Browse button and
then navigate to the coverage
that will be used as a tem-
plate. Click the coverage and
click Open.

6. Click Next.

7. If you want to define or
modify the coordinate system
information for the new
coverage, click Define, then
follow steps 5 through 12 in
the task ‘Defining a coordi-
nate system interactively’.

8. Click Next.

9. Click the dropdown arrow and
click the feature class that will
have topology.

10. Click Single if you want to
create a single-precision
coverage. Double-precision
is the default.

11. Click Finish.

The new coverage appears
in the Catalog.
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Creating a new
INFO table
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1. In the Catalog tree, click the
folder in which the new INFO
table will be created.

2. Click the File menu, point to
New, and click INFO table.

3. Type a name for the new
table.

4. Click the data type of the first
column in the table.

5. Type a name for the column.

6. Default values for the
column’s width, display width,
and number of decimal
places are provided based on
the column’s data type. You
can change these values if
you wish.

7. Click New item to add
another column to the table,
then repeat steps 4 through 6
to define the new column.

8. Repeat step 7 until all
columns have been added to
the table.

9. Use the arrows to navigate
back and forth through the
table’s columns to review and
modify their properties, if
necessary. Click Remove
item if a column must be
deleted.

10. Click OK.

The new INFO table appears
in the Catalog.
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The new INFO table
appears in the Catalog.

Tip

Creating a new workspace
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Building coverage
topology

1. Right-click the coverage for
which you want to build
topology and click Properties.

2. Click the General tab.

3. Click the feature class for
which you want to build
topology.

4. Click Build.

5. Change the feature class or
annotation class for which to
build topology, if appropriate.

6. Click OK in the Build dialog
box.

7. Click OK.

Generating
topology
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A coverage with preliminary topology
can be identified by its icon.

After generating topology, the
coverage’s icon changes.
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Cleaning a coverage

1. Right-click the coverage that
you want to clean and click
Properties.

2. Click the General tab.

3. Click the feature class that
you want to clean.

4. Click Clean.

5. Type in the fuzzy and dangle
tolerances in the Clean dialog
box, if appropriate.

6. If necessary, check Clean
lines only.

7. Click OK in the Clean dialog
box.

8. Click OK.
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Setting tolerances
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Defining a
coverage’s
coordinate
system
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Matching another item’s
coordinate system

1. Click the coverage whose
coordinate system you want
to define.

2. Click the File menu and click
Properties.

3. Click the Projection tab.

4. Click Define.

5. Click Define a coordinate
system for my data to match
existing data.

6. Click Next. �
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7. Click the Browse button.

8. Navigate to and click the
coverage, grid, or TIN whose
coordinate system you want
to use. Click Open.

9. Review the coordinate
system’s parameters that
appear in the wizard. If you
want to use this coordinate
system, click Next. Other-
wise, locate a different
coverage.

10. Click Finish.

The coordinate system and
its parameters now appear in
the Coverage Properties
dialog box.

11. Click OK.
�

�

Tip

Different ways to see
projection information
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Tip

Defining coordinate sys-
tems for grids and TINs
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Defining a coordinate
system interactively

1. Click the coverage whose
coordinate system you want
to define.

2. Click the File menu and click
Properties.

3. Click the Projection tab.

4. Click Define.

5. Click Next.

6. Click the appropriate coordi-
nate system in the Projec-
tions list on the left.

A description of the coordi-
nate system appears on the
right.

7. Click Next. �
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8. Enter the appropriate
parameter values for the
coordinate system; each one
has a different set of param-
eters.

9. Click Next.

10. If the coverage uses a
projected coordinate system,
click the datum it uses or
click Spheroid and define the
spheroid’s parameters.

11. Click Next.

12. Review the summary of the
coordinate system that will
be assigned to the coverage.
If you want to modify the
coordinate system’s param-
eters, go back through the
wizard by clicking the Back
button. Click Finish if you
want to use this coordinate
system.

The coordinate system and
its parameters now appear in
the Coverage Properties
dialog box.

13. Click OK.
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Adding tics

1. Right-click the coverage to
which you want to add a tic
and click Properties.

2. Click the Tics and Extent tab.

3. Click Add.

4. Double-click in the X column
and type the tic point’s x-
coordinate.

5. Double-click in the Y column
and type the tic point’s y-
coordinate.

6. Click OK.

Modifying a
coverage’s tics
and extent
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Updating tic coordinates

1. Right-click the coverage
whose tics you want to modify
and click Properties.

2. Click the Tics and Extent tab.

3. Click the ID of the tic whose
coordinates you want to
modify.

4. Click Update.

5. Click in the X column and
type the tic point’s x-coordi-
nate.

6. Double-click in the Y column
and type the tic point’s y-
coordinate.

7. Click OK. �

�

Deleting tics

1. Right-click the coverage
whose tics you want to delete
and click Properties.

2. Click the Tics and Extent tab.

3. Click the ID of the tic you
want to delete.

4. Click Delete.

5. Click OK.

�
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Recalculating the extent

1. Right-click the coverage
whose extent you want to
recalculate and click Proper-
ties.

2. Click the Tics and Extent tab.

3. Click Fit.

4. Click OK.

The extent is recalculated.

�

�

�

�

Updating the extent
manually

1. Right-click the coverage
whose extent you want to
modify and click Properties.

2. Click the Tics and Extent tab.

3. Click in the text box of the
appropriate extent value and
type the new coordinate
value.

4. Repeat step 3 until all the
extent coordinates are
correct.

5. Click OK.
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1. Click the coverage whose

tolerances you want to set.

2. Click the File menu and click
Properties.

3. Click the Tolerances tab.

4. Click in the text box of the
tolerance whose value you
want to modify and type the
new value.

5. Repeat step 4 until all the
tolerance values are correct.

6. Click OK.

Setting a
coverage’s
tolerances
5���� 

������� 
������
��� ���
�
�����
����/
���������������
�
��������%��
�������������
��
����������������
�����
��
���
�������
����
������������
�
����������������������������
������������
��
����
��
����7�����
������
���������;
�������
�
�����
���$
�����
������
������
����������

���������������
���������������


���������������
������%���������������
�����
������
�� ���������
���7����������������
������
C�
����������
�����
������
�� ������������
���������

$���$
�����
����������������

���������������
������
���


����������
�����
����,
��������
1'������3� ����� �
� ������� ����
����� ����� ���������� ��
	�
���
��,
����������� �


������ ���� �������� �
�����
��� �

������� ����� �����
��� ����
������
�
�� ���� ����� ���� �
���� 
�
��������� ��� ���� 

������7�����
�
�� �
� �
� ��� ����$
�����
��� ����
1'������3� ������������,
�� 
��
���
� ���� �
�����
�������� �����
���	�
$

��
�� �

��
����
	�
���
�"
� �����
�� 

������
"���� �
�� 
���� �����
������
E�
������������
���
�� �����
�������� ���� �

�� 
�� 

������
1-�������3�������������� �
� ���
�
�����
�� ��������� �����

�

	

�

Ch13.p65 02/21/2001, 11:10 AM195



196 USING ARCCATALOG

ArcInfo and ArcEditor

Adding a new attribute

1. Right-click the coverage
feature class or INFO table to
which you want to add an
attribute and click Properties.

2. Click the Items tab.

3. Under Item Name, click the
attribute after which the new
attribute should be placed.
The attribute should not be a
redefined attribute or a
pseudo item. If an attribute is
redefined, “Yes” appears in
the Redefined column. For
pseudo items, “N/A” appears
under Column to the left of
the attribute’s name.

4. Click Add.

5. Type the new attribute’s
name in the Add Item dialog
box.

6. Click next to Type, click the
dropdown arrow, then click
the appropriate data type for
the values the attribute will
contain. �

Maintaining
attributes
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�

�

�

7. Type an appropriate input
width and display width for
the attribute’s values, then
type the maximum number of
decimals the values can
have, if appropriate. Valid
input widths may be pre-
sented as a dropdown list.

8. Type a more descriptive
name for the attribute, if
appropriate.

9. Click OK.

The new attribute appears in
the Properties dialog box.

10. Click Apply to save your
changes.

11. Click OK.

�

The new attribute
appears in the
Properties dialog box.
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Adding a redefined
attribute

1. Right-click the coverage
feature class or INFO table to
which you want to add a
redefined attribute and click
Properties.

2. Click the Items tab.

3. Under Item Name, click an
attribute that is not a rede-
fined attribute or a pseudo
item. For redefined attributes,
“Yes” appears in the Rede-
fined column. For pseudo
items, “N/A” appears under
Column to the left of the
attribute’s name.

4. Click Add.

5. Click next to Redefined, click
the dropdown arrow, and click
Yes.

6. Click next to Column and
type the starting position for
the redefined attribute.

7. To define the attribute’s
properties, follow steps 6
through 10 for adding a new
attribute.

8. Click OK.

Redefined attributes are
listed below other attributes
in the properties dialog box.

9. Click Apply to save your
changes.

10. Click OK.

�

	

�
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�
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Redefined
attributes
are added
to the
bottom of
the list.
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Modifying an attribute

1. Right-click the coverage
feature class or INFO table
containing the attributes you
want to modify and click
Properties.

2. Click the Items tab.

3. Under Item Name, click the
attribute you want to modify.

4. Click Edit.

5. In the Value column, click
next to the property you want
to change. Type a new value
or click a new value in the
dropdown list, as appropriate.
You can only change the
Input Width of a redefined
attribute.

6. Repeat step 5 until all
properties of the attribute
have correct values.

7. Click OK.

The attribute’s properties are
updated in the properties
dialog box.

8. Click Apply to save your
changes.

9. Click OK.

�

�

�

�

Tip

Applying changes
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attribute’s
properties
are
updated.
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Deleting an attribute

1. Right-click the coverage
feature class or INFO table
containing the attribute you
want to delete and click
Properties.

2. Click the Items tab.

3. Under Item Name, click the
attribute you want to delete.

4. Click Delete.

The attribute no longer
appears in the properties
dialog box.

5. Click Apply to save your
changes.

6. Click OK.

�

	

The attribute no longer
appears in the properties
dialog box.
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Adding and removing
indexes

1. Right-click the coverage
feature class or INFO table
whose indexes you want to
modify and click Properties.

2. Click the Items tab.

3. Under Item Name, click the
attribute to which you want to
add or from which you want
to remove an index.

4. Click Add Index to create an
index of the attribute’s values.

Click Delete Index to remove
an existing index on the
attribute’s values.

The value in the Indexed
column changes to Yes or No
depending on whether an
index was added or deleted.

5. Click Apply to save your
changes.

6. Click OK.

�

	

The value in the Indexed
column changes to Yes or No
depending on whether an index
was added or deleted.
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What is a relationship class?
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Properties of a relationship
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Types of relationships
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Relationships have cardinality. Cardinality describes how many objects of
type A are associated with objects of type B. Relationships can have 1-1,
1-M, M-1, or N-M cardinality.

Origin
feature class

Destination
feature class

Relationship
class

O1

O2

R1

R2

D1

D2

Origin
feature class

Destination
feature class

Relationship
class

O1

O2

R1

R2

D1

D2

D3

D4

D5

Origin
feature class

Destination
feature class

Relationship
class

O1

O2
R1

R2

D1

D2
O3

O4

Origin
feature class

Destination
feature class

Relationship
class

O1

O2
R1

R2

O3

O4

D1

D2

D3

D4

D5

One-to-one (1-1) One-to-many (1-M)

Many-to-one (M-1) Many-to-many (N-M)
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ArcInfo and ArcEditor
1. In the Catalog tree, click the

folder containing the cover-
age for which you want to
create a relationship class.

2. Click File, point to New, then
click Coverage Relationship
Class.

3. Type a name for the new
relationship class.

4. Click the origin table or
feature class.

5. Click the destination table or
feature class.

6. Click Next.

7. Click the type of relationship
you want to create.

8. Click Next. �

Creating a
coverage
relationship class
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ArcInfo and ArcEditor

�

9. Type the forward and
backward path labels for the
relationship.

10. Click Next.

11. Click the appropriate
cardinality for this relation-
ship.

12. Click Next. �
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ArcInfo and ArcEditor

�

�

�

13. Click the first dropdown
arrow to see a list of at-
tributes in the origin table or
feature class. Click the
primary key for this relation-
ship.

14. Click the second dropdown
arrow to see a list of at-
tributes in the destination
table or feature class. Only
those attributes that have the
same data type as the
primary key are listed. Click
the foreign key for this
relationship.

15. Click Next.

16. Review the options you
specified for the new
relationship class. If you want
to change something, you
can go back through the
wizard by clicking the Back
button.

17. When satisfied with your
options, click Finish.

The new relationship class
appears in the folder’s
contents.

The new coverage
relationship class appears
in the folder’s contents.
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Geocoding services in ArcCatalog

What is a geocoding service?
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Geocoding indexes
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GEOCODING ADDRESSES 209

ArcView GIS 3 geocoding indexes that use coverage reference data have an
.mxa file extension.

The serverside Geocoding Services folder is located within a spatial database
connection that accesses an ArcSDE geodatabase.

Public geocoding services, which are available to anyone who uses your
computer, aren’t prefaced by your username.

Your username appears before the name of private geocoding services.

The clientside Geocoding Services folder manages geocoding services stored
on your computer.

ArcSDE geocoding services can be used by anyone who has access to their
reference data.

ArcView GIS 3 geocoding indexes that use shapefile reference data have an
.mxs file extension.
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Managing
geocoding
services
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Creating a new
geocoding service

1. In ArcCatalog, click a
Geocoding Services folder.

2. Double-click the Create New
Geocoding Service item.

3. Click the geocoding service
style that you want to use to
create the new geocoding
service.

4. Click OK. �
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5. In the Name text box, type a
name for the new geocoding
service.

6. Click the Browse button on
the Primary Table tab.

7. Navigate to and click the
feature class, shapefile, or
coverage that the geocoding
service will use as reference
data, then click Add.

8. Click a dropdown arrow, then
click the name of the column
that contains the specified
address information.

The required address
attributes have a bold name
to the left of the appropriate
dropdown list. �
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212 USING ARCCATALOG

9. If your geocoding service will
use an alternate street name
table, click the Alternate
Name table tab.

Otherwise, skip to step 13.

10. Click the Browse button.

11. Navigate to and click the
table that the geocoding
service will use as an
alternate street name table,
then click Add.

12. Click a dropdown arrow,
then click the name of the
column that contains the
specified alternate street
name information.

The required alternate street
name attributes have a bold
name to the left of the
appropriate dropdown list.

13. If your geocoding service will
use a place name alias
table, click Place Name Alias
Table.

Otherwise, skip to step 16. �
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14. Click the Browse button,
navigate to and click the
table that the geocoding
service will use as a place
name alias table, then click
Add.

15. Click a dropdown arrow,
then click the name of the
column that contains the
specified place name alias
information.

The required place name
alias attributes have a bold
name to the left of the
appropriate dropdown list.

16. Click OK.

17. Click OK to create the new
geocoding service.
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214 USING ARCCATALOG

Making a serverside
geocoding service public

1. Click the ArcSDE database
connection that contains the
geocoding service that you
want to make public.

2. Right-click the feature
dataset that contains the
feature class, the standalone
feature class, or the table that
the geocoding service uses
as reference data and click
Privileges.

3. Type the name of the user to
which you want to make the
geocoding service available.

4. Check SELECT.

5. Click Apply.

6. Repeat steps 3 through 5 to
make your geocoding service
available to additional users.

7. Click OK.

8. Repeat steps 2 through 7 for
the alternate street name
tables and place name alias
tables if your geocoding
service uses them.
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ArcInfo and ArcEditor
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Controlling the geocoding process

The geocoding process
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A geocoding service standardizes an address into a number of address
components.

4 DUNDAS ST. E.Street number

Street name

Street type

Street direction

The geocoding service searches the reference data for features with
address components that are similar to the components of the
standardized address.
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Input address fields
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The geocoding service scores each potential candidate using all of the
address components. A set of match candidates is generated based on
the geocoding service’s minimum candidate score setting.

The Geocoding Service Properties dialog box allows you to modify the
settings of a geocoding service.
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Output options
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An end offset can be specified that adjusts the location of the address
toward the center of the street feature. Using an end offset will often
rectify the condition shown in the previous diagram. In this example, a
squeeze factor of 10 percent was used to move the address toward the
center of the street feature by a distance equal to 10 percent of the
length of the street feature.

The address, 100 MAIN ST, has been offset from the street feature by
the offset distance of 25 feet. This address falls at the end of the street
feature and is therefore inline with the end of the street feature.

When streets intersect at odd angles, specifying an offset distance can
have the undesirable effect of placing the address so it appears that the
address does not belong to MAIN ST, but rather to OAK AV.
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Output fields
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Modifying a
geocoding
service’s settings
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Adding a default input
address column name

1. Right-click the geocoding
service that you want to
modify and click Properties.

2. In the list on the left-hand
side under Input Address
Fields, click the input address
column for which you want to
search in address tables.

3. Click Add.

4. Type the name of the field to
search for in address tables,
then click OK.

5. Click OK.

Tip

Reordering default input
column names
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Setting matching options

1. Right-click the geocoding
service that you want to
modify and click Properties.

2. Under Matching Options,
drag the spelling sensitivity
slider to the desired setting.

3. Drag the minimum candidate
score slider to the desired
setting.

4. Drag the minimum match
score slider to the desired
setting.

5. Click OK. �
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Specifying an alternate
street name table
���	�
�
�����
����
��	
���
�����

�����
��
����������	������
��	
����������	��!�����	���	
��	�A

�������;B����
���
�	��=
���
�����
��������������	��!���'����
��	
����
���

Tip

Specifying a place name
alias table
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222 USING ARCCATALOG

Specifying intersection
connectors

1. Right-click the geocoding
service that you want to
modify and click Properties.

2. Type the intersection connec-
tors that the geocoding
service will recognize in the
Intersection Connectors text
box.

Items in the Intersection
Connectors text box must be
separated by a space (for
example, “& @ , |”).

3. Click OK.
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Setting output options

1. Right-click the geocoding
service that you want to
modify and click Properties.

2. Under Output Options, click
the dropdown arrow and click
the units that will be used to
measure the side offset.

3. Type the number of units to
offset geocoded addresses.

4. Drag the end offset slider bar
to the desired setting.

5. Check Match if candidates tie
to match addresses arbitrarily
when two or more candidates
with the same best match
score exist.

6. Click OK.
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Specifying output
attributes

1. Right-click the geocoding
service that you want to
modify and click Properties.

2. Under Output Fields, check
X and Y Coordinates to write
X and Y coordinates of
geocoded features to
geocoded feature classes.

3. Check Standardized address
to write standardized ad-
dresses to geocoded feature
classes.

4. Check Reference data ID to
write the IDs of the reference
data features to which
addresses were matched to
geocoded feature classes.

5. Check Percent Along to write
the percent along reference
features at which addresses
are located to geocoded
feature classes.

6. Click OK.
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Geocoding a
table of
addresses
"���� �
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1. In ArcCatalog, right-click the
table of addresses that you
want to geocode and click
Geocode Addresses.

2. Click the geocoding service
that you want to use to
geocode this table of
addresses.

If the geocoding service that
you want to use does not
appear in this list, click
Browse for service, then
browse for the geocoding
service that you want to
use.

3. Click OK � �
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226 USING ARCCATALOG

4. If the geocoding service did
not automatically find the
fields in the address table
that contain the address
information, click the appro-
priate dropdown list and click
the name of the column that
contains the appropriate
address attribute.

The required address
attributes have a bold name
to the left of the appropriate
dropdown list.

5. Click the Browse button.

6. Navigate to and click the
location where you want to
create the geocoded feature
class, then click Save.

7. Click Create a dynamic
feature class related to the
table if appropriate.

8. Click Advanced Geometry
Options to specify the
geometry settings for the
geocoded feature class. �

Tip

Geocoding dynamic feature
classes related to the
address table
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9. Specify the geometry settings
for the geocoded feature
class and click OK.

10. Click Geocoding Options to
specify the geocoding
options that will be used to
geocode the table of
addresses.

11. Specify the geocoding
settings that you want to use
to geocode the table of
addresses and click OK.

12. Click OK on the Geocode
Addresses dialog box to
begin geocoding the table. �

Tip

Specifying the geocoding
settings
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13. Review the results of the
geocoding process.

14. Click Done.

Tip

Attributes in geocoded
feature classes
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Rematching a
geocoded feature
class
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Rematching a geocoded
feature class
automatically

1. In ArcCatalog, right-click the
feature class that you want to
rematch and click Review/
Rematch Addresses.

2. Specify the criteria for the
addresses that you want to
rematch.

3. Click Geocoding Options to
modify the geocoding
settings that you want to use
to rematch the addresses. �
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See Also
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230 USING ARCCATALOG

4. Specify the geocoding
settings that you want to use
to rematch the geocoded
feature class and click OK.

5. Click Match Automatically.

6. Review the results of
rematching the specified
addresses.

7. Click Done.

Tip

Specifying the geocoding
settings
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Rematching a geocoded
feature class interactively

1. In ArcCatalog, right-click the
feature class that you want to
rematch and click Review/
Rematch Addresses.

2. Specify the criteria for the
addresses that you want to
rematch.

3. Click Match Interactively. �
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232 USING ARCCATALOG

4. Click the address in the top
list that you want to rematch.

5. If necessary, edit the input
address.

6. Check the address standard-
ization to ensure that the
geocoding service has
standardized the address
correctly. If not, edit the
address standardization by
clicking Modify.

7. Click Geocoding Options to
modify the gecoding settings
that you want to use to
rematch the addresses.

8. Specify the geocoding
settings that you want to use
to geocode the addresses
and click OK.

9. Click Search to refresh the
list of candidates.

10. Click the candidate in the
bottom list to which you want
to match the address.

11. Click Match.

12. Click Close when you are
finished rematching the
addresses.

13. Click Done to finish
rematching the geocoded
feature class.

Tip

Unmatching an address
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Customizing ArcCatalog 15
• Basic user interface elements

• Customizing toolbars

• Changing a toolbar’s contents

• Changing a command’s
appearance

• Creating shortcut keys

• Creating and running macros

• Creating custom commands with
VBA

• Working with UIControls

• Adding custom commands

• Updating the ArcID module

• Changing VBA security

• Using the ArcObjects Developer
Help system
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Basic user interface elements
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Changing the Catalog’s appearance
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The ArcCatalog window with the Geography toolbar and the Catalog tree
floating on the desktop. All other toolbars are docked.
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Customizing
toolbars
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Hiding and showing
toolbars from the View
menu

1. Click the View menu and
point to Toolbars.

2. Check a toolbar to show it.

Uncheck a toolbar to hide it.

Hiding and showing
toolbars from the
Customize dialog box

1. Click the Tools menu and
click Customize.

2. Click the Toolbars tab.

3. Check a toolbar to show it.

Uncheck a toolbar to hide it.

4. Click Close.

�

�

�
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Creating a new toolbar

1. Click the Tools menu and
click Customize.

2. Click the Toolbars tab.

3. Click New.

4. Type the name of your new
toolbar.

5. Click OK.

The new, empty toolbar
appears in the Toolbars list
and as a floating toolbar on
your desktop.

6. Click Close.

�

�

�
	

Renaming a toolbar

1. Click the Tools menu and
click Customize.

2. Click the Toolbars tab.

3. Click the toolbar you want to
rename.

4. Click Rename.

5. Type the name of your new
toolbar.

6. Click OK.

The toolbar is renamed in the
Toolbars list, and it appears
as a floating toolbar on your
desktop.

7. Click Close.
�

�
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Tip

Shortcut to the Toolbars
list
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Showing ToolTips on
toolbars

1. Click the Tools menu and
click Customize.

2. Click the Options tab.

3. Check Show ToolTips on
toolbars to display ToolTips
when you hold the mouse
pointer over a button.

4. Click Close.

Displaying toolbars with
large icons

1. Click the Tools menu and
click Customize.

2. Click the Options tab.

3. Check Large icons to display
large icons for a toolbar’s
commands.

4. Click Close.

�

�

�

�

You see
large icons
on the
toolbars.
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Adding a command to a
toolbar or menu

1. Show the toolbar to which
you want to add a command.

2. Click the Tools menu and
click Customize.

3. Click the Commands tab.

4. In the Categories list, click the
category that contains the
command you want to add.

5. Click the command you want
to add in the Commands list.

6. Drag the command to any
location in the target toolbar
or menu. A menu’s contents
will appear if you hold the
mouse pointer over the menu.

A black line indicates where
the command will be posi-
tioned.

7. Drop the command.

The command appears in the
toolbar or menu.

8. Click Close.

�

�

Changing a
toolbar’s
contents
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The command
appears in the
toolbar or menu.

Tip

About the Save in combo
box
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Adding a new, empty
menu to a toolbar

1. Show the toolbar to which
you want to add a new, empty
menu.

2. Click the Tools menu and
click Customize.

3. Click the Commands tab.

4. Click New Menu in the
Categories list.

5. Click and drag the New Menu
command from the Com-
mands list and drop it on the
toolbar.

An empty menu called “New
Menu” appears in the toolbar.

6. Right-click New Menu in the
toolbar.

7. Type an appropriate caption
for the menu in the text box.

8. Press Enter.

9. Click Close.

�

�

�

�

The menu’s caption
changes.

Tip

Creating access keys
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Adding a command to a
context menu

1. Click the Tools menu and
click Customize.

2. Click the Toolbars tab.

3. Check the Context Menus
toolbar.

4. Click Context Menus on the
toolbar.

A list of all the context menus
in the Catalog appears. You
may need to scroll up or
down in the list to find the
menu you want to modify.

5. Click the arrow for the context
menu to which you want to
add a command.

The context menu appears.

6. Click the Commands tab in
the Customize dialog box.

7. Click the category that
contains the command you
want to add to the menu.

8. Click and drag the command
from the Commands list to
the context menu. A thick
black line indicates where
the command will be posi-
tioned. Drop the command in
the appropriate location.

The command appears in the
context menu.

9. Click Close in the Customize
dialog box.

�

�

The command appears
in the context menu.

�
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Moving a command

1. Show the toolbar with the
command you want to move.

2. If you’re moving the com-
mand to another toolbar,
show the destination toolbar.

3. Click the Tools menu and
click Customize.

4. Click and drag the command
from its original position and
drop the command in its new
location.

The command appears in the
new position.

5. Click Close in the Customize
dialog box.

�

Removing a command

1. Show the toolbar containing
the command that you want
to remove.

2. Click the Tools menu and
click Customize.

3. Click and drag the tool you
want to remove from the
toolbar.

The mouse pointer changes
to a line through a circle.

4. Drop the command.

The command is removed
from the toolbar or menu.

5. Click Close in the Customize
dialog box.

The command appears in
its new position.

�

The command is removed
from the toolbar.

Tip

Removing commands
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Tip

Why open the Customize
dialog box?
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Resetting a built-in
toolbar

1. Click the Tools menu and
click Customize.

2. Click the Toolbars tab.

3. Click the built-in toolbar that
you want to reset.

4. Click Reset.

5. Click OK.

6. Click Close.
�

	

�

A built-in toolbar was
modified.

�

The toolbar’s original
contents are restored.
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Changing a
command’s
appearance
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Changing the display
type

1. Show the toolbar containing
the command whose display
type you want to change.

2. Click the Tools menu and
click Customize.

3. In the toolbar, right-click the
command you want to
change. �

�

Grouping commands

1. Show the toolbar containing
the commands that you want
to group together.

2. Click the Tools menu and
click Customize.

3. In the toolbar, right-click the
command located to the right
of where the grouping bar
should be placed.

4. Check Begin a Group to show
a grouping bar to the left of a
command.

Uncheck Begin a Group to
remove a grouping bar.

5. Click Close in the Customize
dialog box.

A grouping bar appears
in the toolbar to the left
of the command.

�

�

�
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4. Check Text Only to display
only the command’s caption.

Check Image Only to display
only the command’s image.

Check Image and Text to
display both its image and its
caption.

The command’s display type
changes.

5. Click Close in the Customize
dialog box.

The command’s
display type changes.

Changing the image

1. Show the toolbar containing
the command whose image
you want to change.

2. Click the Tools menu and
click Customize.

3. In the toolbar, right-click the
command you want to
change.

4. Point to Change Button
Image.

5. Click one of the images
displayed. Or click Browse,
navigate to a custom image,
then click Open.

The new image is applied. It
appears in the toolbar if the
display type is Image Only or
Image and Text.

6. Click Close in the Customize
dialog box.

�

The new image appears in the
toolbar if the display type is
Image Only or Image and Text.
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Resetting a built-in
command

1. Show the toolbar with the
command you want to reset.

2. Click the Tools menu and
click Customize.

3. In the toolbar, right-click the
command.

4. Click Reset.

The command’s image,
caption, and display type
return to their default settings.

5. Click Close in the Customize
dialog box.

Changing the caption

1. Show the toolbar containing
the command whose caption
you want to change.

2. Click the Tools menu and
click Customize.

3. In the toolbar, right-click the
command you want to
change.

4. Type a new caption in the edit
box on the context menu.

5. Press Enter.

The new caption is applied. It
appears in the toolbar if the
display type is Text Only or
Image and Text.

6. Click Close in the Customize
dialog box.

�

The new caption appears
in the toolbar if the
display type is Text Only
or Image and Text.

The command’s image, caption,
and display type return to their
default settings.

�

�

�
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Assigning a shortcut key

1. Click the Tools menu and
click Customize.

2. Click Keyboard.

3. Click the category containing
the command you want to
modify.

4. Click the command to which
you want to add a shortcut
key.

5. Click in the Press new
shortcut key text box, then
press the keys on the
keyboard that you want to
use for a shortcut.

If those keys have been
assigned to another com-
mand, that command’s name
will appear below.

6. Click Assign if the keys aren’t
currently assigned to another
command.

The new shortcut appears in
the Current Key/s list.

7. Click Close in the Customize
Keyboard dialog box.

8. Click Close in the Customize
dialog box.
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Creating shortcut
keys
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The new shortcut key
appears in the Current
Key/s list and is assigned
to the command.
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Removing a shortcut key

1. Click the Tools menu and
click Customize.

2. Click Keyboard.

3. Click the category that
contains the command you
want to modify.

4. Click the command from
which you want to remove a
keyboard shortcut.

5. Click the shortcut in the
Current Key/s list that you
want to delete.

6. Click Remove.

7. Click Close in the Customize
Keyboard dialog box.

8. Click Close in the Customize
dialog box.

Resetting built-in
shortcut keys

1. Click the Tools menu and
click Customize.

2. Click Keyboard.

3. Click Reset All.

Click Yes when asked if you
want to reset your shortcuts.

4. Click Close in the Customize
Keyboard dialog box.

5. Click Close in the Customize
dialog box.
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Creating and
running macros
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Creating a macro

1. Click the Tools menu, point to
Macros, then click Macros.

2. Type the name of the macro
you want to create in the
Macro name text box.

To place the macro in a
specific location, type
ThisDocument or the
module’s name and then a
period (.) before the new
macro’s name. Otherwise, the
macro will be added to the
“NewMacros” module.

3. Click Create or press Enter.

The Code window appears
containing a stub for the new
Sub procedure.

4. Type the code for the macro.

5. Click the VBE File menu and
click Save Project.

6. Click the Close button in the
VBE.

�

�

�

When you type a macro name
without specifying which module to
put it in, the macro is placed in the
NewMacros module.
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toolbar or menu

1. Show the toolbar to which
you want to add a macro.

2. Click the Tools menu and
click Customize.

3. Click the Commands tab.

4. Click Macros in the Catego-
ries list.

5. Click and drag the macro
from the Commands list and
drop it on the toolbar.

The macro appears in the
toolbar or menu.

6. Click Close.

	

�

�

Editing a macro

1. Click the Tools menu, point to
Macros, then click Macros.

2. In the list below the Macro
name text box, click the name
of the macro you want to edit.

3. Click Edit.

The code that’s been written
for the macro appears in the
Code window.

4. Edit the code.

5. Click the VBE File menu and
click Save Project.

6. Click the Close button in the
VBE.

�

�

The macro appears
in the toolbar.
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Running a macro in the
Macros dialog box

1. Click the Tools menu, point to
Macros, and click Macros.

2. Click the Macro that you want
to run.

3. Click Run.

�

�

Running a macro in the
Visual Basic Editor

1. Click the Tools menu, point to
Macros, and click Visual
Basic Editor.

2. In the VBE Project window,
double-click ThisDocument or
the module containing the
macro that you want to run.

The Code window for that
module appears.

3. Position the cursor inside the
appropriate Sub procedure.

4. Click the VBE Run menu and
click Run Sub/UserForm.

�

�
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1. Show the toolbar to which
you want to add a new
command.

2. Click the Tools menu and
click Customize.

3. Click the Commands tab.

4. Click UIControls in the
Categories list.

5. Click New UIControl.

6. Click the type of UIControl
you want to create.

7. Click Create to create the
control without attaching code
to it. The name of the control
appears in the Commands
list. You can add code for the
control at another time.

If you want to start adding
code to the control right away,
click Create and Edit and skip
to step 11. �

�

�

Creating custom
commands with
VBA
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The new
control is
added to the
Commands
list.
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�

�

8. Click and drag the newly
created UIControl and drop it
on a toolbar or menu.

9. In the toolbar, right-click the
control and set its image,
caption, and other properties.

10. Right-click the new control
and click View Source.

The Visual Basic Editor
appears, displaying the
control’s code in the Code
window.

11. Click the dropdown arrow
and click one of the control’s
event procedures.

12. Type code for the event
procedure.

13. Repeat steps 11 and 12 until
all the appropriate event
procedures have been
coded.

14. Click the VBE File menu and
click Save Project.

15. Click the Close button in the
Visual Basic Editor.

16. If you clicked Create and Edit
in step 7, open the Custom-
ize dialog box, click the
Commands tab, and drag the
newly created UIControl from
the commands list to a
toolbar or menu.

17. Click Close in the Customize
dialog box.

�
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Working with UIControls
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Adding custom
commands
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1. Click the Tools menu and
click Customize.

2. Click Add from file.

3. Navigate to the file containing
the custom command.

4. Click the file and click Open.

The Added Objects dialog
box appears, reporting which
new objects have been
registered with ArcCatalog.

5. Click OK.

The custom commands
appear in the Commands list
for the appropriate category;
a new category may be
added to the Categories list.

6. Click Close in the Customize
dialog box.

�

	

The custom commands appear in the Commands list for the
appropriate category; a new category may be added to the list.
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1. Click the Tools menu and
click Customize.

2. Click the Options tab.

3. Click Update ArcID module.

4. Click Close.

Updating the
ArcID module
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Using VB’s code completion feature, you
can list the commands that have been
added to the ArcID module.
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1. Click the Tools menu and
click Customize.

2. Click the Options tab.

3. Click Change VBA Security.

4. Click the level of security you
want.

5. Click the Trusted Sources tab
to see a list of the names of
organizations or individuals
whose signed macros will be
allowed to run.

6. Click OK.

7. Click Close.

Changing VBA
security
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Locking customizations
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Using the
ArcObjects
Developer Help
system
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1. Click the Start button on the
Windows taskbar.

2. Point to Programs.

3. Point to ArcGIS.

4. Click ArcObjects Developer
Help.

The ArcObjects Developer
Help system appears.

The ArcObjects Developer Help system appears.
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