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Welcome to the ArcGIS Schematics Designer tutorial. This tutorial 
has been designed to assist you in your ArcGIS Schematics project 
conception. It will help you understand more about how to customize 
your schematic project—the entry point to access your schematic 
definition environment. This schematic project is a set of definitions 
and configurations, which references all primary schematic components 
managed by your schematics application.

Introducing the sample database’s content

A summary of the tutorial database
When the ArcGIS Schematics extension was installed on your computer, 
the C:\arcgis\ArcTutor\Schematics\Designer folder should have been 
created. This directory contains the Schematics_Designer_Tutorial.mdb 
on which this tutorial is based.
This sample database contains an electrical network. The data describing 
this network is organized into four tables: Station, Feeder, LV_Line, and 
HV_Line. The LV_Line and HV_Line tables list all the feature edges 
(links) of the network. The Station and Feeder tables contain all the 
network feature junctions (nodes).
The complete network comprises two parts: a high voltage part and a low 
voltage part that connect to each other.
• High voltage network: Feeder nodes compose a high voltage network. 

In the high voltage network, feeder nodes are connected to each other 
through high voltage links (HV_Line).

• Low voltage network: Station nodes compose a low voltage network. 
All station nodes depend on one unique feeder node that could be 
considered a root node for part of the low voltage network. Low 
voltage links connect a station to another station or a station to a 
feeder. In the latter case, the link that connects the station to the feeder 
connects the low voltage part of the network to the high voltage part.

Specifications for the tutorial schematic project
The purpose is to graphically display the electrical network data 
contained in the Schematics_Designer_Tutorial database. The final 
schematic project will be organized into three main types of schematic 
diagrams:
• The first will contain the complete network (low and high voltage 

parts) and will work with the Custom Query-Based Builder.
• The second will also work with the Custom Query-Based Builder 

and will allow the display of network data related to a single feeder 
subnetwork (that is, related to a given low voltage part of the network, 
each one is managed by one feeder node).

• The third will be a schematic diagram type based on the Standard 
Builder that will be used to generate schematic diagrams from any 
feature set selected or highlighted in an ArcMap document after a 
selection or a trace operation.

Tutorial database’s table of contents
The data model can be presented as follows:

Introducing the Schematics Designer tutorial
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Introducing the tutorial main steps

In this tutorial, the schematic project conception is organized into seven 
exercises:
• The first exercise’s purpose will be to create the schematic dataset that 

will contain all the schematic data related to the schematic project you 
will build and to edit the related schematic project within Schematics 
Designer.

• During the second exercise, you will become familiar with the 
schematic project’s main parameters and you will specify default 
values for these parameters.

• The third exercise’s purpose will be to create all schematic components 
required to display all network data contained in the sample database 
in a unique schematic diagram managed by the Custom Query-Based 
Builder.

• During the fourth exercise, you will learn how to animate and 
document network elements displayed in schematic diagrams 
according to some database field values.

• In the fifth exercise, you will examine the low voltage part of the 
network. The purpose will be to create new schematic components to 
display several schematic diagrams, including one for the low voltage 
subnetwork related to a given feeder.

• The sixth exercise concerns application behaviors. The purpose will 
be to create behaviors that impact schematic diagrams and schematic 
elements.

• In the last exercise, you will create a new schematic diagram type 
that works with the Standard Builder to generate on the fly schematic 
diagrams from any ArcMap selected set or trace result.

The Station table contains six fields:
• OBJECTID: Station identifier (number)• SHAPE: ESRI Binary Large 

Object (BLOB) field
• Name: Station name (string)
• Capacity: Station capacity (number)
• Type: Station type (a variable coded as A, B, C, D, E, or F)
• Feeder: Feeder OBJECTID to which the current station belongs (a 

variable coded as 1, 2, or 3)

The LV_Line table contains eight fields:
• OBJECTID: Low voltage line identifier (number)
• SHAPE: ESRI BLOB field
• FromJunctionType: Low voltage line’s origin node type (a variable 

coded as station or feeder depending on the type of the origin node)
• FromJunctionOID: Low voltage line’s origin identifier (number)
• ToJunctionType: Low voltage line’s extremity node type (a variable 

coded as station or feeder depending on the type of the extremity node)
• ToJunctionOID: Low voltage line’s extremity identifier (number)
• Rate: Ratio value associated with the low voltage line (number)
• Category: Low voltage line category (a variable coded as S, M, or B)

The Feeder table contains two fields:
• OBJECTID: Feeder node identifier (number)
• SHAPE: ESRI BLOB field

The HV_Line table contains six fields:
• OBJECTID: High voltage line identifier (number)
• SHAPE: ESRI BLOB field
• FromJunctionType: High voltage line’s origin node type (a variable 

coded as Station or Feeder depending on the type of the origin node)
• FromJunctionOID: High voltage line’s origin identifier (number)
• ToJunctionType: High voltage line’s extremity node type (a variable 

coded as station or feeder, depending on the type of the extremity 
node)

• ToJunctionOID: High Voltage line’s extremity identifier (number)



In this exercise, you will learn how to create the schematic dataset that 
will contain all the schematic data related to the schematic project you 
will build. Then, you will learn how to edit the related schematic project 
parameters within Schematics Designer.

Creating a schematic dataset

A schematic dataset resides in a personal or ArcSDE geodatabase; it’s 
the schematic equivalent of a geodatabase feature dataset. The schematic 
dataset acts as the entry point for your schematic application. A schematic 
dataset contains a collection of schematic diagram classes and schematic 
element classes that share the same application domain—for example, 
water, electrical, and so on.
ArcCatalog is the application used to create schematic datasets. To create 
a schematic dataset: 
1. Start ArcCatalog. 
2. Browse to the Schematics_Designer_Tutorial.mdb personal 

geodatabase stored in the C:\arcgis\ArcTutor\Schematics\Designer 
folder. 

3. Right-click this personal geodatabase, point to New and click 
Schematic Dataset. 

 A new schematic dataset appears in the Catalog tree.
4. Type a new name for the schematic dataset (“DesignerTutorial”, for 

example). 
5. Press Enter. 
Creating a schematic dataset in ArcCatalog automatically creates the 
associated schematic project where the components that specify the 
graphical parameters of your schematic application will be stored. These 
components can be edited and customized using Schematics Designer.

Editing the schematic project within Designer

A schematic project is a set of configurations that provides access to your 
application’s graphical components, including data sources, diagram 
types, element types, and behaviors.
To define the schematic diagram types and schematic element types 
related to a schematic dataset, you need to edit the schematic project 
associated with that schematic dataset within Schematics Designer:
1. Right-click the new schematic dataset in the Catalog tree and click 

Edit Project. 
The Schematics Designer application starts, loads the associated 
schematic project parameters in memory, and opens directly in Design 
mode.
When you are working in Design mode, all schematic project components 
already defined are displayed in the Designer Editor window. The table 
of contents (tree), on the left side of the window shows all the schematic 
components that have already been defined for the opened schematic 
project. The right side of the Designer Editor window shows the current 
state and values for all parameters that have been defined for the currently 
selected component.
Working in Design mode allows you to create and modify any project 
component’s parameters (diagram type, element type, and so forth). When 
components are created, a new entry corresponding to the newly created 
component is automatically created in the Designer tree.
To enable the Run mode when you are running in Design mode, click the 
Close button on the bottom right corner of the Designer Editor window. 
Working in Run mode allows you to test and visualize instantly the 
schematic project parameters you have just modified when running in 
Design mode: any parameter change is automatically taken into account 
and can be graphically visualized. To enable the Design mode when you 
are running in Run mode, click the Edit tool.

Exercise 1: Creating a schematic dataset and editing the schematic project
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The default parameters for the graphical display of the schematic 
elements are defined at the Schematic Project level. These include default 
node symbol, default flag symbol, default text size and text color, default 
selection style appearance, and other items.
When the Schematic Project entry is selected in the Designer tree, the 
right side of the window lists all the default project parameters. These 
parameters can be modified according to your needs. They are regrouped 
into three tabs:
• The General tab displays where all general graphical project 

parameters are stored.
• The Effects tab includes line, fill, and text effects used for graphic 

representations.
• The Highlighting tab regroups parameters related to the display style 

and mode for elements when they are selected in the diagrams.

In this exercise, default values will be set to:
• Represent the symbol of flags when no specific symbols are defined for 

their related flag model.
• Represent the symbol of nodes when no specific symbols are defined to 

represent them.
• Define the symbol scaling factor.
• Define the line effects (color, width) that will be used by default to 

represent the links.
• Define the text color and the text font that will be used by default to 

display a label.
• Define the selection style.

Defining the default symbol for flag

The Default Flag Symbol parameter available from the General tab will 
be the parameter used by default to represent a flag’s symbol when this 
parameter is defined.
1. Click anywhere on the Default Flag Symbol field.
2. Click the NgUSymbolEditor button  that displays to launch the     

CGM Symbol Editor and Vector Drawing tool.
3. Use the NgUSymbolEditor drawing tools to build your CGM symbol 

as desired.
4.  Click File and point to Save As. Enter the name that will reference 

your first symbol (“DefaultFlag”, in this example).
5.  Exit the NgUSymbolEditor (File > Exit menu).
The Default Flag Symbol field is automatically completed by the name of 
the symbol you have created.
Note: If you want more details about the NgUSymbolEditor drawing 
tools, please see The ‘NgUSymbolEditor tool’ topic in the Schematics 
Designer book of the ArcGIS Help system.

Exercise 2: Setting the schematic project’s default parameters
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Defining the default scaling

The Default Scaling parameter available from the General tab is the 
default scale factor that will be applied to the schematic diagram symbols 
or labels when their own scale parameters are not set.
1. Click the Default Scaling field.
2. Enter a value.
Note: The correct value for your schematic project Default Scaling factor 
is not easy to determine, and a value that is correct for one schematic 
project could be inappropriate for another schematic project. In fact, this  
value depends on your network coordinate system and how close to or far 
from each other your nodes are in your schematic view. Generally, you 
will have to test several values before finding the best one.

Defining the default symbol for node

The Default Node Symbol parameter available from the General tab is the 
parameter that is used by default to represent schematic nodes when their 
own Symbol parameter (defined for their related node element type) is not 
set.
To define this default symbol, follow the steps below:
1. Click the Default Node Symbol field. 
2. Click the NgUSymbolEditor button to launch the CGM Symbol Editor 

and Vector Drawing tool (NgUSymbolEditor).
3. Use the NgUSymbolEditor drawing tools to build your CGM symbol 

as desired and enter a name for the current symbol (File > Save As 
menu).

4. Exit the NgUSymbolEditor (File > Exit).
The Default Node Symbol field is automatically completed by the name 
of the symbol you have just created.
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Defining the default line effects

Parameters defining line effects that will be used by default to represent a 
link line when these effects are not defined at the link element type level 
are available from the Schematic Project Effects tab. They are assembled 
into the Line Effects subset of parameters.
1. Click the Effects tab.
2. Click the Line Color field that will define the default color for the 

lines, and click the color box that displays to launch the Table Color 
Editor

3. Choose or define a color.
4. Click OK to validate.
5. Click the Line Width field to specify the default width for the lines. 

Modify the value with the one you want.
6.  Click the desired default style for lines from the Line Style dropdown 

list.

Defining the default text effects

Parameters defining text effects that will be used by default to display the 
labels when these effects are not defined during the label definition, are 
available from the Schematic Project Effects tab. They are assembled into 
the Text Effects subset of parameters.
1. Click the Effects tab.
2. Click the Text Color field that will define the default color for the 

labels, and click the color box that displays to launch the Table Color 
Editor.

3. Choose or define a color and validate.
4. Click the Text Font field that will define the default text font for the 

labels.
5. Click one of the default fonts already defined from the dropdown 

list, or click the ellipse button displayed on the right to open the Font 
Editor. The Font Editor lists all fonts installed on your computer and 
allows you to choose the font you want.



8

Defining the selection style

Parameters defining the Selection Style are assembled on the Highlighting 
tab.
Three selection styles are available:
• With the Handle style, a selected schematic element is singled out by 

the display of its bounding box.
• With the Highlight style, a selected element is singled out by specific 

color, width, style, and fill.
• With the Handle And Highlight style, the two Handle and Highlight 

selection styles are combined.

When the Highlight or Handle And Highlight style is used, some line, 
fill, and text effects must be set to complete the selection style definition 
and the appearance of links, nodes, and labels when they are selected in a 
schematic view.
1. Choose Handle And Highlight from the Selection Style dropdown list.
2. To specify the color for the selected lines, click the Line Color 

parameter, click the color box to launch the Table Color Editor, and 
choose or define the desired color that will be used to highlight lines 
when they are selected.

3.  To define the selected lines’ width, click the Line Width parameter and 
enter the desired value.

4. For defining the effects for the selected fills, click Solid from the Fill 
Style dropdown list and define the Fill Color parameter. These fill 
attributes will be used to display the symbol fill of the nodes that will 
be selected.

5. To define the effects for the selected labels, click the color box that 
displays when clicking the Text Color field. In the Table Color Editor 
that opens, choose or define the color you want.

6. Click OK to validate.
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The  purpose of this exercise is to create the schematic components 
required to display all network data stored in the Schematics_Designer_
Tutorial database in a unique diagram. The diagram type that will 
implement this schematic diagram will work with the Custom Query 
Based Builder. 
With this predefined builder, you need to specify the queries that return 
the elements you want to be displayed in your diagrams.
Four main steps are required to create such diagrams:
1. Create the data source required to connect the network data.
2. Create the schematic diagram type that will implement the desired 

schematic diagram.
3. Create the node element types that will implement the node elements 

contained in the schematic diagram.
4. Create the link element types that will implement the link elements 

contained in the schematic diagram.

Creating the data source

A data source is related to a database where network elements that you 
want to be displayed in your schematic diagrams are stored.
By default, when you have created the schematic dataset in the 
Schematics_Designer_Tutorial database, Schematics has automatically 
created a data source named CURRENTDS. The CURRENTDS data 
source is an ESRI Access GDB Datasource that connects the geodatabase, 
which contains the schematic dataset related to the schematic project 
currently open in Designer. This data source is always available in the 
Designer tree; it displays under the Data Sources entry. You can use 
the CURRENTDS data source when you create new element types or 
diagram types related to data stored in your geodatabase. But if you need 
to connect your geodatabase using a specific provider or if you need to 
connect another database (for example, a database that contains inside 
plants’ data), you will have to create a new data source.
ESRI Access GDB data source type can’t correctly interpret SQL queries 
that join several tables. In this tutorial, you will have to specify such 
queries; you will start by creating a new ADO extended connection data 
source using the Microsoft Jet 4.0 OLE DB provider. Here are the steps 
required to create this new data source:

1. Right-click Data Sources in the Designer tree and point to Add Data 
Source. 
The New Data Source dialog box opens.

2. Type a name for the new data source in the Name field 
(“TutorialDatasource”, for example).

3. Click ADO extended connection from the Type dropdown list.

4. Click Edit Connection to specify the connection parameters. 
The Microsoft Data Link Properties dialog box opens.

5. Click the Provider tab and click Microsoft Jet 4.0 OLE DB Provider 
from the list.

Exercise 3: Displaying all network data in a unique schematic diagram
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6. Click the Connection tab and click the ellipse button displayed on the 
right side of the Select or enter a database name area. 
The Select Access Database dialog box opens.

7. Browse to the Schematics_Designer_Tutorial.mdb database, and 
click Open. The Select Access Database dialog box closes. 
The Data Link Properties dialog box should appear as follows: 

8. Click Test Connection if you want to check that the connection 
parameters are correctly specified. Click OK to close the Data Link 
Properties dialog box.

9. Click OK to close the New Data Source dialog box. The newly 
created datasource should display in the Designer tree as follows:

Creating the first schematic diagram type

A network is made up of nodes and links. These nodes and links are 
displayed in different generic structures known as diagrams. A diagram 
is a collection of schematic views and is related to a single schematic 
project. A diagram type is a template that brings together a set of 
diagrams that have common characteristics. More than one diagram type 
can be created for a schematic project. Typically, one diagram type can be 
defined for a specific view of the network. For example, a diagram type is 
defined for a schematic of the electric network of primaries and switches, 
and a second diagram type is defined for a schematic of the internal 
schema (inside plant) of the devices. You can either create a diagram type 
that inherits another diagram type or create a diagram type that inherits no 
parent diagram type.
The purpose of this step is to define the schematic diagram type that will 
implement a unique schematic diagram; that is, the schematic diagram 
where all network data stored in the Schematics_Designer_Tutorial.mdb 
database will be displayed.
1. Right-click Diagram Types in the Designer tree and click Create. 

The Create Diagram Type dialog box opens.
2. Type the name that will be used to reference the new diagram type 

(“All”, for example).
Since no diagram has already been created, this new diagram type cannot 
inherit from another one (no Parent Name can be set).

3. Click OK to validate.
The new diagram type subentry is automatically created below the 
Diagram Types main entry in the Designer tree.
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9. Click NAME from the Identifier area and click the Up arrow to 
remove the NAME field from this area.

10. Click OK to close the Identifier Editor dialog box. 
The Identifier field on your diagram type’s General tab should now 
be empty.

11. Specify no datasource for the Data Source field.
12. Expand the Attributes entry under the Diagram Types entry, right-

click DIAGRAMCLASSID, and click Delete. This predefined 
attribute is removed.

13. Proceed in the same way to remove the DIAGRAMOBJECTID 
second predefined attribute.

At the end of these steps, your Diagram Types entry should display as 
follows:

When a new diagram type is created, Schematics specifies the Standard 
Builder by default for the Schematic Builder field; it automatically creates 
the two DIAGRAMCLASSID and DIAGRAMOBJECTID attributes and 
sets some parameters for the newly created diagram type.
In this exercise, you have to create a schematic diagram type that will 
work with the Custom Query Based builder. Moreover, because this 
diagram type will implement a unique schematic diagram, no query,  
identifier, and datasource are required. 
4. Change Standard Builder to Custom Query-Based Builder from the 

Schematic Builder dropdown list.
5.  Click the Query field and click the Ellipsis button that displays. An 

error message saying that an input table cannot be found should 
display. Click OK to close this error message. The Query Editor 
dialog box opens.

6. Click the SELECT * FROM SCH1D_All query specified in the 
Query area and remove it.

7. Click OK to close the Query Editor dialog box. 
The Query field on your diagram type’s General tab should now be 
empty.

8. Click the Type Name field and click the Ellipsis button that displays 
to open the Identifier Editor dialog box.
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Creating the node element types

An ArcGIS junction is implemented as a Schematics node element. 
The node represents a device or other point feature of a network. It 
is displayed as a symbol and is assigned graphic (color, fill style, and 
so forth), geometric (scaling factor, rotation, and so forth), and visual 
(visibility, highlighted state, and so forth) parameters. Any node is 
implemented by a schematic node element type that holds the common 
property of a set of nodes.
The purpose of the following steps is to create two schematic node 
element types: One to implement the display of all records stored in the 
Station table and another to implement the Feeder table’s records.
Creating the StationNodes element type 
1. Right-click Element Types in the Designer tree and click Create. 

The Create Element Type dialog box opens.
2. Enter the name that will be used to reference your first schematic 

node element type (“StationNodes”, in this example).
3. Click Node from the Type dropdown list.
Since no node element type has already been created for this schematic 
project, this new node element type cannot inherit from another one (no 
Parent Name can be set).
4. Keep the Element Group option checked by default to ensure you can 

customize your element type display afterward.

The preview window shows the symbol that will be used by default to 
represent all nodes of this type. In this case, it is the schematic project’s 
default node symbol you defined in Exercise 2.
The purpose now is to set the parameters for this new node element 
type and, in particular, set parameters to query and identify each node 
this StationNodes element type will implement. These parameters are 
available from the General tab, and they are assembled into the Data 
subset of parameters.
6. Click the General tab and click the CURRENTDS datasource from 

the Data Source dropdown list.
7. Click the Query field and click the Ellipsis button that displays. 

The Query Editor dialog box opens.
8. From the Tables list, click the Station table where all records 

corresponding to the network stations are stored.
9. Click All Records. 

The SELECT * FROM Station SQL query automatically displays in 
the Query area.

10. Click OK to validate.
The Query Editor dialog box closes. The specified query automatically 
displays on the General tab’s Query parameter field.

5. Click OK to validate.
The new node element type subentry is automatically created below the 
Element Types main entry in the Designer tree.
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11. Click the General tab’s Identifier field and click the Ellipsis button 
that displays. 
The Identifier Editor dialog box opens.

The Fields list on the Identifier Editor dialog box displays all fields 
returned by the query you have just specified. These fields can be used to 
identify the schematic elements of the element type.
The SCH_DiagramType and SCH_DiagramName items are also 
available at the end of this list. These predefined items are related to the 
diagram type name and the diagram name where schematic elements 
will be displayed. They can help you ensure that each element identifier 
contained in your schematic diagram is unique.
In this example, you will identify each StationNodes node by 
concatenating the diagram type name, the diagram name, the Station 
string, and the OBJECTID field values.
Note: Using the Station string in the node identifier building is useful in 
this example because the FromJunctionType and ToJunctionType fields 
available from the tables of links specify whether each link connects a 
Station type node or a Feeder type node. By using the Station string in 
your StationNodes nodes’ identifiers, it will be easy to specify the origin 
and extremity node for your links afterward.
12. Double-click the SCH_DiagramType and SCH_DiagramName 

fields available from the Fields list so these two items appear in the 
Identifier list.

13. Type “Station” in the central text zone and validate this string by 
clicking the Down arrow.

14. Double-click the OBJECTID field from the Fields list to select it and 
click OK.

The specified items automatically display in the General tab’s Identifier 
parameter field.
When specifying Identifier for an element type, don’t forget these two 
rules:
• All the elements related to an element type must be identifiable as a 

unique element.
• Two elements of the same type (node, link, and so forth) cannot have 

the same identifier when they are found in the same diagram.

Note: For more information about the Query Editor and Identifier Editor, 
open the Schematics Designer book in the ArcGIS Help System, load 

Previously, you created the All schematic diagram type that will 
implement one schematic diagram where all network data stored in the 
Schematics_Designer_Tutorial database will be displayed. The purpose 
now is to specify that the nodes implemented by the StationNodes node 
element type you have just defined must be displayed in this schematic 
diagram. To specify the schematic elements you want to be contained in a 
schematic diagram, you must associate the desired element types with this 
diagram type:
15. Right-click the All diagram type entry in the Designer tree and click 

Associate an Element type. 
The Create Association dialog box automatically opens.

the Setting the node element type General parameters topic and click the 
Query Editor and Identifier Editor hyperlinks in the Data section.
At the end of these steps, your first node element type entry should 
display as follows:
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It is time now to test that your StationNodes node correctly displays in 
your schematic diagram.
18. Click the Save button displayed at the bottom right corner of the 

Designer Editor window to save all the defined parameters.
19. Click the Close button to close the Designer Editor window as well 

as to stop the Design mode. You are now in Run mode.
20. Click File and point to Diagram Toolbar. 

The Diagram toolbar displays.
21. Click the Open Diagrams button . 

The Select Diagram To Open dialog box opens. The only diagram 
type, All, is available from the Diagram Type dropdown list, and the 
All diagram is available from the Diagram Name dropdown list.

22. Click OK to validate.

16. Click the StationNodes element type from the Name dropdown list.
17. Click OK to validate.
The new Associated Element Types tab should appear for your diagram 
type. This tab lists all the schematic element types that are currently 
associated with a diagram type. At the same time, for your StationNodes 
element type, the new Associated Diagram Types tab has been created; 
this tab lists all the diagram types with which that element type is 
associated.

Your first schematic diagram opens. Since no geometric attributes are 
defined for any node (that is, X Y coordinates are not specified for each 
node), Designer automatically places the nodes on a default grid.
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Creating the FeederNodes element type
The purpose now is to create the second node element type that will 
implement the nodes related to the records stored in the Feeder table.  
Before creating this new schematic component, you must stop the Run 
mode and switch to Design mode: 
1. Close the open diagram and click the Edit button  to reedit your 

schematic project parameters.
Then, create your new node element type as follows:
2. Right-click Element Types in the Designer tree and click Create.
3. In the Create Element Type dialog box that opens, type a name for 

the new node element type (“FeederNodes”, for example).
4.  Click Node from the Type dropdown list.
5. Ensure that the Element Group check box is checked and click OK.
Under the Element Types entry, the new FeederNodes node element type 
entry should have been automatically created.
Now, complete your FeederNodes node element type definition by 
specifying the data source and the query that will return all feeder nodes 
stored in the Schematics_Designer_Tutorial database and by identifying 
all nodes the FeederNodes node element type will implement.
6. Click FeederNodes in the Designer tree.
7. Click CURRENTDS from the Data Source dropdown list.
8. Click the Query parameter field and click the Ellipsis button that 

displays to open the Query Editor dialog box.
9. Double-click the Feeder table from the Tables list so the SELECT * 

FROM Feeder SQL query automatically appears in the Query field.
10. Click OK. 

The Query Editor dialog box closes.
11. Click the Identifier parameter field and click the Ellipsis button that 

displays to open the Identifer Editor dialog box.
As you had previously done for the StationNodes element type identifier, 
each FeederNodes node will be identified by concatenating the diagram 
type name and the diagram name where it will be displayed, the Feeder 
string, and the OBJECTID field values.

 12. Double-click the SCH_DiagramType and SCH_DiagramName items 
available at the end of the Fields list so these two fields appear in the 
Identifier list.

13. Type “Feeder” in the central text zone and validate by clicking the 
Down arrow.

14. Double-click the OBJECTID field from the Fields list to add this 
field to the Identifier list.

15. Click OK. 
The Identifier Editor dialog box closes.

At the end of these steps, the General tab related to your new 
FeederNodes element type should display as follows:
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For the StationNodes element type, for instance, no specific CGM symbol 
has been defined to represent station nodes, so the default symbol defined 
at the Schematic Project level is the symbol used by default. For the 
FeederNodes element type, a specific CGM symbol will be created. This 
symbol is defined when the Symbol Name parameter available from the 
General tab is set.
16. Click the Symbol Name parameter field and click the 

NgUSymbolEditor button  that displays to launch the CGM 
Symbol Editor and Vector Drawing tool.

17. Draw your symbol.
18. Click File and click Save.
19. Enter a name for the newly created symbol.

20. Click File and click Exit. 
The NgUSymbolEditor drawing tools toolbox closes.

The Symbol Name field on the FeederNodes General tab is automatically 
completed by the name of the symbol you have created. The Preview 
subwindow on the left corner of the Designer Editor window shows this 
new symbol. The General tab related to your Feeders node type should 
appear as follows:

You must now associate the newly created FeederNodes element type 
with the All diagram type so that all nodes (station and feeder) stored in 
the Schematics_Designer_Tutorial database display in the diagram that 
the All diagram type implements:
21. Right-click the All diagram type entry and click Associate an 

Element Type.
22. Click FeederNodes from the Name dropdown list and validate.
The FeederNodes item automatically adds onto the Associated Element 
Types tab related to the All diagram type.
23. Click Save to save the newly defined parameters. 

If you want to test that the nodes implemented by the new FeederNodes 
element type correctly display in your schematic diagram, close the 
Designer Editor window and click the Open Diagrams button. Click the 
All diagram from the Select Diagram To Open dialog box that displays 
and validate. The All schematic diagram should appear as follows:
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Creating the link element types

An ArcGIS edge is implemented as a Schematics link element. The link 
represents an edge of a network. A link is represented either by a direct 
single line segment or by several line segments passing through one or 
more link points known as vertices. Line patterns and line styles (color, 
style, width) can be applied to links to refine their graphical display. 
Any link is implemented by a schematic link element type that holds the 
common property of a set of links.
The purpose of the following steps is to create two schematic link element 
types: One to implement the display of all records stored in the LV_Line 
table and another to implement the HV_Line table’s records.
Creating the LV_LineLinks element type 
1. Right-click Element Types in the Designer tree and click Create. 

The Create Element Type dialog box opens.
2. Type a name for the link element type (“LV_LineLinks”, for 

example).
3. Click Link from the Type dropdown list.Close the open diagram and click the Edit button to switch to Design 

mode.

4. Ensure the Element Group check box is checked and click OK.
Under the Element Types entry, the new LV_LineLinks element type 
entry should have been automatically created. The preview window 
shows the link appearance for the links of this type. Since no specific 
values are specified for the line display, the schematic project’s default 
parameter values set for lines are used.
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The purpose now is to set the parameters for this new link element type 
and, in particular, set parameters to query and identify each link this 
LV_LineLinks element type will implement. These parameters are 
available from the General tab, and they are assembled into the Data 
subset of parameters.
5. Click LV_LineLinks under the Element Types main entry.
6. Click CURRENTDS from the Data Source dropdown list.
7. Click the Query parameter field and click the Ellipsis button that 

displays to open the Query Editor dialog box.
8. From the Tables list, click the LV_Line table where all records 

corresponding to the network LV_Line links are stored.
9. Click All Records. 

The SELECT * FROM LV_Line SQL query automatically displays 
in the Query area.

10. Click OK to validate and close the Query Editor dialog box.
The specified query automatically displays in the General tab’s Query 
parameter field.

11. Click the Identifier field and click the Ellipsis button that displays. 
The Identifier Editor dialog box opens.

To be homogeneous with the node elements identifying process, each 
LV_LineLinks element identifier will be built according to the same 
format: the diagram type name, the diagram name, the  LV_Line string 
value and the OBJECTID field values will be concatenated to build the 
identifiers. 
12. Double-click the SCH_DiagramType and SCH_DiagramName items 

available at the end of the Fields list so these two items appear in the 
Identifier list.

13. Type “LV_Line” in the central text zone and validate this string by 
clicking the Down arrow.

14. Double-click the OBJECTID field from the Fields list to select it and 
click OK.

The Identifier Editor dialog box closes and the specified items 
automatically display in the General tab’s Identifier field.
At the end of these steps, the General tab related to the LV_LineLinks 
element type should display as follows:
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Suppose that you want to test the display of your network. Even if you 
associate your new link element type with your schematic diagram type 
(this step is essential to display your new links), your network will appear 
as follows:

Note that even though the links appear in the Legend subwindow, they 
are not displayed. The schematic links’ display is conditioned by their 
topological properties; that is, origin and extremity schematic nodes must 
be specified to display a schematic link. To specify this information, you 
will have to create two specific attributes for your link element type. 
These attributes must be created with the OriginNode and ExtremityNode 
predefined names. When such attributes are created for a link element 
type, their values should return the origin node identifier and the 
extremity node identifier that connect each link of this element type. 
The purpose of the following steps is to define these two compulsory 
attributes for the LV_LineLinks element type:
15. Right-click LV_LineLinks in the Designer tree and click Create 

Attribute. 
The Create Element Type Attribute dialog box opens.

16. Click OriginNode from the Name dropdown list.
Then, specify the type of the attribute. In this case, because origin node 
identifiers can be retrieved from the fields stored in the 
LV_Line table and since these fields are returned by the query defined for 
the LV_LineLinks element type, you have to create a Field Attribute.

17. Click Field Attribute from the Type dropdown list.

18. Click OK.
The Create Element Type Attribute dialog box closes. 
A new Attributes entry is automatically created below the LV_LineLinks 
element type entry, and the OriginNode newly created attribute is 
referenced below this new entry.
Then, complete the attribute definition by setting the field or the set of 
fields returned by the LV_LineLinks element type’s query that will be 
merged to compute each origin node identifier. The OriginNode attribute 
format should follow the node identifier format. In this example, each 
node identifier merges its diagram type name, its diagram name, a string 
value corresponding to the type of node (Station or Feeder), and its 
OBJECTID field value. The OriginNode attribute values must be merged 
with this information:
19. Click the Field Name field available from the General tab of the 

OriginNode attribute and click the Ellipsis button that displays. 
The Identifier Editor dialog box opens.

20. Double-click the SCH_DiagramType and SCH_DiagramName items 
at the end of the Fields list so these two items appear in the Identifier 
list.

21. Double-click FromJunctionType from the Fields list so this specific 
field takes part in the identifying process (this field, stored in the 
LV_Line table, identifies the link’s origin node type; that is, Station 
or Feeder node).

22. Repeat this operation with the FromJunctionOID field (this field, 
stored in the LV_Line table, identifies the link’s origin node 
OBJECTID). 

23. Click OK to validate.
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Then, following the same process, you will create the ExtremityNode 
attribute.
24. Right-click LV_LineLinks and click Create Attribute to open the 

Create Element Type Attribute dialog box.
25. Click ExtremityNode from the Name dropdown list.
26. Ensure the Field Attribute value is selected in the Type dropdown list 

and click OK.
Then on the General tab related to the newly created OriginNode 
attribute’s entry:
27. Click the Field Name field and click the Ellipsis button that displays 

so the Identifier Editor dialog box opens.
28. Double-click the SCH_DiagramType and SCH_DiagramName items 

available at the end of the Fields list so these two items appear in the 
Identifier list.

29. Double-click ToJunctionType from the Fields list so this specific field 
takes part in the identifying process (this field, stored in the LV_Line 
table, identifies the link’s extremity node type; that is, Station or 
Feeder node).

30. Repeat this operation with the ToJunctionOID field (this field, 
stored in the LV_Line table, identifies the link’s extremity node 
OBJECTID). 

31. Click OK to validate.
The ExtremityNode attribute definition is now complete.

The LV_LineLinks element type definition is now complete. Now you 
only need to associate this new link element type with the All diagram 
type so the links implemented by the LV_LineLinks element type are 
displayed in the diagram implemented by the All diagram type.
As previously done when you associated your element node types with 
your diagram type:
32. Right-click the All diagram type entry in the Designer tree and click 

Associate an Element Type.
33. Click the LV_LineLinks from the Name dropdown list and validate.
The LV_LineLinks item automatically adds onto the All diagram type’s 
Associated Element Types tab.
If you switch to Run mode and open the All diagram, it should display as 
follows:

At the end of these steps, the OriginNode attribute’s General tab should 
display as follows:
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Creating the HV_LineLinks element type
The purpose now is to create the second link element type that will 
implement the links related to the records stored in the HV_Line table. 
Because this new link element type definition will be very close to the 
LV_LineLinks element type you have just created, there is a quick way to 
proceed by copying the LV_LineLinks element type defintion:
1. If you are in Run mode, start by closing the open diagram and 

clicking the Edit button to switch to Design mode.
2. Right-click LV_LineLinks in the Designer tree and click Copy. 

The Copy Element Type dialog box opens.
3. Keep the Parent Name field empty.
4. Type a name for your new link element type (“HV_LineLinks”, in 

this example).

5. Click OK.
The Copy Element Type dialog box closes. The new HV_LineLinks 
element type entry displays under the Element Types entry in the 
Designer tree.
All general parameters (query, identifier), and attributes defined for the 
LV_LineLinks element type from which the new HV_LineLinks element 
type has been copied are automatically reported. The HV_LineLinks 
element type entry presents as follows:

You must now modify the definition of the HV_LineLinks element type 
so it is related to the HV_Line table instead of the LV_Link table.

6. Click the HV_LineLinks element type’s General tab.
7. The copied data source is OK.
8. Then, notice the Query field. The copied query returns all the links 

stored in the LV_Line table. You must modify this query so it returns 
all the links stored in the HV_Link table. Click the Query parameter 
field and click the ellipse button that displays to open the Query 
Editor dialog box.

9. Remove the query from the Query field.
10. Double-click the HV_Line table from the Tables list so the SELECT 

* FROM HV_Line SQL query automatically appears in the Query 
area.

11. Click OK to validate. 
The Query Editor dialog box closes. The Query field value on the 
HV_LineLinks’ General tab is updated with the newly specified 
query.

As you had done for all previously defined element types, each  
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HV_LineLinks link will be identified by concatenating the diagram type 
name and the diagram name where it will be displayed, the HV_Line 
string, and the OBJECTID field values. The copied Identifier must be 
modified:
12. Click the Identifier parameter field and click the Ellipsis button that 

displays to open the Identifier Editor dialog box.
13. Select the OBJECTID item from the Identifier list and click the Up 

arrow to remove the item from the list.
14. Proceed in the same way to remove the LV_Line item from the 

Identifier list. 
Then, keep both SCH_DiagramType and SCH_DiagramName items 
in the Identifier list and complete the definition as follows:

15. Type “HV_Line” in the central text zone and validate by clicking the 
Down arrow.

16. Double-click the OBJECTID field from the Fields list to add this 
field to the Identifier list.

17. Click OK.
The Identifier Editor dialog box closes and the specified items 
automatically display in the General tab’s Identifier field. At the end of 
these steps, the General tab related to the HV_LineLinks element type 
should appear as follows: 

Now, notice the OriginNode and ExtremityNode attributes that have been 
copied for the HV_LineLinks element type during the copying operation. 
These OriginNode and ExtremityNode attribute formats must follow 
the node identifier format that, in this example, merges the diagram type 
name and the diagram name where these nodes display the Station or 
Feeder string, depending on the node type, and the node OBJECTID. 
All this information is available from the HV_Line table, and all the 
HV_Line table’s fields are returned by the query defined for the HV_
LineLinks element type. You only need to check that the fields used to 
generate these attributes are correctly specified:
18. From the OriginNode attribute’s General tab, the Field Name 

field indicates how the attribute values will be built. It is obtained 
by concatenating SCH_DiagramType, SCH_DiagramName, 
the FromJunctionType, and the FromJunction OID fields. The 
information is specified as expected.

19. Then, check the General tab’s Field Name field value for the 
ExtremityNode attribute. The concatened items are also specified as 
expected.

For the LV_LineLinks element type definition, no graphic effects had 
been defined to customize the link display. In this case, since no specific 
values are specified for the line color, line width, and line style parameters 
from the Effects tab, the schematic project’s default parameter values 
set for lines are used. For the HV_LineLinks element type, it could be 
interesting to customize its own line parameters so this link’s display is 
different from the LV_LineLinks links.
20. Click HV_LineLinks in the Designer tree and click the Effects tab.
21. Click the Line Color field and click the color box that displays to 

launch the Color editor.
22. Choose the desired color and click OK to validate. 

The Color Editor closes. The Line Color parameter on the Effects tab 
references the newly specified color.

23. Type a value in the Width Line field if you want to change the width 
of the lines for the HV_LineLinks element type.
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The HV_LineLinks element type definition should be correct. 
It only allows you to associate this new element type with the All diagram 
type before testing that your HV_LineLinks links correctly display in the 
diagram.
24. Right-click the All diagram type entry in the Designer tree and click 

Associate an Element Type.
25. Click HV_LineLinks from the Name dropdown list in the Create 

Association dialog box and click OK.
The HV_LineLinks item automatically adds onto the All diagram type’s 
Associated Element Types tab.

The following screenshot is a sample of the Effects tab’s content after 
these steps:

If you switch to Run mode and open the All diagram, it should display as 
follows:
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Displaying schematic elements using their geographical coordinates
Until now, since no geometric attribute is defined for the node element 
types (that is, X and Y coordinates are not specified for the schematic 
node elements), ArcGIS Schematics automatically places the nodes 
contained in the All diagram on a default grid. The purpose now is to 
create two specific attributes for the StationNodes and FeederNodes 
element types so the node elements implemented by these element 
types display at their geographical positions. These two attributes call 
InitialXPosition and InitialYPosition.
Generally, InitialXPosition and InitialYPosition attributes must be linked 
to specific fields stored in the database.
• If your nodes’ X and Y coordinates are clearly stored in two fields in 

your database, you can define these attributes, such as simple attribute 
fields.

• If no X and Y fields are clearly available in your ESRI geodatabase 
tables and if the data source used to return the node elements from this 
database is an ESRI Access GDB data source, ArcGIS Schematics can 
decode the information from the ESRI SHAPE field using a Geometry 
Attribute.

In this example, the StationNodes and FeederNodes element types’ 
specified queries return the node elements from the Station and Feeder 
tables using the CURRENTDS data source. As this data source is an 
ESRI Access GDB data source, you can create Geometry Attributes for 
defining the InitialXPosition and InitialYPosition attributes.
1. Right-click the FeederNodes element type entry and click Create 

Attribute. The Create Element Type Attribute dialog box opens.
2. From the Name dropdown list, click InitialXPosition.
3. From the Type dropdown list, click Geometry Attribute.

element type entry, and the newly created InitialXPosition attribute is  
referenced below this new entry.
5. From the new attribute’s General tab, keep the default value for the 

Type parameter XCoordinate.
6. From the Field Name dropdown list, click SHAPE and validate.
At the end of these steps, the InitialXPosition attribute’s General tab 
content should appear as follows:

4. Click OK.
The Create Element Type Attribute dialog box closes. A new Attributes 
entry is automatically created below the FeederNodes 

In a similar way, you need to repeat the process to create the 
InitialYPosition attribute required to display the FeederNodes according 
to their Y coordinates.
7. Right-click the FeederNodes element type entry and click Create 

Attribute.
8. From the Create Element Type Attribute dialog box and the Name 

dropdown list, click InitialYPosition, and from the Type dropdown 
list click Geometry Attribute.

9. Click OK.
10. From the InitialYPosition attribute’s General tab, from the Type 

dropdown list click YCoordinate value.
11. From the Field Name dropdown list, click SHAPE and validate.
The FeederNodes nodes should now be displayed at their geographical 
location.

You need to repeat these 11 steps for creating the same InitialXPosition 
and InitialYPosition attributes for the StationNodes element type so these 
nodes also display at their geographical location.
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Click Save to save the specified parameters.
You can now switch to Run mode and test the All diagram display. It 
should appear as follows:

For the link element types, there is also a specific attribute 
InitialListPoints that can be set so ArcGIS Schematics automatically 
displays vertices along links. 
To be interpreted correctly, the values returned by the InitialListPoints 
attribute must be strings formatted as follows: 
N;X1;Y1;…;Xi;Yi;...;XN;YN where:
• N is the number of vertices.
• Xi;Yi are the coordinates of point i.
• The “;” character works as a separator.

In the Schematics_Designer_Tutorial database, the ListPoints field 
containing such string values is available from the LV_Line links table. 
To use this database field, the InitialListPoints specific attribute must be 
created as follows:
1. In the Designer tree, right-click the LV_LineLinks element type entry 

and click Create Attribute. The Create Element Type Attribute dialog 
box opens.

2. From the Name dropdown list, click InitialListPoints. 
3. In the Type dropdown list, make sure that the Field Attribute value is 

selected. 

4. Click OK.
 The newly created InitialListPoints attribute displays under the 

Attributes entry related to the LV_LineLinks element type.
5. From this attribute’s General tab, click the Field Name field and click 

the Ellipsis button that displays.
6. Then, from the Identifier Editor dialog box that opens and from the 

Field list click the ListPoints field, and validate by clicking the down 
arrow button.

7. Click OK.
The Identifier Editor dialog box closes.
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At the end of these steps, the InitialListPoints attribute’s General tab 
should display as follows:

Click Save to save the specified parameters.
You can now switch to Run mode and test the All diagram display. It 
should appear as follows:
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In this exercise, you will learn how to graphically document and animate 
the schematic elements contained in your schematic diagram according 
to data stored in the database. You will become familiar with property 
creation and use.

Properties can be created and defined for all types of schematic elements, 
but only on one condition—the element type must be an element group. 
Properties are used to highlight the characteristics of a group of schematic 
elements. When they are enabled, they have a direct impact on the 
graphic representation of a network. The overall state of a network is 
determined by the values taken by the existing set of properties at a given 
time. The values taken by properties are often field values stored in the 
database table that the schematic element type query is based on. In this 
case, an attribute related to the desired database field must be defined and 
associated with the property. When this association is done, the schematic 
element’s database field value must be interpreted by the property to 
determine each element’s appearance.

This exercise is organized into three parts
• In the first part, you will create textual properties for labeling your 

schematic nodes and links. You will also learn about how to create and 
use flags to display these labels.

• The second part’s purpose is to create discrete properties. You will 
also learn about how to create a composed CGM symbol to display a 
node element type and use this composed symbol to specify interesting 
subsymbols’ effects to represent your discrete filters.

• During the third part, you will learn about bounded properties. You 
will also learn how to create pattern models that can be an interesting 
alternative to the basic effects usually used for displaying schematic 
links.

Displaying labels for StationNodes and 
LV_LineLinks

In this part, you will create two textual properties:
• The Label1 property will display the OBJECTID of each link in blue, 

centered below each link.
• The Label2 property will display a label for each station node. This 

label will merge the values of two database fields, Name and Feeder, 
formatted as follows: Name (F-Feeder).

 
The property label will be centered at the top of the station. 
Then, in a second step, you will create a flag model and will learn how 
flags can be attached on schematic nodes to display the Label2 property 
labels.

Displaying a label below the schematic links
The Label1 property will use the OBJECTID field returned by the 
LV_LineLinks query. Begin by creating an attribute corresponding to this 
OBJECTID field:
1. Right-click the LV_LineLinks entry in the Designer tree and click 

Create Attribute.
2. In the Create Element Type Attribute dialog box, enter the name of 

the new attribute in the Name field (“LVLine_OID”, in this example), 
click Field Attribute from the Type dropdown list, and click OK to 
validate.  

The Create Element Type dialog box closes. The LVLine_OID attribute 
is automatically referenced below the Attributes tree entry related to the 
LV_LineLinks element type.
3. Click the Field Name field on the General tab and click the Ellipsis 

button.
4. On the Identifier Editor dialog box, click the OBJECTID field from 

the Fields list, click the Down arrow button and click OK.
The Identifier Editor dialog box closes. The General tab related to the 
newly created LVLine_OID attribute should display as follows:

Exercise 4: Animating and documenting schematic elements display
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At the end of these steps, the Label1 textual property’s General tab should 
display as follows:

Now, you must create the textual property that will manage this attribute 
display:
5. Right-click the LV_LineLinks entry and click Create Property. 

The Create Property dialog box opens.
6. Type a name for the new property in the Property Name field 

(“Label1”, for example).

7. Since the default parameters set in this dialog box (Textual property 
type and String value type) are those you need, click OK. 
The Create Property dialog box closes.

Under the LV_LineLinks element type entry, a new Properties entry is 
automatically created. The newly created Label1 property appears under 
this main entry.  
Now, you need to relate the LVLine_OID attribute with the newly created 
property:
8. Click the General tab.
9. From the Attribute Name dropdown list, click LVLine_OID.
10. From the Legend Visibility dropdown list, click Invisible so this label 

doesn’t display in the Legend subwindow and in the ArcMap TOC 
(when the diagram will be open in the ArcMap environment).

Now, you need to specify how the label will display. The label must 
display in blue, centered below each link.
11. Click the Effects tab where the text effects are assembled.
12. From the Text Alignment dropdown list, click Top Center.
13. Click the Text Color field and click the color box that displays to 

launch the Color Editor. Choose the desired blue color and validate.
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14. Click Save to save the specified parameters.
If you want to test the Label1 property definition result, click Close and 
open the All diagram. The result should look similar to the following 
screenshot:

Switch to Design mode.

Displaying a label for the schematic nodes
The Label2 property must use the Name and Feeder field returned by 
the query specified for the StationNodes element type as formatted 
parameters to display a label formatted as follows: Name (F-Feeder). 
You must begin by creating the two attribute fields related to the station’s 
Name and station’s Feeder database field before building the final 
formatted attribute that will be displayed.
1. Right-click the StationNodes element type and click Create Attribute.
2. From the Create Element Type Attribute dialog box that opens, type 

StationName in the Name field, click Field Attribute from the Type 
dropdown list, and click OK to validate.

3. On the attribute’s General tab, click the Field Name field and click 
the Ellipsis button that displays.

4. From the Identifier Editor dialog box that opens, click the Name item 
from the Field’s list, click the Down arrow, and validate.

5. Proceed in the same way to create the StationFeeder attribute field 
related to the Station table’s Feeder field.
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As the label values you want to display for your station nodes are defined, 
you can now create the textual property that will manage this information 
display.
12. Right-click the StationNodes element type entry and click Create 

Property.
13. In the Create Property dialog box that opens, in the Name field,  type 

“Label2” and click OK.
Under the StationNodes element type entry, a new Properties entry is 
automatically created. The newly created Label2 property appears under 
this main entry. Now, you need to relate the StationLabel attribute with 
the newly created property.
14. Click the General tab.
15. From the Attribute Name dropdown list, click StationLabel .
16. From the Legend Visibility dropdown list, click Invisible so this label 

doesn’t display in the Legend subwindow and in the ArcMap TOC 
(when the diagram will be open in the ArcMap environment).

You must now create the formatted attribute that will concatenate the 
StationName and StationFeeder attributes to generate values formatted as 
follows: Name (F-Feeder).
6. Right-click the Attributes tree entry related to the StationNodes 

element type and click Create.
7. From the Create Element Type Attribute dialog box, in the Name 

field, type “StationLabel”, in the Type dropdown list click Formatted 
Attribute and click OK.

8. From the General tab related to the newly created attribute, you then 
need to specify the format that will be used to build the new attribute 
value (Format parameter). The format is generally a string combining 
words or characters in C language-compliant format. For example, 
if your formatted attribute must generate values by concatenating 
two attribute values, each one being related to a string field, and if 
these two attribute values must be separated by the “>>” characters, 
the format will be: %s >> %s. The %s is used to indicate that the 
attribute values are string values. Use %e for double and %d for 
integer.

 In this example, type %s (F-%s) for the Format parameter.
9. Press Enter to validate the Format parameter.
Designer automatically detects that two attributes are needed to build the 
formatted attribute. The new Attribute1 and Attribute2 parameter field are 
automatically displayed.
10. From the Attribute1 dropdown list, click StationName.
11. From the Attribute2 dropdown list, click StationFeeder. 
At the end of these steps, the StationLabel attribute’s General tab should 
display as follows:
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Then, you need to define the property label effects. In this example, the 
label must be centered at the top of each node.
17. From the Text Alignment dropdown list, click the Label2 property’s 

Effect tab and click Bottom Center. 
Note that Bottom Center text alignment means that the element node will 
appear centered at the bottom of the property label; that is, the label will 
be centered at the top of each node.

18. Click Save to save your schematic project parameters.
Close the Designer Editor window and test your network display. The 
result should be similar to the following screenshot:

As the size of the displayed labels is too large, you can redefine the Text 
Size parameter value available from the Schematic Project’s Effects tab 
so all label sizes are decreased.
19. Switch to Design mode.
20. In the Designer tree, click Schematic Project and click the Effects 

tab.
21. Type “0,2” in the Text Size field.
22. Save, close the Designer Editor window, and test the network display 

again.
 When the diagram is at full extent, the labels are invisible, but when 

zooming in on a set of elements, the labels appear.
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Displaying label in flags
In this part, you will have to modify the Label2 property defined for the 
StationNodes element type so this property’s labels are displayed through 
a flag attached to each station.
Begin this step by creating the flag model that will implement the flags 
into which the labels will display.
1. In the Designer tree expand Environment, right-click Flag Models, 

and click Create.
2. In the Create Flag Model dialog box that opens, in the Name field, 

type a name for the new flag model (“ClassicFlag”, in this example).

3. Click OK.
The new flag model tree entry is automatically created below the Flag 
Models entry. The Preview window shows the symbol that will be used 
by default to represent all flags of this type. The Default Flag Symbol 
(named DefaultFlag) you defined at the Schematic Project level in 
Exercise 2 displays in this window:

Now, you need to specify the flag model parameters:
4. On the General tab, change the Symbol Name parameter by creating 

a new CGM symbol, if desired. 
5. Click the Others tab, where parameters related to the flag geometry 

and visualization are available.

6. Type “2” for the Scaling parameter.
7. Specify how the flags will be displayed regarding the elements they 

attach to: type “45” for Shift Angle and “500” for Shift Distance.
8. Save your parameters definition.
At the end of these steps, the flag model’s Others tab should display as 
follows:

The purpose now is to modify the Label2 property so this new flag model 
is used to display the property label. Because no flag can be attached to 
the element of a group if no association is set between the flag model and 
this element group, you must first associate the new flag model with your 
StationNodes element group.
9. In the Designer tree, click the StationNodes element type entry and 

click Add Flag Model on the lower right corner of the Designer 
Editor window.

10. From the Name dropdown list, in the Add Flag Model dialog box that 
opens, click ClassicFlag.
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11. Click OK.
The Add Flag Model dialog box closes. A new Flag Models tab displays 
for the StationNodes element type. The Preview subwindow shows the 
new node appearance with its flag.

From this new FlagModels tab, you can specify parameters for the pole 
that will connect each flag to its attached element:
12. Click the ClassicFlag flag model line and click the Ellipsis button. 

The Pole Effect dialog box opens.
13. Click the Effects tab, click the Line Color parameter, and specify the 

color you want using the Color Editor.

14. Click Close. The Pole Effect dialog box closes.
Since the flag model is now associated with the desired StationNodes 
element group, it only allows you to modify the Label2 property 
parameters so that the property label displays in the flag.
15. In the Designer tree, click the Label2 property tree entry and click the 

General tab.
16. From the Display Flag Model dropdown list, click ClassicFlag.
17. Click the Effects tab from the Text Alignment parameter and click 

Half Center so labels display centered on their attached flags.

18. Click Save. Switch to Run mode and test the flags display.
After zooming in on a part of the All schematic diagram content, the 
result should be similar to the following screenshot:
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Creating discrete properties for StationNodes and LV_
LineLinks

In this part, you will learn a discrete property is a property whith specified 
values that belong to a finite set of numbers or of alphanumeric codes. 
The values for the property are generally returned by an attribute that 
must be associated with the property.
Two discrete properties will be created:
• You will first animate the low voltage links display according to the 

Category database field values. Each link is an S, M, or B category 
(for Small, Medium, or Big, respectively). A discrete property will be 
created, and display rules will be defined for the discrete filters based 
on these categories.

• Then, after defining a composed CGM symbol to represent the station 
nodes, you will learn how to define subsymbol effects to animate the 
station nodes display according to the Type database field values. Since 
this field stores discrete values (A, B, C, D, E, or F), a discrete property 
with six discrete filters (one for each value) will be created. Subsymbol 
display rules will then be defined for each discrete filter.

Animating the schematic links according to their category
The Category field returned by the LV_LineLinks element type query 
stores the category of each link. Each link is an S, M, or B category (for 
Small, Medium, or Big, respectively). 
In this section, you need to represent this information graphically. You 
will create the DisplayByCategory discrete property composed of three 
discrete filters with each filter corresponding to one category value. This 
property will display LV_LineLinks according to the Category field as 
follows:

Category Value Filter Graphic Effect
S Line Width: 1.0
M Line Width: 2.0
B Line Width: 4.0

Since the DisplayByCategory property will use the Category field values 
returned by the query, you must begin by creating an attribute field 
corresponding to this field.
1. Expand the Element Types entry, right-click LV_LineLinks, and click 

Create Attribute.

2. In the Create Element Type Attribute dialog box that opens, in the 
Name field  type a name for the attribute (“CategoryLine”, in this 
example), from the Type dropdown list click Field Attribute value 
and click OK.

Then, specify the attribute parameters.
3. Click the attribute’s General tab, click the Field Name parameter, and 

click the Ellipsis button to open the Identifier Editor dialog box.
4. From the Fields list, click Category, click the Down arrow to validate 

this field, and click OK.
At the end of these steps, the CategoryLine attribute’s General tab should 
display as follows:

Now, you will create the DisplayByCategory discrete property that will 
display each LV_LineLinks link according to the CategoryLine attribute 
value.
5. Right-click the Properties entry displayed below the LV_LineLinks 

element type and click Create.
6. In the Create Property dialog box that opens, in the Property Name 

field, enter “DisplayByCategory”, check the Discrete option and keep 
String for Value Type.
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7. Click OK. 
The Create Property dialog box closes.

Now, you have to associate this new property with the CategoryLine 
attribute.
8. From the DisplayByCategory property’s General tab, from the 

Attribute Name dropdown list, click CategoryLine.
Now, you are going to create the discrete filters related to each Category 
field’s value.
9. Click the Add Filter button displayed on the lower right corner of the 

Designer Editor window.
10. From the Add Discrete Filter dialog box that opens, type a name 

for the discrete filter (“Small”, for example), and specify the value 
for the discrete filter (“S”, in this example). This value is one of the 
values used by the Category field stored in the LV_Line table.

11. Click OK to validate the discrete filter definition.
The Filters tab appears for the DisplayByCategory property. A line 
corresponding to the discrete filter you have just created displays in this 
tab.
12. Repeat steps 9 through 11 to create two new discrete filters for the M 

and B values of the Category field database.
At the end of these steps, the Filters tab should display as follows:

Now, you need to define the graphical effects related to each discrete 
filter.
13. Click the Filters tab, click the first discrete filter parameter line 

(Small filter) and click the Ellipsis button that displays.
The Filter Effects dialog box opens. The links that will verify this Small 
discrete filter must display with line width of 1.0.
14. On the Filter Effects dialog box, click the Effects tab and type “1,0” 

in the Line Width field.

15. Click Close to validate this parameter and close the Filter Effects 
dialog box.
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16. Repeat steps 13 through 15 to define the effects related to Medium 
and Big discrete filters as follows:

• For the Line Width parameter field related to the Medium filter, type 
“2,0 “

• For the Line Width parameter field related to the Big filter, type “4,0”. 

17. Click Save.
If you test the All diagram content display, it should appear as follows:

Animating the schematic nodes according to their type
The Type field returned by the StationNodes element type query stores 
the type of each station. Each station node is either an A, B, C, D, E, or F 
type. The purpose of this section is to create the DisplayByType discrete 
property composed of six discrete filters, with each filter corresponding to 
one Type value.
In this example, you will create a CGM symbol based on the default 
node symbol you have created during the second exercise for which 
you will add two subsymbols. This composite symbol will be used by 
default to represent the StationNodes elements. Then, when defining 
the graphic effects related to the six discrete filters you create, you will 
have interesting alternatives for representing the filters by specifying 
subsymbol effects. The following table lists the graphic effects to specify 
for each discrete filter:

Type Value Filter Graphic Effects
A The first subsymbol will be invisible.
B The second subsymbol will be invisible.
C The first subsymbol will be invisible; the second one will 

be rotated 90 degrees, and its fill color will be changed.
D The two subsymbols will be invisible. The fill color of the 

basic main symbol will be changed.
E The two subsymbols will both be rotated 45 degrees.
F A new CGM symbol will be used to represent this type of 

station.
Begin by creating the composite CGM symbol. As the StationNodes 
element type is represented by the default node symbol, specify this new 
composed symbol for representing StationNodes.
1. Expand the Element Types entry and in the Designer tree click 

StationNodes.
2. Click the StationNodes’ General tab, click the Symbol Name field, 

and click the NgUSymbolEditor button  that displays to launch 
the CGM Symbol Editor and Vector Drawing tool.

Begin with the creation of the first subsymbol:
3. Click the Insert Rectangle button and draw a green rectangle as in the 

following screenshot.
 

For a better understanding of the other exercises, you will temporarily 
disable the display of the ClassicFlag.
18. In the Designer tree, click StationNodes and click the Flag Models 

tab. Click the ClassicFlag parameter line and click Remove Flag 
Model.

19. Click the Label2 entry and deselect ClassicFlag from the Display 
Flag Model field.

20. Click Save.
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8. Click OK. The Symbol Browser dialog box closes.
9. From the Import dialog box that displays, keep the Import graphics 

option checked and click OK. The symbol related to the DefaultNode 
CGM symbol displays.

You must now insert the first subsymbol you have created.
10. Click Insert, point to SubSymbol and click Internal SubSymbol.
11. From the Symbol Browser dialog box that opens, click SubSymbol1.
12. Click OK.
The SubSymbol1 inserts.
13. Repeat steps 10 through 12 to insert the second subsymbol.

Now, you will create the composite CGM symbol. This symbol will be 
based on the DefaultNode CGM symbol built during the second exercise 
and will combine the two subsymbols you have just created.
5. Click File and click New.
6. Click File and click Import.
7. From the Symbol Browser dialog box that opens, select the 

DefaultNode CGM symbol.

Note: To change the rectangle color fill, double-click the newly created 
rectangle to open the Graphic Attributes dialog box; click the Fill 
Attributes tab, and change the Color parameter.
Click File, click Save, type a name for the first subsymbol 
(“SubSymbol1”, for example), and validate. 

Then, create the second subsymbol.
4. Click File and click New. Click the Insert Rectangle button and draw 

a pink rectangle as in the following screenshot. Save this new symbol 
(as “SubSymbol2”, for example). 
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15. Exit the NgUSymbolEditor drawing tool.
The newly composed symbol is automatically used as the StationNodes  
default symbol.
The Sub Symbols tab, which contains all subsymbols that comprise this 
symbol, appears among the other tabs.

14. Save your composed CGM symbol. Now, you will create the DisplayByType discrete property.
As this discrete property will be based on the Type field values stored 
in the Station table, begin by creating the attribute field related to this 
database field.
16. Right-click the StationNodes element type entry and click Create 

Attribute.
17. On the Create Element Type Attribute dialog box that opens, in 

the Name field type a name for the attribute (“TypeStation”, in this 
example), from the Type dropdown list, click Field Attribute value 
and click OK.

18. Click the attribute’s General tab, click the Field Name parameter, and 
click the Ellipsis button to open the Identifier Editor dialog box.

19. From the Fields list, click Type, click the Down arrow to validate this 
field, and click OK.

At the end of these steps, the TypeStation  General tab should display as 
follows:

Now, you will create the DisplayByType discrete property that will 
display each StationNodes node according to the TypeStation attribute 
value.
20. Below the StationNodes element type, right-click Properties and 

click Create.
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21. In the Create Property dialog box that opens, in the Property Name 
field  enter “DisplayByType”, check the Discrete option, keep String 
for Value Type, and validate.

The Create Property dialog box closes.
22. You must now associate the property with the TypeStation attribute.
From the DisplayByType General tab, from the Attribute Name dropdown 
list, click TypeStation.

Now, you will define the graphic effects that will represent each discrete 
filter.
To define graphical effects related to a filter, you will need to click the 
Filters tab and choose the desired discrete filter parameter. Then, by 
clicking the Ellipsis button displayed at the end of this parameter line, the 
Filter Effects form will automatically open.
In this case, as the station symbol comprises subsymbols, a Sub Symbols 
tab containing all subsymbols that compose the StationNodes symbol will 
be available from the Filter Effects dialog box.
As the filter effects you need to specify will work on subsymbols, the Sub 
Symbols tab will be the central tab of the exercise.

Now, create the discrete filters related to each Type field’s value.
23. Click the Add Filter button displayed on the lower right corner of the 

Designer Editor window.
24. From the Add Discrete Filter dialog box that opens, type a name for 

the discrete filter (“Type A”, for example) and specify the first value 
for the discrete filter (“A”, in this example). This value is one of the 
values taken by the Type field stored in the Station table.

25. Click OK to validate the discrete filter definition.
The Filters tab containing the first created discrete filter appears for the 
DisplayByType property.
26. Repeat steps 23 through 25 to create five new discrete filters for the 

B, C, D, E, and F values of the Type field database.
At the end of these steps, the Filters tab should display as follows:
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31. Click OK. The Sub Symbol Effect dialog box closes.
32. Close the Filter Effects dialog box. 

37. Click OK to close the Sub Symbol Effect dialog box.
38. Close the Filter Effects dialog box.

Then, specify the Type B filter effects to set the second subsymbol as 
invisible.
33. On the Filters tab, click the Type B discrete filter and click the 

Ellipsis button. 
34. From the Filter Effects dialog box, click the Sub Symbols tab. 
35. Double-click the line corresponding to SubSymbol2 and click the 

Ellipsis button that displays.
36. Click the Others tab and from the Visibility dropdown list click 

Invisible.

Start with the Type A filter to set the first subsymbol as invisible.
27. From the Filters tab, click the Type A discrete filter and click the 

Ellipsis button that displays to open the Filter Effects dialog box. 
28. As the station symbol comprises subsymbols, a Sub Symbols tab 

containing all subsymbols that compose the StationNodes symbol is 
available from the Filter Effects dialog box. Click the Sub Symbol 
tab.

29. Double-click the line corresponding to the SubSymbol1 and click the 
Ellipsis button that displays.

The Sub Symbol Effect dialog box related to SubSymbol1 opens.
30. Click the Others tab and from the Visibility dropdown list click 

Invisible.
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45. Click OK to close the Sub Symbol Effect dialog box.
46. Close the Filter Effects dialog box.

52. Close the Filter Effects dialog box.

Now, define the filter effects related to the Type D discrete filter. For this 
filter, you need to set the two subsymbols to invisible and change the 
color for the basic symbol.
47.  Open the Filter Effects dialog box corresponding to the fourth 

discrete filter (Type D).
48. Click the Sub Symbols tab and open the Sub Symbol Effect dialog 

box related to SubSymbol1.
49. On the Others tab, from the Visibility dropdown list click invisible 

and validate so the subsymbol effect related to the first symbol closes.
50. Repeat steps 48 and 49 for SubSymbol2.
51. From the Filter Effects dialog box click the Effects tab. Click the Fill 

Color parameter and set the color you want.
The Preview subwindow on the Filter Effects dialog box should display 
similarly to the following screenshot:

For the Type C discrete filter graphic effects, the first subsymbol must 
be invisible, and the second subsymbol will be rotated 90 degrees with a 
different fill color.
39. Open the Filter Effects dialog box corresponding to the third discrete 

filter (Type C).
40. Click the Sub Symbols tab and open the Sub Symbol Effect dialog 

box related to SubSymbol1.
41. On the Others tab, from the Visibility dropdown list click invisible 

and validate so the subsymbol effect related to the first symbol 
closes.

42. Then, from the Sub Symbols tab, open the Sub Symbol Effect dialog 
box related to SubSymbol2.

43. On the Others tab, in the Rotation field type “90”.
44. Click the Effects tab. Click the Fill Color field and set the color you 

want.
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For the Type E discrete filter, the subsymbols must both be rotated 45 
degrees:
53.  Open the Filter Effects dialog box corresponding to the fifth discrete 

filter (Type E).
54. Click the Sub Symbols tab and open the Sub Symbol Effect dialog 

box related to SubSymbol1.
55. On the Others tab, type “45” for the Rotation parameter and validate 

so the subsymbol effect related to the first symbol closes.
56. Repeat steps 54 and 55 for SubSymbol2.
The Preview subwindow in the Filter Effects dialog box should display  
similarly to the following screenshot:

For the Type F discrete filter, you must create a new CGM symbol.
58.  Open the Filter Effects dialog box corresponding to the last discrete 

filter (Type F).
59. On the General tab, click the Symbol Name field and click the 

NgUSymbolEditor button  that displays to launch the CGM 
Symbol Editor and Vector Drawing tool.

60. Draw a new CGM symbol and save it.

57. Close the Filter Effects dialog box.
61. Exit the NgUSymbolEditor.
The Symbol Name field on the Filter Effects dialog box automatically 
fills with the new CGM symbol name. The Preview subwindow should 
display similarly to the following screenshot:
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62. Close the Filter Effects dialog box.
63. Save the discrete property definition parameters.
If you want to test the impact of the DisplayByType property on the 
schematic StationNodes elements, click Close, switch to Run mode, and 
open the All diagram. It should appear as follows:

Creating bounded properties for StationNodes and LV_
LineLinks

In this part, you will learn about bounded properties. 
A bounded  property allows you to specify the graphic effects matching 
different value ranges defined for this property. The value ranges 
defined for the property are generally based on an attribute that must be 
associated with the property.
Two bounded properties will be created:
• You will first animate the station display according to the Capacity 

database field values. Bounded property and display rules will be 
defined for each bounded filter, so the size of the symbol used to 
represent stations varies according to the Capacity field values.

• Then, you will create pattern models. A pattern is a symbol or a text 
that is repeated one or several times along a link path route. Displaying 
patterns is an interesting alternative to the basic line styles you can set 
for links. Using pattern models to represent bounded filters, you will 
animate the network links according to the Rate database field values.

Modifying the schematic station sizes according to their capacities
The Capacity field returned by the StationNodes query stores the capacity 
of each station as an integer value.
In this section, you will need to represent this information graphically. 
You will create the DisplayByCapacity bounded property composed of 
four bounded filters with each filter corresponding to one range of values. 
This property will display the nodes according to the Capacity field 
values as follows:

Capacity 
Lower Value

Capacity 
Upper Value

Filter Graphic Effects

0 2 Scaling factor: 1.0
3 5 Scaling factor: 2.0
6 8 Scaling factor: 3.0
9 10 Scaling factor: 4.0

Since the DisplayByCapacity property will use the Capacity field returned 
by the query, you must begin by creating an attribute corresponding to 
this field. 
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1. Right-click the Attributes entry displayed under the StationNodes 
element type and click Create. 

2. On the Create Element Type Attribute dialog box that opens, in the 
Name field type the name that will be used to reference this attribute  
(“StationCapacity”, for example), from the Type dropdown list click 
Field Attribute and validate.

3. Use the Identifier Editor to fill the Field Name parameter by clicking 
the Capacity field from the Fields list then validate it.

At the end of these steps, the StationCapacity attribute should display as 
follows:

The purpose now is to create the DisplayByCapacity bounded property 
that will display each station according to the StationCapacity attribute 
values. 
4. In the Designer tree, under StationNodes right-click Properties and 

click Create.
5. In the Create Property dialog box that opens, type 

“DisplayByCapacity”in the Name field. 
6. Check the Bounded option.
7. From the Value Type dropdown list click Integer.
8. Click OK. 
The new DisplayByCapacity property is automatically referenced below 
the Properties entry.
9. In the General tab, associate the property with the StationCapacity 

attribute by clicking StationCapacity from the Attribute Name 
dropdown list.

Now, you need to create the bounded filters. 
10. Click the Add Filter button on the lower right corner of the Designer 

Editor window. 
11. From the Add Bounded Filter dialog box that opens, in the Name 

field type a name for the first bounded filter (“Capacity 1”, for 
example) and set the lower and upper values (“0” and “2”, in this 
exercise) that will define this first bounded range. 

12. Click OK. 
The Add Bounded Filter dialog box closes.

13. Repeat the steps 10 through 12 to create three new filters 
corresponding to:

• The 3 to 5 value range (Capacity 2)
• The 6 to 8 value range (Capacity 3)
• The 9 to 10 value range (Capacity 4)

At the end of this step, the Filters tab should look like the following 
graphic:
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Now, you will define the graphic effects that will represent each bounded 
filter.
Start with the Capacity 1 bounded filter that must set the station scaling 
factor to 1.
14. From the Filters tab, click the Capacity 1 bounded filter and  

click the Ellipsis button that displays. 
15. On the Filter Effects dialog box, click the Others tab and type “1” for 

the Scaling parameter.

If you want to test the impact of the DisplayByCapacity property on 
the schematic diagram, click Close, switch to Run mode, and open the 
diagram. It should appear as follows:

16. Click Close to close the Filter Effects dialog box. 
17. For defining the graphic effects related to Capacity 2, 3, and 4, repeat 

the 14 through 16 to set the Scaling parameter with values of 2, 3, 
and 5 respectively.

18. Click Save.
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Using pattern models to animate the links according to the Rate field 
values
In this step, you will create two pattern models that you will use afterward 
to display the links according to a new bounded property with values that 
will be based on the Rate field stored in the LV_Line table. 
The first PatternSymbol1 model you will create is a pattern model symbol 
that will display an arrow placed on the middle of each link path route.
The second PatternText1 model will be a pattern model text that displays 
the X character along each link path route. The rules to repeat the pattern 
along the segment are as follows:
• Spacing between items: 5.0
• First item is 3.0 units away from link origin (Shift Distance)

The steps required to create the PatternSymbol1 model are detailed 
below:
1. Under the Environment entry, right-click the Pattern Models tree 

entry displayed and click Create.
2. From the Create Pattern Model dialog box that opens, enter 

the name that will be used to reference your first pattern model 
(“PatternSymbol1”, in the example).

3. From the Type dropdown list, click Pattern Symbol. 

4. Click OK.
5. From the General tab, specify the CGM symbol that will represent 

each pattern. After you click the Symbol Name field, click the 
NgUSymbolEditor button displayed to launch the NgUSymbolEditor.

6. Draw the new CGM file representing the desired symbol and save it.

7. Close the NgUSymbolEditor.
8. The parameters needed to define the rules that will be used to repeat 

the patterns along the segment are those available from the pattern 
model Others tab. Click the Others tab.

9. The default values set for the Positioning Mode, Shift Distance, 
Spacing, and Max Items On Segment parameters are those you need 
to display a pattern on the middle of each link path route. 
Your first pattern model definition is finished.
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The second PatternText1 pattern model you must create is a pattern 
model text that will display the X character along each link path route. 
The pattern color should automatically change according to the color of 
the link in which it will be displayed. The rules to repeat the pattern along 
the segment are as follows:
• Spacing between items: 5.0
• First item is 3.0 units away from link origin (Shift Distance)

10. Right-click the Pattern Models tree entry and click Create to open the 
Create Pattern Model dialog box. 

11. In the Name field from the Type dropdown list enter the name that 
will be used to reference your second pattern model (PatternText1, 
for example), click Pattern Text value , and click OK.

12.  Below the Pattern Models tree entry click the new pattern model tree 
entry and on the General tab type “X” in the Pattern Text field  as in 
the following screenshot:

The second pattern model definition is finished. 
18. Click Save.
The purpose now is to create the DisplayByRate bounded property 
that you will use to animate LV_LineLinks according to the Rate field 
returned by the LV_LineLinks query. This Rate field contains double 
values. The property will display the links according to the Rate field as 
follows:

Rate 
Lower value

Rate 
Upper Value

Filter Graphic Effects

0 200000 Use the PatternSymbol1 pattern model.
200000 400000 Display the link in green and use the 

PatternText1 pattern model.
400000 600000 Use the PatternSymbol1 and 

PatternText1 pattern models.
600000 800000 Display the link in pink.
800000 1000000 Display the link in black with the dashed 

dotted line style.
Because the DisplayByRate bounded property will use the Rate field 
returned by the query to animate the link display, you must create an 
attribute corresponding to this field.

13. Click the Effects tab and from the Text Alignment parameter field  
click Half Left. 

Now, you must define the rules that will be used to repeat the patterns 
along the segment. The pattern model must implement five items along 
the link path route, with the first item 3 units away from the link origin: 
14. Click the Others tab and from the Positioning Mode dropdown list 

click Absolute Spacing.
15. For the Shift Distance parameter field type “3”.
16. For the Spacing parameter field type “5”.
17. Click Slave from the Color Mode dropdown list so the pattern color 

automatically changes according to the link color.
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19. Under the LV_LineLinks element type, right-click the Attributes 
entry and click Create.

20. From the Create Element Type Attribute dialog box that opens, in the 
Name field type “RateLine” and validate. 

21. In the new RateLine attribute’s General tab, click the Field Name 
parameter and open the Identifier Editor dialog box.

22. From the Field’s list click Rate and validate.

Now, you need to create the five bounded filters that will be used to 
represent the links according to the DisplayByRate property values.
26. Click the Add Filter button on the lower right of the Designer Editor 

window to create the property’s first bounded filter. 
27. In the Add Bounded Filter dialog box that opens, in the Name field  

type “Rate 1” and set the lower and the upper values that will define 
this first bounded range (“0” and “200000”, respectively).

Now, you are going to create the DisplayByRate bounded property that 
will display each link according to the created RateLine attribute values. 
23. Under the LV_LineLinks element type, right-click the Properties 

entry displayed and click Create. 
24. From the Create Property dialog box that opens, in the Name field 

type “DisplayByRate”, check the Bounded option from the Value 
Type dropdown list, click Double and validate.

25. On the property’s General tab from the Attribute Name dropdown 
list, click RateLine to associate the new DisplayByRate property with 
the RateLine attribute.

28. Click OK.
29. Repeat steps 26 through 28 to create four other filters corresponding 

to the value ranges specified in the dialog box above.

30. From the Filters tab, click the Rate 1 bounded filter and click the 
Ellipsis button that displays to open the Filter Effects dialog box. 

31. From the Add Pattern Model dialog box that opens, on the bottom 
right, click the Add Pattern Model button, click PatternSymbol1 and 
validate.

The Pattern Model tab automatically displays among the Filter Effects’ 
tabs related to the first bounded filter.
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32. Click Close so the Filter Effects dialog box closes.
33. For defining the Rate 2 bounded filter effects, open the Filter Effects 

dialog box, click Add Pattern Model, and from the Name dropdown 
list click PatternText1. Then, click the Effects tab and specify the 
Line Color parameter as green. Close the Filter Effects dialog box. 

34. For the Rate 3 bounded filter, repeat steps 30 through 32 twice: the 
first time to add the PatternSymbol1 model and the second time to 
add the PatternText1 model.

For the Rate 4 and Rate 5 bounded filter effects, the graphic effects to 
specify are all on the Effects tab of the Filter Effects dialog box.
35. Define the graphic effects for the Rate 4 bounded filterby clicking 

the Filters tab, click the Rate 4 bounded filter and click the Ellipsis 
button to open the Filter Effects dialog box. Click the Effects tab 
and select a pink color for the Line Color parameter. Close the Filter 
Effects dialog box.

36. Repeat the same operation for the Rate 5 bounded filter: Click the 
Filters tab, select the Rate 5 bounded filter, and click the Ellipsis 
button to open the Filter Effects dialog box. Click the Effects tab and 
choose black for the Line Color parameter. Then from the Line Style 
dropdown list click Dash-dotted. Close the Filter Effects dialog box.

37.  Save the specified parameters.
If you test the All diagram display, it should appear as follows:
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Three subnetworks compose the network stored in the 
Schematics_Designer _Tutorial database, each one describing a feeder.  
This exercise will examine the Low Voltage part of the network. The 
purpose is to create new schematic diagram and element types to generate 
three schematic diagrams, one for each Low Voltage subnetwork related 
to a given feeder. In this way, the Feeder field stored in the Station table 
and the FromJunctionType and ToJunctionType fields stored in the LV_
Line table can be used to filter out the records stored in the database, so 
you will display three diagrams, one per feeder.
The exercise is organized into three parts:
• You will begin by creating a new diagram type that will implement 

these three diagrams per Feeder.
• Then, new node and link element types will be created and associated 

with this new diagram type. During this part, you will become familiar 
with the inheritance relationship that can be defined between two 
schematic element types. The new element type that you create will 
inherit from the StationNodes and LV_LineLinks element type you 
created in Exercise 3.

• In the last part, you will learn how properties inherited from a parent 
element type can be redefined at the child element type level.

Creating a new diagram type to visualize Feeder 
subnetworks separately

In this step, you will define a new diagram type that will implement the 
three Feeder subnetworks stored in the database: 
1. In the Designer tree, right-click the Diagram Types and click Create. 
2. From the Create Diagram Type dialog box that opens, in the Name 

text box type a name for the new diagram type (“Feeder”, for 
example).

Even if the All diagram type created in Exercise 3 has no particular 
characteristics, the new diagram type you are creating inherits from this 
All diagram type. In this case, if you decide to create specific behaviors 
for the parent diagram type, these behaviors will be automatically 
inherited at the child level. 
3. From the Parent Name dropdown list, click the All diagram type.

4. Click OK.
A new Diagram Types entry for the All diagram type’s children displays 
under the All diagram type entry. The new Feeder diagram type appears 
under this new Diagram Types entry:

Exercise 5: Displaying network data in several schematic diagrams
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12. Close the Identifier Editor dialog box.Because this new diagram type must filter out the schematic elements 
that will be associated with it according to the Feeder subnetwork these 
elements belong to, the query that will return all the schematic diagrams 
of this type should return the distinct occurrences of the subnetworks 
stored in the database. In this case, the SQL query for the Feeder diagram 
type can be defined from the Feeder table that contains all network 
feeders. 
5. In the Designer tree, click the Feeder diagram type entry, and click 

CURRENTDS from the Data Source dropdown list.
6. Click the Ellipsis button that displays when you click the Query field 

to open the Query Editor.
7. From the Tables list, click the Feeder table  and click All Records so 

the SELECT * FROM Feeder SQL query atomatically displays in the 
Query area. 

8.    Close the Query Editor form.

Now, you must specify the Identifier that will be used to reference each 
diagram of this type. The OBJECTID field returned by the query can be 
directly used to identify each schematic diagram, but instead of using a 
single number to identify each diagram, this field can be preceded by the 
Feeder string. 
9. Click the Ellipsis button that displays when you click the Identifier 

field to open the Identifier Editor.
10.  In the central text zone type “Feeder”, and click the Down arrow to 

validate this parameter. 
11. Then, from the Fields list click OBJECTID and click the Down 

arrow to add this field.

When such a diagram type is created to filter out elements stored in the 
database, you must define the diagram type attribute that will later be 
used to filter the schematic elements associated with a given diagram 
of this type. This way, these schematic elements will be automatically 
associated with each diagram of this type. In this case, it is the Feeder 
table’s OBJECTID field that you will need. 
13. Right-click the Feeder diagram type entry and click Create Attribute.
14. From the Create Diagram Type Attribute dialog box that opens, in 

the Name field type a name for the attribute (“FeederSubnetwork”, in 
this example), from the Type dropdown list click Field Attribute, and 
validate.

15. Then, click the Field Name field from the attribute’s General tab.
16. From the Fields list of the Identifier Editor dialog box that opens, 

click OBJECTID, click the Down arrow, and validate.
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Creating new schematic element types to filter out 
nodes and links according to their subnetworks

In this section, you will create two new node element types and one new 
link element type that will be associated with the new Feeder diagram 
type.
The queries that will return the elements of these types will be built 
according to the FeederSubnetwork attribute (defined for the Feeder 
diagram type) so they automatically filter out the schematic elements 
related to one feeder.
Defining the StationNodes_F new node type
1. Right-click the Element Types entry and click Create to open the 

Create Element Type dialog box. 
2. In the Name text box type “StationNodes_F”.
3. From the Type dropdown list click Node.
4. From the Parent Name dropdown list click StationNodes.
5. Uncheck the Element Group check box.

6. Click OK to validate.
Now, you will need to modify the inherited query so it filters out the 
stations stored in the database according to the FeederSubnetwork 
attribute values defined for the Feeder diagram type. 
Begin by associating your new StationNodes_F element type with the 
Feeder diagram type. 
7. Right-click the Feeder diagram type entry and click Associate an 

Element Type.
8. From the Create Association dialog box that opens,  from the Name 

list click StationNodes_F and validate. 

As the StationNodes_F new node type inherits from the StationNodes 
element type, the default query set for this new element type is the same 
as the StationNodes query. This query must be redefined so that it only 
returns the nodes related to one feeder subnetwork:
9. In the Designer tree, click the StationNodes_F entry and from the 

General tab click the Query field. Then, click the Ellipsis button that 
displays to open the Query Editor.

10. In the Query zone area, complete the query as follows: 
SELECT * FROM Station Where Feeder=?

11. Then you need to focus on the Parameters area. From the Name 
dropdown list click FeederSubnetwork (the attribute you defined for 
the Feeder diagram type the StationNodes_F is associated with).

12. As this attribute returns numerical values (the OBJECTID field 
related to this attribute stores numerical values), from the Text 
dropdown list click N.

If you want to test your query, type “1”,” 2”, or “3” for the Test Value 
field and click Show Results (the query result automatically displays in 
the Results zone).

The new Associated Element Types tab displays among the Feeder 
diagram type’s tabs. An item corresponding to StationNodes_F should 
now be displayed in this tab.
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13. Click OK.
14. Now, check the default inherited Identifier definition to ensure it is 

unique.
The first new StationNodes_F element type definition is finished. 
15. Click Save.
Even if you have not already created all the element types required 
to generate your Feeder diagrams, you can check that the new Feeder 
diagram type correctly generates three diagrams with stations related to 
each feeder subnetwork.
16. Switch to Run mode by closing the Designer Editor window.
17. Click Open Diagrams.
18. From the Select Diagram To Open dialog box that opens, from the 

Diagram Type dropdown list click Feeder.
19. The Diagram Name dropdown list should contain three items 

(Feeder-1, Feeder-2, and Feeder-3), one for each feeder stored in the 
Schematics_Designer_Tutorial database. Click Feeder-1. 

20. Click OK. The Feeder-1 schematic diagram should open as follows:

Note that the diagram names available from the Diagram Name dropdown 
list of the Select Diagram To Open dialog box are those returned by the 
Identifier diagram type parameter.
Note also that because the new StationNodes_F element type inherits 
from the StationNodes element type, all properties defined for the parent 
node type are automatically reported on the child node type. As the query 
set for the new node type returns the same parent fields needed by these 
inherited properties, the properties’ representation is effective.
The following screenshots show how the Feeder-2 and Feeder-3 diagrams 
should display:
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Defining the FeederNodes_F new node type
The purpose now is to create the new FeederNodes_F element type that 
will return the unique feeder related to each Feeder subnetwork diagram. 
This new node element type will inherit from the FeederNodes element 
type you created in Exercise 3.
1. Switch to Design mode.
2. Right-click the Element Types entry and click Create.
3. From the Create Element Type dialog box that opens in the Name 

field type “FeederNodes_F”, from the Type dropdown list click 
Node, from the Parent Name dropdown list click FeederNodes, 
uncheck the Element Group check box, and validate.

Before redefining the parameters related to the new FeederNodes_F 
element type, you must associate this element type with the Feeder 
diagram type.
4. Right-click the Feeder diagram type entry and click Associate an 

Element Type. Then, from the Create Association dialog box and 
from the Name dropdown list click FeederNodes_F, and validate.

You must now redefine the FeederNodes_F General tab parameters.
5. In the Designer tree, click the FeederNodes_F element type entry, 

click the Query parameter value and open the Query Editor dialog 
box. In the Query zone area, complete the query as follows: 
SELECT * FROM Feeder Where OBJECTID=?

 Next, focus on the Parameters area, from the Name dropdown list 
click FeederSubnetwork (the attribute you defined for the Feeder 
diagram type), from the Text dropdown list click N, and validate.

6. Now, check the default inherited Identifier definition to ensure it is 
unique.

At the end of these steps, the FeederNodes_F element type’s General tab 
should display as follows:

Now, if you test the Feeder-1, Feeder-2, or Feeder-3 schematic diagram 
display, one feeder schematic element should display in each of these 
diagrams:
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Defining the new LV_LineLinks_F element type
In this part, you will create a new element type link that will be used 
to filter out all the links stored in the LV_Line table, according to the 
subnetwork to which they belong. This new link type will inherit from the 
LV_LineLinks element type.
Note that since the HV_Line table contains links that connect Feeder 
nodes to other Feeder nodes, and the new Feeder diagram type will be 
used to display subnetworks related to a unique feeder, no new link type 
must be created from the HV_Line table.
1. In the Designer tree, right-click the Element Types entry and click 

Create. 
2. From the Create Element Type dialog box that opens, in the Name 

text box type LV_LineLinks_F, from the Type dropdown list click 
Link, from the Parent Name dropdown list click Link, uncheck the 
Element Group check box, and validate.

3. Associate the newly created link element type with the Feeder 
diagram type.

You must then redefine the LV_LineLinks_F element type’s General tab 
parameters. When an ESRI Access GDB data source is used to connect 
a database, SQL queries joining several database tables are not easy to 
define. In this example, as the query related to your new LV_LineLinks_F 
element type must merge the LV_Line table with the Station table to 
obtain all LV_Line links related to one feeder node (from the Station 
table, you can relate the feeder to each station), you have to define and 
use the TutorialDatasource you have created at the begining of Exercise 3.
4. In the Designer tree, click the LV_LineLinks_F element type entry 

and click the General tab. 
5. From the Data Source dropdown list click TutorialDatasource.
6. Then, click the Query parameter field and click the Ellipsis button to 

open the Query Editor dialog box.
7. In the Query area, change the specified query with the following one: 

SELECT LV_Line.*, Station.Feeder FROM LV_Line, Station where 
(Station.OBJECTID=ToJunctionOID and Station.Feeder=?)

 In the Parameters area, from the Name dropdown list click 
FeederSubnetwork, for the Text parameter select N, and validate.

8. Check the default inherited Identifier definition to ensure it is unique.

At the end of these steps, the General tab for the LV_LineLinks_F 
element type should display as follows:

A link can be displayed only when Schematics knows to which origin 
and extremity nodes the link connects. In this example, because the query 
defined for the new link type returns all the fields required to compute 
the inherited OriginNode and ExtremityNode attribute values, each link 
should correctly connect its origin and extremity nodes for FeederNodes_
F or StationNodes_F.
The new link type definition is now finished. It only allows you to test the 
Feeder-1, Feeder-2, and Feeder-3 diagrams display. They should display 
as follows:
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Redefining inherited properties for the schematic elements contained 
in the Feeder diagrams
Due to the inheritance, the Label1 and Label2 properties defined for the 
StationNodes and LV_LineLinks element types are automatically reported 
on the StationNodes_F and LV_LineLinks_F element types. However, 
inherited properties can also be redefined at the child level if needed.
In this section, you will redefine these property labels as follows:
• In Feeder subnetwork diagrams, the Label2 textual property will 

display each station NAME field value stored in the database (instead 
of displaying the inherited, formatted StationLabel attribute value).

• In Feeder subnetwork diagrams, the Label1 textual property will 
display a new label that will concatenate its origin node OBJECTID 
and extremity node OBJECTID as follows: FromJunctionOID-
ToJunctionOID.

Associating an inherited property with an inherited attribute
The StationName attribute field defined for the StationNodes element 
type corresponds to the NAME field stored in the database. 
As the StationNodes_F element type inherits from the StationNodes 
element type, this attribute is automatically inherited at the child level. 
At the StationNodes element type level, the Label2 property is associated 
with the formatted StationLabel attribute. In the Feeder diagrams, you 
want to associate the Label2 inherited property with the StationName 
inherited attribute. For the StationNodes_F element type, the Label2 
property redefining consists of reassociating this inherited property with 
the inherited StationName attribute. 
1. Right-click the StationNodes_F entry and click Associate Property.
2. From the Associate Property dialog box that opens, from the Name 

dropdown list click the inherited Label2 property.
3. Then, from the Attribute dropdown list click the StationName 

attribute among all the inherited attributes available.

4. Click OK to validate.

5. Click Save.
If you want to test the inherited property label redefinition, switch to 
Run mode and open the Feeder-1, Feeder-2, or Feeder-3 diagram. After 
zooming in on a set of stations, the label should display in a similar way 
as in the following screenshot:

The property entry should display as follows:
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Defining a new attribute at the child element type level and 
associating an inherited property with that attribute
At the LV_LineLinks element type level, the Label1 property is 
associated with the LVLine_OID field attribute. For the Feeder diagrams, 
you will have to change the inherited property label so that this 
property displays a formatted label built as follows: FromJunctionOID-
ToJunctionOID.
You must start by creating a new attribute at the LVLineLinks_F level to 
build this new label. Since a field attribute can concatenate several fields 
returned by its related element type’s query, with each concatenated field 
value being hyphenated, this label will be defined as a field attribute. 
1. Right-click the LVLineLinks_F entry and click Create Attribute.
2. From the Create Element Type Attribute dialog box that opens, in the 

Name field enter a name (“FromTo”, for example), from the Type 
dropdown list click Field Attribute, and validate.

3. In the newly created attribute’s General tab, click the Field Name 
parameter, and click the Ellipsis button that displays to open the 
Identifier Editor dialog box.

4. From the Identifier Editor dialog box, double-click the 
FromJunctionOID field available from the Fields list so this field is 
added to the Identifier list, 

5. Repeat this operation for the ToJunctionOID field. 
6. Click OK to validate and close the Identifier Editor dialog box.
The FromTo attribute’s General tab should display as follows:

Now, the Label1 property redefinition only needs the reassociation of 
this inherited property with the new FromTo attribute defined at the 
LVLineLinks_F level.
7. Right-click the LVLineLinks_F entry and click Associate Property to 

open the Associate Property dialog box.
8. From the Name dropdown list click the inherited Label1 property and 

from the Attribute dropdown list click the FromTo attribute among 
all the attributes.

9. Click OK to validate. 
The newly associated property’s General tab should display as follows:

10. Click Save.
If you want to test the inherited property label redefinition, switch to 
Run mode and open the Feeder-1, Feeder-2, or Feeder-3 diagram. After 
zooming in on a set of links, the label should display in a similar way as 
in the following screenshot:
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The purpose now is to define the CommandPopupMenu parameters. The 
Command tab related to a behavior definition always lists the parameters 
for the main command set in the General tab’s Command parameter. 
5. Click this Command tab.
In this example, the first menu item will be used to fit all the elements 
contained in the diagram.
6. Type a label for the first item of the context menu in the Item1 

parameter field (“Full Extent”, in this example) and press Enter.
7. Then, from the Command1 dropdown list, click CommandFitAll.

In this exercise, you will learn how to define schematic behaviors. 
A behavior defines how an application responds to a user’s actions. 
Behaviors can be applied to Schematics diagrams, elements, and views. 
Note that when schematic diagrams open in the Schematics Designer 
environment, behaviors can also be applied to legend entries. But when 
these diagrams display in the ArcMap environment as schematic layers, 
behaviors defined for legend entries cannot be intercepted.

Defining behaviors that will impact schematic diagrams

In this section, you will define a behavior impacting any schematic 
diagram (or view) when it is right-clicked. Generally, the main commands 
needed from a diagram are as follows:
• Fitting all the elements in the diagram
• Activating the Pan mode
• Repositioning the elements displayed in the diagram according to their 

initial positions

You are going to create a behavior that will display a context menu for 
launching these three commands:
To create behaviors that impact diagrams: 
1. Right-click the Behaviors entry in the Designer tree and click Create.
2. From the Create Behavior dialog box that opens, choose RightClick 

from the Event Name dropdown list and click Schematic Diagram 
from the Meta Type dropdown list.  
In this example, because the behavior you are defining will impact 
any diagram defined for the schematic project, keep the Object Type 
parameter empty.

3. Click OK to validate.
The new RightClick behavior entry is automatically created under the 
Diagram Types Behaviors main entry.

You must now specify the command that will be automatically triggered 
each time a schematic diagram is right-clicked. The predefined command 
used to display a context menu is CommandPopupMenu: 
4. From the new behavior’s General tab, click CommandPopupMenu 

from the Command dropdown list.

Exercise 6: Defining schematic behaviors
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The first item definition is finished.
You must now define the second menu item that will enable the Pan 
mode:
8.  Click Add Item to create the second context menu item.
9. Type the second item label (“Pan”, in this example) that will appear 

in the context menu in the Item2 parameter field and press Enter.
10. Then, click CommandSetPanMode from the Command2 dropdown 

list.

The second item definition is finished.
It only allows you to define the third menu item that must reposition the 
elements contained in the diagram according to their database position.
11. Click Add Item to create the last context menu item.
12. Type the third item label (“Initial Positions”, in this example).

13. Then, click CommandInitialPosition from the Command3 dropdown 
list and press Enter.

Until now, the predefined commands you have used for each item menu 
definition were simple commands without parameters. But in this case, 
the CommandInitialPosition is a parameterized command.
14. Click the Command3 parameter field. An Ellipsis button should 

display at the end of the command line.

15. Click this Ellipsis button to display the Current Command tab where 
the parameters related to the CommandInitialPositions are displayed.

16. The Current Command tab content should appear as follows:

The default value set for the ModeSet and ModeNotSet parameters is 
what you need to reposition the elements in the diagram at their initial 
coordinates.
For more details on the CommandInitialPosition command parameters, 
open the Schematics Designer Help system.
17. Click Save to save the new specified parameters.
If you want to test this context menu display, switch to Run mode, open 
a diagram, and right-click this diagram background. The context menu 
should display as follows:
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Defining behaviors that will impact schematic elements

In this section, you will create behaviors that will impact the 
StationNodes and LV_LineLinks element types when an element of this 
type is right-clicked.
For example, the context menu displayed from any right-clicked 
StationNodes station will allow you to:
• Rotate all stations by 45 degrees
• Center the clicked node in the view
• Activate or deactivate the Label2 property label display
• Activate or deactivate the DisplayByCapacity property graphic effects
• Activate or deactivate the DisplayByType property graphic effects.

From any right-clicked LV_LineLinks link, the context menu that will be 
displayed will allow you to:
• Activate or deactivate the Label1 property label display
• Activate or deactivate the DisplayByCategory property graphic effects
• Activate or deactivate the DisplayByRate property graphic effects.

Note: Since StationNodes_F and LV_LineLinks_F element types inherit 
from StationNodes and LV_LineLinks element types, behaviors defined 
for StationNodes and LV_LineLinks element types will also impact 
StationNodes_F and LV_LineLinks_F element types.

Defining the sample behavior related to the StationNodes type
If the first, third, fourth, and fifth context menu items you have to define 
for the StationNodes element type right-clicked node will correspond to 
a single parameterized command, the second one that will automatically 
center the clicked node in the view must chain several commands. In 
fact, the predefined command used to center an element in a diagram 
(CommandCenterObject) works on a selected element only. Since right-
clicking a node doesn’t select it, you will have to select the node (using 
the CommandSelectObject predefined command) before centering it. 
But the predefined CommandContainer command usually used to chain 
several commands cannot be called directly from a context menu item. 
In this case, the solution consists of defining a user event to trigger the 
command chaining that you will call from the context menu item through 
a CommandDelegate command.
 



64

The following steps describe this user event behavior:
1. Right-click the Behaviors entry in the Designer tree and click Create.
2.  From the Create Behavior dialog box that opens, type a name 

(“Centering”, for example) for the Event Name parameter that will be 
used to reference this behavior.

3. Click Schematic Element from the Meta Type dropdown list.

4. Click OK to validate.
A new Element Type Behaviors entry should display under the Behaviors 
main entry in the Designer tree. The newly created Centering behavior 
should display under Element Type Behaviors.
5. From the new behavior General tab, click CommandContainer from 

the Command dropdown list.

6. Click the Command tab where the CommandContainer parameters 
must be specified. 

7. From the Command1 dropdown list, click CommandSelectElement, 
the first predefined command that will be used to select the clicked 
element.

8. Click Add Command to create the second command that will chain 
with the first. 

10. Click Save.
Note: This user event definition can end by calling the 
CommandUnselectAll command so that element is automatically 
deselected after it is centered in the diagram.
Because this user event is now defined, each item menu you want to be 
displayed when a StationNodes node is right-clicked can be easily defined 
and customized as follows: 
11. Right-click the Behaviors entry in the Designer tree, and click 

Create. 
12. From the Create Behavior dialog box, choose RightClick from the 

Event Name dropdown list, clickSchematic Element from the Meta 
Type dropdown list, and click StationNodes from the Object Type 
dropdown list. 

13. Click OK.
14. From the new behavior General tab, clickCommandPopupMenu from 

the Command dropdown list.
15. Then, click the Command tab where parameters related to the 

CommandPopupMenu must be specified.

9. From the Command2 dropdown list, click CommandCenterElement, 
the predefined command that will then be used to center the clicked 
element.
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18. Click the Ellipsis button that automatically appears on the right of 
the Command1 field to display its associated Current Command tab 
where the CommandRotate command parameters are available.

19. Click this Current Command tab and specify the Parameter value that 
corresponds to the angle that will be used to rotate the nodes (“45”, 
in this example).

Start defining the command that will correspond to the first context menu 
item. Clicking the first menu item must rotate all stations by 45 degrees:
16. Type the first item that will appear in the menu (“Rotate 45°”, in this 

example).
17. Click CommandRotate from the Command1 dropdown list.

You must now define the second context menu item. This new menu item 
will be used to center the clicked node in the diagram:
20. Click the Command tab and click Add Item.
21. Type the second item that will appear in the context menu (“Center”, 

in this example).
The command you must specify here is not a simple, predefined 
command. You must launch the execution of the Centering behavior you 
previously defined. The CommandDelegate is the predefined command 
you must use to trigger the execution of an existing behavior:
22. Click CommandDelegate from the Command2 dropdown list.

23.  Click the Ellipsis button on the right of the Command2 field to 
display its associated Current Command tab and click this tab.
24. The Meta Type parameter default value is the correct one. 

Click the Centering behavior from the Event Name dropdown list.

Save the specified parameters.

Save the specified parameters.
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You must now define the third context menu item. Clicking this new 
menu item must activate or deactivate the Label2 property label display.
25. Click the Command tab and click Add Item to set the third context 

menu item. 
26. Type the third item that will appear in the context menu (“Display 

Name”, in this example).
27. Select CommandTogglePropertyState from the Command3 

dropdown list.

28. Click the Ellipsis button on the right of the Command3 field to 
display its associated Current Command tab and click this tab.

29. Here, as you want to enable/disable the Label2 property label display, 
select Property Value from the Label Display Mode dropdown list so 
that the property label display is turned on/off, select StationNodes 
from the Element Type1 and select Label2 for the Property1 
dropdown list.

Save the specified parameters.

The purpose now is to define the fourth context menu item that will be 
used to activate or deactivate the DisplayByCapacity property’s graphic 
effects.
30. Click the Command tab and click Add Item to set the fourth context 

menu item. 
31. Type the fourth item label that will appear in the context menu 

(“Display by Capacity”, in this example).
32. Select CommandTogglePropertyState from the Command4 

dropdown list.
33. Click the Ellipsis button on the right of the Command4 field to 

display its associated Current Command tab and click this tab.
34. Here, since you want to enable or disable the DisplayByCapacity 

property’s graphic effects, click Enabled from the Status dropdown 
list so the property graphic effects are turned on or off according 
to the current property status. Click StationNodes in the Element 
Type1 field and click the related property, DisplayByCapacity, for the 
Property1 field.

Save the specified parameters.
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Note that for the last three menu items, the item is checked when the 
related property’s effects are enabled and unchecked when they are 
disabled. Clicking one of these three context menus when they are 
checked deactivates the related property, while clicking one of these three 
context menus when they are unchecked activates the related property.

It only allows you to define the last context menu item that will be used to 
activate or deactivate the DisplayByType property’s graphic effects.
35. Click the Command tab and click Add Item to set the fifth context 

menu item. 
36. Type the item that will appear in the context menu (“Display by 

Type”, in this example).
37. Click CommandTogglePropertyState from the Command5 dropdown 

list.
38. Click the Ellipsis button on the right of the Command5 field to 

display its associated Current Command tab and click this tab.
39. Here, since you want to enable or disable the DisplayByType 

property’s graphic effects, click Enabled from the Status dropdown 
list so the property graphic effects are turned on or off according to 
the current property status. Click StationNodes in the Element Type1 
field and click the related property, DisplayByType, for the Property1 
field.

40. Save the specified parameters.
If you want to test this new context menu display, switch to Run mode, 
open a diagram, and right-click any StationNodes schematic node 
contained in this diagram. The context menu should display as in the 
following screenshot.
Note because this behavior is defined for the StationNodes element type, 
it is also available from the inherited StationNodes_F element type; that 
is, this context menu also displays when right-clicking a StationNodes_F 
node in any diagram implemented by the Feeder diagram type.
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Defining the sample behavior related to the LV_LineLinks type
As you did for the StationNodes element type, you must now create a new 
behavior to display a context menu from any right-clicked LV_Lines link.
1. Right-click the Element Types Behaviors entry in the Designer tree, 

and click Create.
2. From the Create Behavior dialog box, choose RightClick from the 

Event Name dropdown list. 
Because the Create Behavior dialog box has been opened from the 
Element Type Behaviors entry, Schematic Element should be already 
selected for Meta Type.

3. Then, click LV_LineLinks from the Object Type dropdown list and 
validate.

4. Click OK.
5. Now, from the newly created behavior’s General tab, click 

CommandPopupMenu from the Command dropdown list.
6. Click the Command tab where you have to specify the menu items.
The first menu item must activate or deactivate the Label1 property label 
display:
7. Type the Item1 value (“Display Information”, in this example).
8. Click CommandToggleProperty from the Command1 dropdown list.

9. Click the Ellipsis button on the right of the Command1 field to 
display its associated Current Command tab and click this tab.

10. Here, because you want to enable or disable the Label1 property 
label display, click PropertyValue from the Label Display Mode 
dropdown list so the property label display is turned on or off.

11. Then, click LV_LineLinks from the Element Type1 dropdown list.
12. Click Label1 for the Property1 dropdown list.

Save the specified parameters.

You must now define the second context menu item that will be used to 
activate or deactivate the DisplayByCategory property’s graphic effects.
13. Click the Command tab and click Add Item to set the second context 

menu item. 
14. Type the second item that will appear in the context menu (“Display 

by Category”, in this example).
15. Click CommandTogglePropertyState from the Command2 dropdown 

list.
16. Click the Ellipsis button on the right of the Command2 field to 

display its associated Current Command tab and click this tab.
17. Since you want to enable or disable the DisplayByCategory 

property’s graphic effects, click Enabled from the Status dropdown 
list, click LV_LineLinks in the Element Type1 field, and click the 
related property, DisplayByCategory, for the Property1 field.
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It only allows you to create the last item menu that must activate or 
deactivate the DisplayByRate property’s graphic effects.
18. Repeat steps 13 through 15 so the Command tab content displays as 

follows:

Save the specified parameters.

19. Then, repeat steps 16 and 17 for the DisplayByRate property. The 
Current Command tab should display as follows:

20. Click Save.
If you switch to Run mode and test this new context menu display, it 
should appear as follows:
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The purpose of this exercise is to create a new schematic diagram type 
that works with the Standard Builder to generate schematic diagrams on 
the fly from any selected features set or trace result in ArcMap. Creating 
such a diagram type is easier than creating a diagram type that works with 
the Custom Query Based Builder because there are specific commands 
in Designer which let you define it with a minimum of setup work 
and configuration. The standard way to create such a diagram type is 
organized into three steps:
1. Create an ArcMap document containing the geometric network data 

you want to use to generate schematic diagrams, then symbolize this 
data.

2. Create the schematic diagram type that will implement the schematic 
diagrams, and use the Import From Feature Layers command to 
quickly create the schematic element types that will implement the 
schematic diagrams’ content.

3. Customize the display of these schematic diagrams’ content.

Starting from an ArcMap document

When working with Schematics, you often have a map, map template, 
or layer file that contains the feature layers that compose the geometric 
network with which you want to work and generate schematic diagrams. 
The symbology used to represent the feature layers in your ArcMap 
project is often already defined, categories have been created, and you are 
familiar with the representation. ArcGIS Schematics offers the possibility 
to use these layer definitions to quickly create schematic element types. 
This point will be detailed in the next section. The purpose here is to 
create an ArcMap document based on the ElectricDataset stored in the 
Schematic_Designer_Tutorial database.
1. Start ArcMap with a new, empty map.
2. Click Add Data, browse to the Schematic_Designer_Tutorial 

database that should have been installed in C:\arcgis\ArcTutor\
Schematics\Designer, click ElectricDataSet, and click Add.

3. Customize the feature layers as you want. You can define categories 
for some of them if you want.

4. Save your .mxd file.

Below is a customization sample where:
• A blue square has been used to represent Feeder junctions.
• Station junctions are categorized according to the Feeder subtype field 

value. That is, each station is represented by a circle whose color varies 
according to the values of the Feeder field.

• HV_Line edges are represented by a large, red line.
• LV_Line edges are categorized according to the Category field values.

That is, each edge is represented by a line whose color and width vary 
according to the values of the Category field.

Creating a schematic diagram type to generate 
schematic diagrams from this .mxd file data

The purpose now is to create a new schematic diagram type to generate 
schematic diagrams on the fly after a selection or a trace operation from 
any selected feature set in this .mxd document .
1. Open ArcCatalog, and browse to the Schematics_Designer_Tutorial 

geodatabase that should contain the schematic dataset you have 
created during Exercise 1.

2. Right-click this schematic dataset, and click Edit Project.
3. Designer starts and your schematic project opens.
4. From the Designer tree, right-click Diagram Types and click Create.

Exercise 7: Generating schematic diagrams on the fly
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5. In the Create Diagram Type dialog box that opens, type a name 
for the new schematic diagram type (“DiagramsOnTheFly”, for 
example) and validate.

By default, the newly created diagram type works with the Standard 
Builder, the builder that allows you to generate schematic diagrams on the 
fly.

You must now define the schematic element types that will implement the 
schematic elements contained in the schematic diagrams related to this 
diagram type. As you want to use this diagram type to generate schematic 
diagrams from selected feature set in the .mxd document you  created in 
the previous section, the best way to complete this diagram type definition 
is to use the Import From Feature Layers command that displays when 
you right-click your diagram type entry from the Designer tree. This 
command creates schematic element types related to the feature layers 
displayed in a .mxd document:
6. In the Designer tree, right-click DiagramsOnTheFly and click Import 

From Feature Layers. The Import From Feature Layers dialog box 
opens.

7. At the right of the Map or Layer File field, click the Ellipsis button, 
browse to the .mxd file you previously created, select it, then click 
Add. 

8. All feature layers contained in this .mxd document should display 
in the Select the feature layers to import area. The check boxes 
corresponding to these feature layers should all be checked. 
Make sure that the Import Symbology option is checked so the 
feature symbology you have customized for your map document is 
also reported on the element types created during the import process. 
The Import From Feature Layers dialog box should display as 
follows:

9. Click OK.
In this example, when the import is complete, the Feeder, Station, 
ElectricDataSet_Net_Junctions, HV_Line, and LV_Line schematic 
element types related to these feature layers should have been created. 
These new schematic element types display under the Element Types 
entry:

A blue square symbol has been created to display Feeder schematic nodes 
in the same way as in the ArcMap document. When checking the Station 
node element type, you can note that an attribute and a property have 
been created to display these schematic nodes according to the Feeder 
subtype field values in the same way as their associated junctions are 
categorized in ArcMap.
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When expanding the LV_Line element type entry, you can also see that 
an attribute and a property have been created to display the LV_Line 
schematic links according to the Category field values as they are in the 
.mxd file.

Finally, you’ll take notice on the Associated Element Types tab for the 
DiagramsOnTheFly diagram type, each newly created Feeder, Station, 
ElectricDataSet_Net_Junctions, HV_Line, and LV_Line schematic 
element type is associated with it.
10. Click Save.

All schematic components required to generate a schematic diagram 
from a selected feature set or trace operation highlighted in your .mxd 
document are now available. Now, you may test how this new diagram 
type works.
11. Exit Designer.
12. Start ArcMap and load the .mxd file you created in the previous 

section.
13. Click the Select Features tool and create a selection set of features in 

your map.

14. Click the Generate New Schematic Diagram tool. The New 
Schematic Diagram dialog box opens.

15. Click the Browse button next to the Schematic Dataset or Folder 
dropdown list to select the DesignerTutorial schematic dataset in the 
Schematics_Designer_Tutorial geodatabase.

16. From the Diagram type dropdown list, click DiagramsOnTheFly.
17. In the Schematic Diagram Name field, type a name for the schematic 

diagram that will be generated (“Selection1”, for example).
18. Keep the Selection Set option that should be checked by default.
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19. Click OK.
The new schematic diagram is generated. At the end of the generation 
process, a new schematic diagram containing the schematic elements 
associated with the selected set of features is displayed. The symbology 
used to represent the schematic element should be similar to the 
symbology used to represent the associated features in the map.

20.  Now, activate your map data frame, set the parameters for executing 
any trace operation in your map, and click Solve.

21. Click the Generate New Schematic Diagram tool.
22. From the New Schematic Diagram dialog box that opens, make sure 

that the DesignerTutorial schematic dataset is currently selected in 
the Schematic Dataset or Folder dropdown list .

23. From the Diagram type dropdown list, click DiagramsOnTheFly.
24. In the Schematic Diagram Name field, type a name for the schematic 

diagram that will be generated (“Trace1”, for example).
25. Keep the Tracing Result option that should be checked by default.

Below is a sample trace result obtained with the Find Loops trace task:
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26. Click OK.
At the end of the generation process, a new schematic diagram containing 
the schematic elements associated with the set of features currently 
highlighted in the map is displayed.
27. From the Utility Network Analyst toolbar, click Analysis and click 

Clear Results. Repeat this operation to clear the flags and barriers 
you have specified.

Note that if you click the Generate New Schematic Diagram tool, the 
Diagram type dropdown list from the New Schematic Diagram dialog 
box that opens also lists the All and Feeder schematic diagram type you  
created during Exercises 3 and 5.

Choosing one of these diagram types to work with the Custom Query- 
Based Builder, lets you open and visualize in ArcMap All or Feeder-1, 
Feeder-2, and Feeder-3 schematic diagrams you have already opened in 
Designer.
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Customizing the schematic diagrams’ display

The purpose now is to learn how the generated schematic diagrams’ 
display can be customized.
Displaying vertices along links
1. Close ArcMap and edit your schematic project with Designer.
2. Click the DiagramsOnTheFly entry, and in the General tab, click the 

Schematic Builder field. Then, click the Ellipsis button that displays 
on the right. The Standard Builder Property Page displays

3. Check the Initialize links vertices check box.

4. Click OK to validate.
5. Click Save and close Designer.
6. Now, launch ArcMap and open your .mxd file. Select a set of features 

in the map and use the Generate Schematic Diagram command to 
generate the new DiagramsOnTheFly schematic diagram from the 
current selection set.

At the end of the process, a new schematic diagram should open. 
Schematic links contained in this diagram should now be displayed with 
their vertices.
Below is a sample schematic diagram obtained after selecting the part of 
the geometric network corresponding to the stations related to Feeder #1.

Note that for all schematic diagrams you have previously generated, if 
you reopen them, they display without vertices along links. To display 
vertices along these diagrams’ links, you need to update the schematic 
diagram content.
7. Click Open Schematic Diagrams and choose one of the diagrams you  

generated previously.
8. Click Schematic and click Update Diagram. The Update Diagram 

dialog box opens.
9. Make sure the Initial features option is selected and click OK. 

After the diagram updates, vertices should display along the links.
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Creating properties and attributes
As you already did when you customized the content of the diagrams 
implemented by the All schematic diagram type, attributes and properties 
can be created to document and animate schematic diagrams that work 
with the Standard Builder. This section, shows you how to add labels to 
these diagrams.
1. Close ArcMap and edit your schematic project with Designer.
The purpose is to display the name of the stations at the top of each 
station node. Before creating the textual property that will be used to 
display these labels, you must create the attribute that will return the 
stations’ name information.
Schematic elements contained in diagrams generated by the Standard 
Builder are managed in a different way from those managed by the 
Custom Query Based Builder. During each schematic diagram generation, 
the Standard Builder proceeds in two steps:
• First, it analyzes the highlighted features in the ArcMap document, 

decodes the topology related to these features from the geometric 
network, builds all associated schematic nodes and links, and pulls 
these elements into specific schematic tables it has created in the 
schematic dataset

• Subsequently, it creates the schematic element types associated with 
the schematic diagram type required to display the set of elements 
stored in the schematic tables by querying them directly from these 
tables; then the generated diagram opens

For the element types managed by the Standard builder, there are two new 
types of attributes that can be created:
• The Dynamic Feature attribute that retrieves field values directly 

from the feature class table with which the schematic element type is 
associated

• The Static Feature attribute that imports field values from the feature 
class table with which the schematic element type is associated into the 
schematic dataset during the diagram generation process

Note that if you create a Static Feature Attribute and use it to document or 
animate your schematic elements, you will have to update any previously 
generated diagrams so the attribute values can be pulled into the 
schematic database and so the elements display according to these values. 
With a Dynamic Feature Attribute, the impact on the schematic element 
representation is automatic.

2. Click the Station element type entry that corresponds to the Station 
feature layer created during the import process.

3. Click Create Attribute.
4. From the Create Element Type Attribute dialog box that opens, type a 

name for the attribute (“Label”, for example).
5. From the Type dropdown list, click Dynamic Feature Attribute. 

6. Click OK. 
The Feature Attribute Editor dialog box opens.

7. From the Feature Class Fields list, click Name and click the right 
arrow to validate this field.

8. Click OK. 
The newly created attribute should display as follows:

In this example, you are going to create a Dynamic Feature attribute 
related to the Name field stored in the Station feature class table:
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You have now to create the textual property that will be used to display 
this label
9. In the Designer tree, right-click the Station element type entry and 

click Create Property.
10. From the Create Property dialog box that opens, type a name for the 

property (“DisplayLabel”, for example), keep the Textual option and 
the default String Value Type.

11. Click OK.
12. From the newly created property’s General tab, and from the 

Attribute Name dropdown list, click the attribute you have just 
created, .

You must now specify how the labels will be displayed on each station 
node’s symbol. Labels on nodes are usually placed according to the 
reference point of the symbol used to represent these nodes. This 
reference point is the center of the symbol. In this example, you will learn 
how to create label ports that will be used to attach your labels.
13. In the Designer tree click the Station element type entry, in the 

General tab click the Symbol Name field, and click the Edit Symbol 
button  that opens the vector drawing tool (NgUSymbolEditor).

14. Click Insert, point to Port, and click Label Port.

15. Click at the top of the symbol to place a label port.
16. If needed, zoom to this location to check the label port position and 

reposition it if you want.



79

17. Click Save and exit NgUSymbolEditor.
As the station nodes’ symbol varies according to the Feeder field values 
through a discrete property, you will have to repeat the same operation to 
create a label port for each symbol used to represent the filters defined for 
this discrete property.
18. Click the entry related to this discrete property. It should be 

referenced under the “ArcGIS Symbology - (Feature_Feeder_Static)” 
name.

19. Click the Filters tab.
20. Click the first filter parameter line and click the Ellipsis button that 

opens the Filter Effects dialog box.
21. Then, from the General tab, click the Symbol Name field and click 

the Edit Symbol button.
22. Repeat steps 14 to 17 to create a label port for this symbol.
23. Click Close to close the Filter Effects dialog box.
24. Repeat steps 20 to 23 to create label ports for the symbols used to 

represent the second and third discrete filter.
Then, you can specify that you want your label to be attached to these 
label ports.
25. Click the DisplayLabel textual property you previously created and 

click the Effects tab.
26. For the Label Port parameter enter 1. Set the Text Color you want. 

You can also specify a Text Background color if you want.

27. Click Save.
Exit Designer, open ArcMap and test one of the schematic diagrams 
implemented by the Standard Builder you generated: it opens with 
labels.

Note that when defining a selection set in your map view, you can use 
the Propagate Map Selection To Schematic command to highlight the 
associated features in your schematic diagrams generated with the 
Standard Builder. Conversely, using the Propagate Schematic Selection 
To Map command lets you highlight the features associated with a set of 
schematic elements currently selected in your schematic diagrams. These 
tools also work for diagrams generated with the Custom Query-Based 
Builder but require some code to be developed to define which features 
are associated with schematic elements. The way to develop a component 
to define this relationship is detailed in the VB section of the ArcGIS 
Schematics training.
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