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Welcome to ArcReader and ArcGIS Publisher 1
• Sharing information

• Viewing maps

• Exploring data

• Printing maps

• Publishing maps with ArcGIS
Publisher

• Tips on learning ArcReader and
ArcGIS Publisher
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2 USING ARCREADER AND ARCGIS PUBLISHER

Sharing information
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Examples of maps created in ArcMap,
published with ArcGIS Publisher, and
viewed in ArcReader.
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WELCOME TO ARCREADER AND ARCGIS PUBLISHER 3

Viewing maps
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Being able to share well-designed maps, such as these, increases their
value greatly.
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4 USING ARCREADER AND ARCGIS PUBLISHER

Exploring data
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You can identify features to see their attributes.
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WELCOME TO ARCREADER AND ARCGIS PUBLISHER 5

Printing maps
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These maps can all be printed once they are opened in ArcReader.

Ch01.pmd 10/30/02, 2:34 PM5



6 USING ARCREADER AND ARCGIS PUBLISHER

Publishing maps with ArcGIS Publisher
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Publisher menu

Example of a map being published in ArcMap
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Finding answers to questions
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Getting help on your computer
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Tips on learning ArcReader and ArcGIS Publisher

Contacting ESRI
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ESRI education solutions

��(%����6�
	��	
������
����������
���	���	���	
�����	��������
�
��������
����	
�	2�$%������������
�2��

��	��
����.8�@�����

�����	����
���
��������;�	
������	�2�:	";"��	
������	�2��


�	��;���
.�����"����������

�	
������
��������
�����������.���
�	��
�
����.�	8�B������	��
��������
2�6����������������	�
��
��������
� ��	�:	"8

Ch01.pmd 09/18/2002, 9:02 AM7



Ch01.pmd 09/18/2002, 9:02 AM8



IN THIS CHAPTER

9

ArcReader tutorial 2
• Exercise 1: Viewing a map

• Exercise 2: Querying a map

• Exercise 3: Printing a map

The best way to learn ArcReader is to try it yourself. This tutorial guides
you through some basic ArcReader skills as you explore a map of Canada.

Exercise 1 introduces various ways that you can view a map in ArcReader.

Exercise 2 shows you how to query a map in ArcReader to get the most
information possible from it.

Exercise 3 walks you through printing a map from ArcReader.

Each exercise in this tutorial takes between 15 and 20 minutes to complete.
You can either work through the entire tutorial at once or complete each
exercise one at a time.

Before you begin the exercises in this tutorial, install the ArcReader tutorial
data. To install the data, run the Tutorial setup during the ArcReader
installation. You also have the option of running the Tutorial setup
independently of the ArcReader installation.

Ch02.pmd 09/18/2002, 10:33 AM9



10 USING ARCREADER AND ARCGIS PUBLISHER

2. Click the Look in dropdown arrow and navigate to the
Map folder on the local drive where you installed the
tutorial. (C:\arcgis\arcexe82\ArcTutor is the default
location.)

3. Double-click Gulf of St. Lawrence.pmf.

ArcReader opens the map.

Exercise 1: Viewing a map

In this exercise, you will open and explore a published map
with ArcReader. You will also use ArcReader to query data
on the map.

Starting ArcReader

1. Click Start on the Windows taskbar.

2. Click Programs, point to ArcGIS, and click ArcReader.

ArcReader opens.

Opening an existing published map

1. Click File and click Open.

�

�

�

�
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ARCREADER TUTORIAL 11

ArcReader can open published map files (.pmf) that have
been created in ArcMap using Publisher. These published
maps do not actually store the data shown on the map, but
rather reference the data, which may be stored on a local
disk, on another computer, or on the Internet. The map
document stores map elements, such as titles, scalebars,
and North arrows.

This particular map contains the following layers in a data
frame named Gulf of St. Lawrence:

Layers What layers contain

Links to Web Sites Internet addresses

Cities Locations of population centers

Major Roads Locations of expressways and
primary  highways

Base Map Contains land and coastline layers

A data frame is a frame on the map that displays layers in
the same geographic area.

The map portrays the Gulf of St. Lawrence and the
surrounding region. Notice that there are check boxes next
to each layer name in the table of contents. All layers that
are checked are drawn in the map display area.

Moving around a map

The Data toolbar has tools to move around the map and
query features on the map. Hover your cursor over each
icon (without clicking) to see the name of each tool. The
name is displayed in a ToolTip. This tutorial will use these
names to refer to specific buttons and tools. When you
interact with the map, one of these tools will be active, and
the pointer will change to the active tool when moved over
the map.

This is an example of a .pmf—the Gulf of St. Lawrence.pmf.

Table of
contents Data toolbar  Map display

Ch02.pmd 09/18/2002, 10:33 AM11



12 USING ARCREADER AND ARCGIS PUBLISHER

If you need more information about how a tool or command
works, you can quickly access the context-sensitive help
that is available for most tools. Press Shift+F1 on your
keyboard while hovering over the tool with the mouse.

1. Click the Zoom In tool, then click and drag a box around
Anticosti Island and a portion of the St. Lawrence River.
This will make it easier to read the labels and see where
the cities and roads are located.

2. Using the Pan tool you can interactively manipulate the
map. Click the Pan tool, then click the map and hold
down the left mouse button to drag the display in any
direction.

3. The Go Back and Go Next buttons can be used to revisit
any of the places to which you have previously zoomed
or panned. Click the Go Back button now to view the
previous map extent.Context-sensitive help for the Zoom In tool is shown above.

Pan tool

�
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ARCREADER TUTORIAL 13

Using bookmarks

Bookmarks are named map extents created by the publisher
of the map. The publisher zooms to a specific view of the
map and saves it for future use. You can access the
publisher’s saved extents by selecting Bookmarks.

1. Click the View menu, point to Bookmarks, then click
Prince Edward Island.

The map now shows Prince Edward Island.

2. Click the View tab, point to Bookmarks, then click Gulf
of St. Lawrence to reset the map to its original display.

To learn how to set bookmarks, see Using ArcMap.

�

�
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14 USING ARCREADER AND ARCGIS PUBLISHER

Turning layers on and off

The table of contents is where you turn map layers on and
off. To display a layer, check the Layer visibility check box
next to its name. To turn the layer off, uncheck the box.

1. Check Links to Web Sites.

Notice the blue question mark symbols now draw on the
map.

2. Uncheck the Links to Web Sites.

Notice that the layer is turned off and no longer displays
on the map.

Getting information about layers

Each of the layers in a map has a set of properties that can
be viewed, allowing you to learn what features are available
for that layer.

1. In the table of contents, right-click Major Roads and
click Properties.

Layer visibility check box

�

�
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ARCREADER TUTORIAL 15

Using the magnifier window

There are times when you may not want to change the
location displayed on the map but still need to see more
detail. The ArcReader magnifier window allows you to do
this.

1. Click Window and click Magnifier.

The magnifier window opens.

2. Click the title bar of the magnifier window and drag it
over the map. While you are dragging it, the magnifier
window will show a crosshair to indicate what part of
the display will be magnified.

2. Click the General tab.

You can see whether the layer is displayed at all scales
or only within a specific range of scales and whether
Map Tips have been enabled for the layer. Map Tips are
onscreen descriptions of map features that appear when
you hover the mouse pointer over a feature. Later in this
tutorial you will use Map Tips from this layer.

3. Click OK to close the Layer Properties dialog box.

�

�

�
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16 USING ARCREADER AND ARCGIS PUBLISHER

3. When the crosshair is over the portion of the map you
would like to magnify, release the mouse button. You will
see a magnified view of the location under the magnifier.

Changing the magnifier window properties

You can change several of the magnifier window
properties, such as the magnification factor and what the
magnifier window displays.

1. Move your cursor near the edge of the magnifier
window, then click and drag the cursor in the direction
you want to resize the window (make it a little larger).

2. Place your cursor in the middle of the magnifier window
and right-click.

3. Point to Magnification Factor and click 800%. This will
scale the data displayed in the magnifier window by the
percentage chosen.

4. Right-click the magnifier window and click Snapshot.
Move the magnifier window somewhere else; notice that
the picture doesn’t change, but instead keeps your
snapshot.

5. To reenable the magnifier, right-click the magnifier
window and click Snapshot again. The window redraws
to magnify the section of the map it is over. When you
have finished experimenting with the magnifier window,
click the Close button to close it.

� �
While dragging

Result after dropping

�

�
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ARCREADER TUTORIAL 17

Data view and Layout view

ArcReader is capable of displaying a map in either Data
view or Layout view. Up to this point this tutorial has been
using Data view. Data view shows the contents of a data
frame. Layout view shows the map as it would appear on a
printed page. Layout view also shows map elements that
aren’t contained within the data frame, such as the map
title, legend, scalebar, and North arrow.

1. Click the View tab and click Layout View.

The map displays in Layout view. Notice the page
includes a title, legend, scalebars, and some supporting
text. Also displayed is the Layout toolbar, which contains
tools for navigating in Layout view. Hover your cursor
over each icon, without clicking, to see the name of each
tool.

The Layout tools in the Layout toolbar are used like the
tools in the Data toolbar. They allow you to change the way
the page is displayed. Notice that the data tools are still
accessible for changing the view of the data within the data
frame.

    Page for map

Data view

Layout toolbar

Layout view
Refreshes

�

There is a shortcut for switching between Data and Layout
view. In the scrollbar near the bottom of the map, there are
three small buttons. Clicking the globe icon switches to
Data view, clicking the page icon switches to Layout view,
and clicking the arrow icon refreshes the map.

In this exercise, you learned various ways to view a
published map in ArcReader. In the next exercise, you will
learn how to query a map in ArcReader.
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A map in ArcReader typically contains more information
than you initially see. For example, a feature may hold
attribute information that is not labeled or displayed on the
map. With ArcReader you can query that information or
use Map Tips to find a feature on the map.

Using Map Tips

The most readily accessible kind of map attribute
information comes in the form of Map Tips. A Map Tip is
an attribute chosen by the map author that displays
whenever you hover any data tool over a feature on the
map. Map Tips are only visible while in Data view.

1. Click the Data view button, located at the bottom-left
part of the map.

2. Click any data tool and hover over a road to see its
name.

The Major Roads layers is the only layer in this map that
has Map Tips enabled. You can tell if Map Tips are enabled
for a layer by right-clicking the layer name in the table of
contents and clicking the General tab on the Properties
dialog box.

Road name

Exercise 2: Querying a map

Ch02.pmd 09/18/2002, 10:34 AM18
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Identifying a location

9����������������������#��������������$��.�������
������������#�����������$������������������������������
��������������������"��������������������������������������� 

: 0���.������������#����� 

*����������#�$����$������ 

1 0���.������������#������������$���������������.�;-������
��#���< 

4 0���.�����-��$�����%�����.�=��.���.�%����������.�������
	�$���������� 

�

��

5 0���.��������������������������������#����0����������$� 

>����������������������#���������������������#������������
������0����������$��������������������������������
��?��������%�0����������%�����@��� �*����������#��������
������������"���������#��� 
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Identify window commands

�����7����.������������%���#���%���������������������������
�������#�$����$����������������������$���������������
$��.����$�������������������������������������#�� 

: �����7����.�����#������������� �*�������������������������
���������$�#���������������������������%�������������
�������#�����%����������������%�������#��������� 

1 �����7����.����������������-����������� �*�������������
���������������������$�#������������/������6�����"����� 
9������������������$���������������%����������������������%
�������������������������������(��"��������������)%���
���#��������������� ����#�������.�0��#%�#�����������������
����������������������������������������%���������������
����������������������� 

4 0���.�����������������$����������������������������
@�������������������������������������$��������$�#�����
������#������������������������#�����������������#���
������ �0���.������� 

5 0����������������#�$����$ 

Feature  Attributes

Layer  Location

�

�

� �
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Finding a location

���
������������������#����������������������������������
���"���������������6�������� 

: 0���.�����6�������� 

*���6���������������������� 

1 �������6������������%��#���A@������B 

4 0���.����������#����������$������$���������.�;
��
��#���< 

5 0���.�6��� �
������������������������#��������@������
�������$������������$������������������������������
$����$ 

�

C����#��'"���������������%�#���������������6����������
���������"���������������������������������������� 

8 �������6��������������%������7����.�@���������������.
D��������������(�) �
���������/���������������#���
@������ 

E ��.�����������6��������������������������"����������#���
@������ ��������6��������������%������7����.�@����������
�������6������������ �@�������$��������� 

F �����7����.�@���������������.��������#��������(�) �*��
�������#�6�����������������������������%�$�������������
�����������������������������������������#����@������%
������� 

G 0����������������#�6���������������������������������
����6�������������� 

�� �� Results section of Find
dialog box

� ��
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Using hyperlinks

�����"��$���$����
�����������#���"���#������.����
���"������������������������������������������������� �*��
��������
� �@�$��������������������#������.���������@��.�
�������
�������#�� �!#������.���������#��"�����������H���
"��$%�����#���$�������������������������������������������
���� �0���.�����-��$�����%����������=��.���.�%�����.�������
	�$����������%���������������$���������������� 

: 0���.�����@��.���������
�������#������������������
�������� �9���������������������3�����������.����������
���������� ��������3�����������.����������������%�/���
���������������������"������ 

1 C������H����������������.�����!#������.�������������"���
�� �>�������������������������������"�������3�������
���. �*������������������������#������.����������� �*��
@��.���������
�������#�������������#���#���$�����#������.�
����������� 

4 !�"�������!#������.�������"�����������������������������
�#������. �*������������������������������������ �0���.
��������#������������������������$��� �*���������������
��������������"������������������	�$����������%
0�����%�$�����#������������������������������
	�$����������%�������#� 
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Measuring distance

9����������������������������
�������� �*���
��������
�����������������$��#������������$������������$��������
��������"������������������������.������������� 

: 0���.�����-��$�����%����������=��.���.�%����������.
���������I�����# 

1 0���.�������������������������H����������� 

4 0���.�����70������%������������������������������������J
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�����#���$������������������������ 
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���������#�����"���������� 

����������������%�#�����������"�������$�#�����3���#��
��������������������������������������������� �9����������
����������*������������"����������������������#�����"��������
�����������#������������������������������� ������������
��������%�#���$������������$�������������������
�������� 

Measure tool

�

�
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*�������������������$������������%�#���$��������������"���
���������"������� �*�������������������������������������������
��/��(���
5)����������������������������������������.7���7
$��������������������� 

: 0���.�����
���������6�����������������.������
���� 

*��������
��������������������� �*��������������
��������������������������#����������$�������������#��
������������������������������������������������� 

1 ���������������#���$����������������������������#���
���������������%��.������
����4 �C����$���%�����.�����������
���������
�����������������������������������������
$�����#���$�������������#������� 

Exercise 3: Printing a map

�

�

�

4 0���.�@�������� 

5 ���������������
��������%�����.�����
�/��������$������$
��������.�@������(���
5) 

>��������������������������������������������������������
����������������/���#�����.��������
���������������������.
����������������
��������������� �*�������$���������������
��$����������������� 

8 0���.�CK 
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Printing a map

1. Click the Layout view button.

It’s important to switch to Layout view because your
printing results can vary depending on what view you are
in. Printing in Data view will print the currently displayed
data frame at the current extent to the selected paper size.
The printed data will be scaled to fit the page size selected
in Page Setup. When printing from Layout view the entire
published page is printed.

2. Click the File menu and click Print.

3. Click OK.

In this tutorial you have been introduced to viewing,
querying, and printing published maps with ArcReader. The
next chapter provides more detail about these tasks as well
as information about published maps and their uses in
ArcReader.

In Layout view the original page size
is displayed on the status bar. �
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• Starting ArcReader

• Opening a map

• The ArcReader window

• The table of contents, data
frames, and layers

• Looking at a map in Data view
and Layout view

• Using spatial bookmarks

• The magnifier window

• Exploring and working with data
on a map

• Printing

• Getting help
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Starting
ArcReader
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Starting ArcReader from
the Start menu

1. Click Start on the Windows
taskbar, click Programs, point
to ArcGIS, then click
ArcReader.

Starting ArcReader from
Windows Explorer

1. Navigate to the folder where
your published map (.pmf
extension) is saved, then
double-click the published
map.

ArcReader launches and the
map displays.

�

�
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Opening a map
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Opening a map from
ArcReader

1. Click the Open button or click
the File menu and click Open.

2. Click the Look in dropdown
arrow and navigate to the
folder that contains the map.

3. Click the map you want to
open.

4. Click Open.

Opening a recently
opened map

1. Click File and click a map
from the list of recently
opened maps.

You can also use the Recent
Files button on the File
toolbar.

Recent Files button

Tip

Setting the number of files
in the recent file list
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Open button
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When you see this message, some functionality is not
available in the map.

When you see this message, the data is unavailable for display.

Interpreting the ArcReader information warning messages

Check the check
boxes to turn the
messages about
functionality in
ArcReader on and
off.
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The ArcReader window

The layers are drawn on the map display.

The table of contents lists
the data frames and

layers for the map.

Open

Recent files

Print

Toggle table of contents

Zoom in

Zoom out

Fixed zoom in

Fixed zoom out

Pan

Full extent

Back

Forward

Identify

Find

Measure

Hyperlink
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An unchecked layer will not
be drawn in the display

window.
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The table of contents, data frames, and layers
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Additional data frames display
layers in separate frames on

the map.

Right-click the layer to zoom
to it, find data in it, identify a

feature within it, or see its
properties.

Layers are organized in
data frames, similar to files

in a directory. The active
data frame name is

displayed in bold in the
table of contents.
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Using the table of
contents
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Showing the table of
contents

1. Click the View menu.

2. Click Table of Contents.

This command is used to
toggle the table of contents
on and off.

If the table of contents was
disabled by the map’s author,
it cannot be turned back on.

Turning a layer on or off

1. Check the box next to the
layer’s name in the table of
contents.

The layer should appear on
your map. If you can’t see the
layer, it may be hidden by
another layer or may be set to
display only at a particular
scale.

The spinning globe on the
ArcReader status bar
indicates the map is drawing.

Tip

No table of contents?
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Interrupting the drawing of
the layer
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The data frame
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Showing the contents of
a data frame in the table
of contents

1. Click the plus or minus sign
to the left of the data frame in
the table of contents to show
or hide the list of layers it
contains.

The active data frame is
shown in bold.

2. Right-click the data frame
name and click Properties.
The Data Frame Properties
dialog box shows information
about the coordinate system
and notes from the map
author.
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Viewing a layer’s
properties

1. Right-click the layer name
and click Properties.

The Layer Properties dialog
box opens.

2. Click the General tab.

The General tab contains
information about scale
dependency. Scale depen-
dency is used to draw
features at various scales.
Some data is too dense to
show at small scales. In this
case, the data will draw when
you zoom to a larger scale.

3. Click the Source tab.

The Source tab displays
information about the type,
name, location, and coordi-
nate system of the data
source referenced by this
layer. If the layer has a red
exclamation point next to it in
the table of contents,
ArcReader is unable to
connect to the source data.

Tip

Why isn’t my layer
drawing?
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The Source tab
shows the data type
and location.

�
A Map Tip shows a
text attribute for the
Holston River.
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Accessing the General
tab on the Map
Properties dialog box

1. Click File and click Map
Properties.

The Map Properties dialog
box opens.

2. Click the General tab.

The General tab
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Finding the status of the
data for layers in the map

1. Click File and click Map
Properties.

The Map Properties dialog
box opens.

2. Click the Data tab.

The Data tab
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Tip

Broken data links
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Repairing broken layers
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Click About Accessing Data on the Data tab to learn more about
broken layers and data access.
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Controlling the look and
feel of ArcReader using
the Options dialog box

1. Click the Tools menu and
click Options.

2. Click the General tab.

3. Set the startup options.

4. Click OK.

The changes will be in effect
for current and future
ArcReader sessions.

The appearance of the ArcReader splash
screen and other settings can be
controlled in the Options dialog box.

The Options
dialog box
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Looking at a map
in Data view and
Layout view
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Switching to Layout view

1. Click View and click Layout
View.

ArcReader shows the entire
layout.

Switching to Data view

1. Click View and point to Data
View.

The checked data frame is
the active data frame.

2. Click a data frame.

The selected data frame will
become the active view.

Tip

Not all maps have Data
view and Layout view
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You can also use these buttons to quickly switch
between Data view and Layout view.
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Moving around on the map

The Layout toolbar

The Data toolbar

A data frame on the page

The layout page
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Using Zoom in the data
frame

1. Click Tools, point to Data, and
click Zoom In.

2. Drag a box over the area to
which you want to zoom in
the data frame.

The area will be centered and
enlarged on the screen.

You may also click a location
to Zoom In. You can use
Zoom Out to see more of the
data in a data frame.Tip

Using Pan in the data
frame
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Using the Pan and Zoom
tools on the Data toolbar
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PanZoom
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out
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Zooming to the extent of
a layer

1. Right-click the layer to which
you want to zoom.

2. Click Zoom To Layer Extent.

ArcReader redraws to show
the entire layer.

Tip

Why doesn’t a layer draw
when I move around the
data frame?
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Zooming to make a scale-
dependent layer visible

1. Right-click the scale-
dependent layer to which you
want to zoom.

Scale-dependent layers only
draw at specific map scales.

2. Click Zoom To Make Visible.

ArcReader zooms to a scale
that will make the layer draw.
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Zooming the layout

1. Click Tools, point to Layout,
and click Zoom In. This allows
you to zoom in on the map
page.

2. Using the Zoom In tool, drag
a box around the area of
interest. The area will be
centered and enlarged in the
display window.

The extent of the data frame
remains unchanged, and map
elements appear larger.

Layout tools are only avail-
able while in Layout view. To
see more of the page, use
Zoom Out.

Zooming to a specific
scale in the data frame

1. Type the desired scale in the
text box or click a scale from
the dropdown list.
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Using spatial
bookmarks
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1. Click the View menu, point to
Bookmarks, and click the
name of the bookmark you
want to use.

The predefined area displays.

Tip

Reloading the map
$
��������%�
��
���������
���
&�
���������������
������������
�	�����

�����
������

�

Ch03.pmd 09/17/2002, 4:07 PM45



46 USING ARCREADER AND ARCGIS PUBLISHER

The magnifier
window
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Opening the magnifier
window and setting the
view

1. Click the Window menu and
click Magnifier.

The magnifier window
appears.

2. Drag the magnifier window
over the data to see a
magnified view.

3. Right-click inside the
magnifier window to access
different options.

Tip

The magnifier window
updates when you switch
between Data and Layout
view
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Exploring and
working with data
on a map
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Finding features with
attribute values

1. Click the Find button.

2. Type the attribute value of
interest in the Find text box.

3. Click the In layers dropdown
arrow and click the layer you
want to search.

4. Search for the attribute in all
fields, in a specific field, or in
the primary display field.

5. Click Find.

6. Right-click the found feature
listed in the results window to
Flash, Zoom to, or Identify
the feature.

Tip

Finding features faster by
narrowing the search
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Tip

Accessing the Find tool
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Identifying features by
pointing at them

1. Click the Identify button.

An empty Identify dialog box
appears.

2. Click the map feature you
want to identify or drag a box
around multiple features.

By default, information about
the topmost layer will be
shown in the Identify window.

3. Use the Identify from
dropdown arrow to identify a
feature in a specific layer.

Only features in that layer will
show up in the Identify results
window.

Getting the location of
the identified feature

1. Click a feature in the Identify
tree.

2. Click the small dropdown
arrow to the right of the
Location text box to select the
location units of your choice.

Tip

Accessing the Identify tool
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Tip

Identifying a location
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Tip

Identifying multiple
features at once
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When you click a feature, the location will be
updated to show the x,y location of the feature.
The centroid is returned for polygons, and the
midpoint is shown for lines. The feature will also
flash to help you find it in the display.
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Copying attributes from
the Identify window

1. Click an attribute in the
Identify window.

2. Right-click the field and click
Copy.

You can now paste the
attribute into another
software application.

Copying the entire record

1. Right-click the feature in the
Identify tree and click Copy
Record to copy the entire
record.

The feature’s record can now
be pasted into another
application.

Tip

Copying the field values
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Measuring distance

1. Click the Measure button on
the Data toolbar.

2. Click the map at the location
you want to start measuring.

3. Move the pointer to the point
to which you want to mea-
sure. If you would like to
measure along the curve of a
line, click along the line to
add vertices.

4. Double-click to end the line.

Accessing hyperlinked
features

1. Click the Hyperlink button on
the Tools toolbar.

Hyperlinked features are
outlined in blue when using
the Hyperlink tool. When you
hover over the feature, the
icon will change to a hand,
and you will see a popup tip
with the name of the target.

2. Click a hyperlinked feature.

The hyperlink will open. In
this case, the hyperlink is an
Internet Web page.

�

The measurement displays here on the status bar.

Tip

The Measure tool
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Tip

Controlling whether
hyperlinks are drawn
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The Hyperlink tool
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Printing
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Showing margins

Before printing, it is important to
know the published page size of
the map you are working with.

1. Click the Layout button.

2. Click the File menu and click
Page Setup.

3. Choose your printer and the
paper size.

4. Choose the desired orienta-
tion—Portrait or Landscape—
for your map.

5. Check the Show Margins
check box to see the printer
margin in Layout view if you
are unsure about the chosen
paper size and orientation
settings.

6. Check the Scale to fit Page
check box if the map you are
working with has a page size
that is too large for your
printer, allowing you to print
the map to the paper size of
your choice.

� The page size is shown on
the ArcReader status bar.

�

�
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Using Page Setup to determine the appropriate paper size

Notice that Landscape would be a more
appropriate setting for this map. Only the
portions of the map within the red rectangle
will print on the printer page (as shown on the
lower right).

The printed page

What you see after checking the Show
Margins check box in Page Setup

What you see before checking the Show
Margins check box in Page Setup
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Printing a large map on a small page
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The printed page

Printer margin for a letter-size page Notice that Scale to fit Page does not
change the appearance of the map in
ArcReader.
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Printing from Data view
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Printing from Layout view
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The map displayed in Data view

Printing from Data view scales the data in the ArcReader
display window to fit the printer page.
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Getting help
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Getting help in the
ArcReader window

1. Move the pointer over a
button or command and press
Shift+F1 on your keyboard.

Help text appears.

2. Click anywhere on the screen
to close the Help description
box.

Getting help in a dialog
box

1. Click the What’s This? button.

2. With the Help pointer, click
the item in the dialog box
about which you want more
information.

3. Click anywhere on the screen
to close the Help description
box.
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Closing and
exiting
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Closing an opened map

1. Click the File menu and click
Close.

Opening a new map also
closes the current map.

Closing ArcReader

1. Click the File menu and click
Exit.

The ArcReader session is
ended.
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�

Enabling and adding the
Publisher toolbar

1. Click the Tools menu in
ArcMap and click Extensions.

2. Check Publisher in the
Extensions dialog box.

3. Click Close.

4. Click the View menu, point to
Toolbars, and click Publisher.

The Publisher toolbar will be
added to ArcMap.

Starting ArcGIS
Publisher
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Why is the Publisher
toolbar unavailable?
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The Publisher
toolbar is added to

ArcMap
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Preparing maps for publishing in ArcMap
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Accessing data
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Delivering data with the map
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Converting local drive
paths to UNC paths

1. Open ArcMap, click the Add
Data button, then click the
Add button to add data from a
local drive.

2. Right-click the layer in the
table of contents and click
Properties.

3. Click the Source tab and click
Set Data Source in the Layer
Properties dialog box.��

Creating a map
to share on a
computer
network
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Notice the current data source is local.
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4. Click the Connect To Folder
button.

5. Double-click Network
Neighborhood on the
Connect to Folder dialog box,
browse to the directory on the
computer that contains the
data, then click OK.

6. Click Add in the Data Source
dialog box to close it and get
back to the Layer Properties
dialog box.

In the Layer Properties dialog
box, you will now see that the
UNC pathname is stored in
the map.

The UNC pathname will be
published in the map, and all
computers on the network
with access to the directory
will be able to use the map in
ArcReader. �

�

The UNC
pathname

is stored in
the map.
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Creating a map
to distribute with
data
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Creating a map with
relative path data

1. Open Windows Explorer and
put all of the data that will be
used to create the map into
the same folder.

2. Click the Add Data button
and add your data to the
map.��
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3. Click the File menu and click
Map Properties.

4. Click Data Source Options on
the Map Properties dialog
box.

5. Click Store relative path
names in the Data Source
Options dialog box, then
click OK.

6. Click OK in the Properties
dialog box.

7. Click the Publisher menu and
click Publish Map.

8. Publish or save the map in a
directory that has the same
parent directory as the data
in the map. The data in the
map will be referenced
correctly as long as the map
and data stay in the same
relative location to one
another. Send the whole
directory to anyone that will
be using the map.
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Creating a map
with Internet data
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Creating a map with
Internet data

1. Click the File menu, point to
Add Data from Internet, and
click Geography Network.

2. Search for Geography
Network data and add it to
ArcMap.

3. Click the Publish Map button
on the Publisher menu bar
and enter the output location.

The published map can be
sent to and used by anyone
who has ArcReader
and a Geography
Network connection.

Tip

ArcReader can open maps
from the Geography
Network
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Using Publisher
settings
2�������������������������������
���
� ���	�
���
�������
�������
����� ���� ���� ���	�
0��� ��
���������������������	�
���
���
3���"���� ������ ���� ����
�������� �"�������� ����� ������ ���
���
��������������������������
"����
� ��
� ���
� ���	�
���
���
9�����2���������� ���� 
��
������
�� ����"������������
���


��������������������������������

�����
��� ��� �"��� ���
���� �
�������
� ��� �����
�� ��������
#��� ��������� ���� 
������
� ��
��"�� �������� ������� 
������
�"������������������"����
���

��������
���� ����������
��#��
���������� ������ ����� ���� ���
����������������������
��������
�������� ��� ������
��

���
����������

Publishing a map with
default settings

1. Open a map document in
ArcMap.

2. Click the Publisher menu.

3. Click Publish Map.

4. Choose the output location
for your published map and
click Save.

A published map will be
created that will look the
same in ArcReader as it
does in ArcMap.
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Publishing a map with
just the visible layers

1. Click Publisher and click
Settings.

2. Click Only include layers that
are checked on in the Table
of Contents.

This setting allows you to
choose specific layers for
publishing in a map without
removing the layers from the
map.

3. Click OK.

4. Click Publisher and click
Publish Map.

Publishing a map with
just the Data view
enabled

1. Click Publisher and click
Settings.

2. Click the Contents tab in the
Publisher Settings dialog box
and click Data view only.

Only the data frames will be
viewable in ArcReader. That
means the map’s page layout
elements will not be included
in the published map and
Layout view will be
unavailable.

If you want, you can also
choose the data frame that
will be visible in ArcReader. �
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3. Check the Restrict Data view
to one data frame check box
and choose a data frame
from the dropdown list to
publish one specific data
frame. ArcReader will not be
able to view the data frame in
Layout view.

4. Click OK.

5. Click the Publisher menu and
click Publish Map.
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Publishing just the
Layout view

1. Click Layout view only in the
Publisher Settings dialog
box.

Only the Layout view will be
available in ArcReader. It will
not be possible to view the
map in Data view.

2. Click OK.

3. Click Publisher and click
Publish Map.

Disabling ArcReader
commands and tools

1. Click Publisher, click
Settings, then click the
Functionality tab.

2. Uncheck the commands and
tools in the list that will be
disabled in ArcReader, then
click OK.

When the map is opened, a
message will appear telling
the ArcReader user that
some functionality has been
disabled. To supress this
message, uncheck the
Display disabled functionality
message when this map is
opened in ArcReader check
box before publishing the
map.

3. Click Publisher and click
Publish Map.

�

�

�
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Protecting published
maps with a password

1. Click the Publisher menu
and click Settings.

2. Click the Other tab in the
Publisher Settings dialog
box.

3. Check the Password protect
the published map check
box.

4. Type in a password and
confirm the password.

5. Click OK.

ArcReader requires the
password to open the map.

Including secure-layer
passwords

1. Click the Publisher menu and
click Settings.

The Publisher Settings dialog
box appears.

2. Click the Other tab. Check the
Save the password within the
published map check box.

3. Click OK.

Secure data requires a
password to be entered when
it is added to ArcMap. Use
this setting to store secure-
layer passwords in the
published map if you want
the ArcReader user to see
the secure layers without
entering a password.

Tip

You can open published
maps that contain secure
layers with or without a
password.
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Adding comments to
publish with the map

1. Click the Publisher menu and
click Settings.

2. Click the Other tab in the
Publisher Settings dialog
box.

3. Type comments into the
Comments text box.

4. Click OK.

ArcReader users will be able
to see the comments in the
ArcReader Map Properties
dialog box.

�
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The Map
Contents
Summary dialog
box
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1. Click Publisher and click
Map Contents Summary.

The Map Contents Summary
dialog box appears.

The Map Contents Summary dialog box shows you the
parameters that control how the map will be published.
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Sharing your
maps
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Opening maps shared on
the Geography Network
with ArcReader

1. Click the File menu n
ArcReader, point to Open
Map from Internet, then click
Open Map from the
Geography Network.

2. Search for a map and add it
to ArcReader.
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Tip

Adding Web sites to your
map other than the Geogra-
phy Network
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Choosing a map to publish
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Enabling and loading the Publisher toolbar
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Exercise 1: Publishing a map
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Using context-sensitive help to get more
information about Publisher
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Publishing a map using the default settings
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Viewing the map in ArcReader
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Publishing a map in Data view only
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Exercise 2: Customizing ArcGIS Publisher settings
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��������������������������
��������%�����������������#���������������������������������������������������# 

This is an example of a map published with only Data view enabled.

The Layout view button is disabled.
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Publishing a map without a table of contents
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The message notifies the user that some commands or tools have
been disabled.
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Publishing a map that is password protected
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Exercise 3: Using ArcGIS Publisher security settings
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ArcReader prompts for a password when the map is opened.
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12Glossary active data frame
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feature class
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