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A Selection of Time-Saving Tips and Shortcuts

ArcGIS® Desktop

Tips and Time-Savers

Shortcut Availability

In any application, click Tools > Customize to enter customization mode where you can 
drag controls around to rearrange the user interface the way you want. 

9.1, 9.2

Access context-sensitive help by clicking the What’s This tool         and clicking any 
command or button. To get context-sensitive help for a command on a context menu, 
highlight the command and press Shift + F1.

9.1, 9.2

In ArcCatalog™, drag a folder onto the entry at the top of the Catalog tree to create a 
folder connection to it.

9.1, 9.2

Rename your folder connections in ArcCatalog to give them more meaningful names. 9.2

Use the Window > Viewer command or the Create Viewer Window tool on the Data 
Frame Tools toolbar to set up custom viewer windows. Viewer windows are fully 
functioning live ArcMap displays, so all tools and navigation shortcuts work inside them. 

9.2

In the Catalog tree, drag and drop your most frequently used coordinate systems into 
the top level of the Coordinate Systems folder for quick access to them on dialog boxes.

9.2

Control how far out the Full Extent button will take you by setting the full extent 
property on the Data Frame Properties dialog box.

9.2

In a table, calculate area, length, perimeter, centroid, and point coordinates by right-
clicking the name of a text or numeric field and choosing Calculate Geometry.

9.2

The Results tab on the ArcToolbox™ window keeps a record of all the geoprocessing you 
have done. 

9.2

Right-click any tool in the ArcToolbox window and click Batch to execute a single tool 
multiple times with different inputs without your intervention.

9.2

Additional ArcGIS Resources
What’s New in ArcGIS: www.esri.com/whatsnew

ArcGIS Desktop Help Online: www.esri.com/webhelp

Support: www.esri.com/support

Training: www.esri.com/training

Books: www.esri.com/esripress

All Editing Tools

Function Shortcut Availability

Show vertices of features near your cursor V 9.1, 9.2

Temporarily suspend snapping (especially useful when 
tracing along features)

Spacebar 9.1, 9.2

Sketch Tool

Create a segment parallel to an existing one Ctrl + P 9.1, 9.2

Create a segment perpendicular to an existing one Ctrl + E 9.1, 9.2

Create a segment at an exact angle Ctrl + A 9.1, 9.2

Create a segment at an exact length Ctrl + L 9.1, 9.2

Create a segment at an exact angle and length Ctrl + G 9.1, 9.2

Enter coordinate by value F6 9.1, 9.2

View the snapping tolerance represented as a circle 
around your cursor

T 9.1, 9.2

Delete the sketch Ctrl + Delete 9.1, 9.2

Finish the sketch F2 9.1, 9.2

Finish a part of the sketch to create a multipart feature Shift + double-click 9.1, 9.2

Undo last edit Ctrl + Z 9.1, 9.2

Edit Tool

Move the selection anchor Ctrl 9.1, 9.2

Toggle through selected features within the selection 
tolerance to select correct one when there are multiple 
overlapping features

N 9.1, 9.2

Toggle among Edit, Sketch, and Edit Annotation tools 
when one is active 

E 9.1, 9.2

Editing Tips and Time-Savers

When editing in ArcMap™, you can do on-the-fly unit conversion if you specify the unit 
type when you type a distance. When you enter a distance into a pop-up window, press 
F1 to get a list of the unit abbreviations you can use.

9.1, 9.2

Use the sticky move tolerance on the Editing Options dialog box to set a minimum 
number of pixels your pointer must move on the screen before a selected feature is 
moved. This helps prevent features from being accidentally moved small distances when 
they are clicked with the Edit tool.

9.1, 9.2

Customize the Editor toolbar to move the Start Editing, Stop Editing, and Save Edits 
commands onto the toolbar itself. Once moved, right-click each control and choose 
Image Only to show it as a button you can access with just one click.

9.1, 9.2



Map Navigation

Function Shortcut Availability

Refresh and redraw the display F5 9.1, 9.2

Suspend the map’s drawing F9 9.1, 9.2

Zoom in and out Roll the mouse wheel 
backward and forward. Hold 
down Ctrl for a finer zoom. To 
switch direction of the mouse 
roll, go to Tools > Options > 
General tab.

9.2

Center map Click mouse wheel. Ctrl + 
click to center and zoom in.

9.2

Pan Hold down mouse wheel 
and drag

9.2

Zoom in on box you define Ctrl + drag mouse wheel 9.2

Temporarily change to Zoom In tool Hold down Z 9.2

Temporarily change to Zoom Out tool Hold down X 9.2

Temporarily change to Pan tool Hold down C 9.2

Temporarily change to Continuous Zoom/Pan tool Hold down B 9.2

In layout view, apply the navigation to the data frame 
rather than the page

Shift + navigation shortcuts 9.2

Nudge or scroll map Arrow keys or Home, End, 
Page Up, Page Down

9.2

Go back to the previous extent < 9.2

Go forward to the next extent > 9.2

Open context menu of useful shortcuts to various 
commands

Right-click map in data view 
with any tool

9.2

Toggle among Zoom In tool, Zoom Out tool, or Pan 
tool when one is active

F6 9.2

Full Extent Insert 9.2

Zoom to layer’s extent Alt + click layer name in the 
table of contents

9.2

Table of Contents

Function Shortcut Availability

Put keyboard focus on the table of contents F3 (or click the table of 
contents)

9.1, 9.2

Put keyboard focus on the map Esc (or click the map) 9.1, 9.2

Expand/Contract selected items Left/Right arrows  
or + and - keys

9.1, 9.2

Expand/Contract all the items at that level Ctrl + click an expansion 
control

9.1, 9.2

Turn on/off selected layers Spacebar 9.1, 9.2

Turn on/off all layers Ctrl + spacebar 9.1, 9.2

Turn on/off all layers at that hierarchical level or all 
selected layers

Ctrl + click a check box 9.1, 9.2

Activate data frame F11 (or Alt + click a data 
frame)

9.1, 9.2

Cycle through each data frame and activate it Ctrl + Tab  9.1, 9.2

Open context menu for selected item Application key (or Shift + 
F10) 

9.1, 9.2

Rename selected item F2 9.1, 9.2

Open properties dialog box of a selected item F12 (or Enter) 9.1, 9.2

Select multiple layers in the table of contents Ctrl + click or Shift + click 9.1, 9.2

Copy layers inside a data frame instead of reordering 
them, or move layers between data frames instead of 
copying

Hold down Ctrl and drag 
and drop

9.1, 9.2

Tables

Open context menu of field management shortcuts Right-click field name 9.1, 9.2

Open context menu of selection and navigation 
shortcuts

Right-click gray cell to the left 
of a record 

9.2

Open table for any item in the table of contents Ctrl + double-click 9.2

Open tables for selected items in table of contents Ctrl + T 9.2

Close all open table windows Ctrl + Shift + F4 9.2

Tables (Continued)

Function Shortcut Availability

Sort field Double-click field name 9.2

Turn off field Ctrl + double-click field name 9.2

Zoom in and out on table window Ctrl + roll mouse wheel 9.2

Toggle Show All and Show Selected views Ctrl + Tab 9.2

Select all records Ctrl + A (or Shift + click top 
left gray cell)

9.2

Deselect all records Ctrl + Backspace (or click top 
left gray cell)

9.2

Switch selection Ctrl + U (or Ctrl + click top 
left gray cell)

9.2

Deselect row Backspace 9.2

Work sequentially through table, selecting each record 
in turn

Ctrl + Enter 9.2

Go to cell below Enter 9.2

Go to cell to right and wrap around to next row down Tab 9.2

Go to first cell in the current column Ctrl + Up arrow 9.2

Go to last cell in the current column Ctrl + Down arrow 9.2

Zoom to selected features Ctrl + Shift + = 9.2

Flash the current feature Ctrl + 8 9.2

Zoom to the current feature Ctrl + = 9.2

Pan to the current feature Ctrl + P 9.2

Identify the current feature Ctrl + I 9.2

Zoom to feature represented by a record and select it Hold down Ctrl + double-
click to select and pan

9.2

Start or stop an edit session Ctrl + Shift + E 9.2

Copy cell value onto the clipboard Ctrl + C 9.2

Copy selected records onto the clipboard Ctrl + Shift + C 9.2

Start editing a cell F2 9.2

Cancel editing and restore cell’s original value Esc 9.2

Delete the selected records Delete (or Ctrl + D) 9.2
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Sort field Double-click field name 9.2

Turn off field Ctrl + double-click field name 9.2
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Start editing a cell F2 9.2

Cancel editing and restore cell’s original value Esc 9.2
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A Selection of Time-Saving Tips and Shortcuts

ArcGIS® Desktop

Tips and Time-Savers

Shortcut Availability

In any application, click Tools > Customize to enter customization mode where you can 
drag controls around to rearrange the user interface the way you want. 

9.1, 9.2

Access context-sensitive help by clicking the What’s This tool         and clicking any 
command or button. To get context-sensitive help for a command on a context menu, 
highlight the command and press Shift + F1.

9.1, 9.2

In ArcCatalog™, drag a folder onto the entry at the top of the Catalog tree to create a 
folder connection to it.

9.1, 9.2

Rename your folder connections in ArcCatalog to give them more meaningful names. 9.2

Use the Window > Viewer command or the Create Viewer Window tool on the Data 
Frame Tools toolbar to set up custom viewer windows. Viewer windows are fully 
functioning live ArcMap displays, so all tools and navigation shortcuts work inside them. 

9.2

In the Catalog tree, drag and drop your most frequently used coordinate systems into 
the top level of the Coordinate Systems folder for quick access to them on dialog boxes.

9.2

Control how far out the Full Extent button will take you by setting the full extent 
property on the Data Frame Properties dialog box.

9.2

In a table, calculate area, length, perimeter, centroid, and point coordinates by right-
clicking the name of a text or numeric field and choosing Calculate Geometry.

9.2

The Results tab on the ArcToolbox™ window keeps a record of all the geoprocessing you 
have done. 

9.2

Right-click any tool in the ArcToolbox window and click Batch to execute a single tool 
multiple times with different inputs without your intervention.

9.2

Additional ArcGIS Resources
What’s New in ArcGIS: www.esri.com/whatsnew

ArcGIS Desktop Help Online: www.esri.com/webhelp

Support: www.esri.com/support

Training: www.esri.com/training

Books: www.esri.com/esripress

All Editing Tools

Function Shortcut Availability

Show vertices of features near your cursor V 9.1, 9.2

Temporarily suspend snapping (especially useful when 
tracing along features)

Spacebar 9.1, 9.2

Sketch Tool

Create a segment parallel to an existing one Ctrl + P 9.1, 9.2

Create a segment perpendicular to an existing one Ctrl + E 9.1, 9.2

Create a segment at an exact angle Ctrl + A 9.1, 9.2

Create a segment at an exact length Ctrl + L 9.1, 9.2

Create a segment at an exact angle and length Ctrl + G 9.1, 9.2

Enter coordinate by value F6 9.1, 9.2

View the snapping tolerance represented as a circle 
around your cursor

T 9.1, 9.2

Delete the sketch Ctrl + Delete 9.1, 9.2

Finish the sketch F2 9.1, 9.2

Finish a part of the sketch to create a multipart feature Shift + double-click 9.1, 9.2

Undo last edit Ctrl + Z 9.1, 9.2

Edit Tool

Move the selection anchor Ctrl 9.1, 9.2

Toggle through selected features within the selection 
tolerance to select correct one when there are multiple 
overlapping features

N 9.1, 9.2

Toggle among Edit, Sketch, and Edit Annotation tools 
when one is active 

E 9.1, 9.2

Editing Tips and Time-Savers

When editing in ArcMap™, you can do on-the-fly unit conversion if you specify the unit 
type when you type a distance. When you enter a distance into a pop-up window, press 
F1 to get a list of the unit abbreviations you can use.

9.1, 9.2

Use the sticky move tolerance on the Editing Options dialog box to set a minimum 
number of pixels your pointer must move on the screen before a selected feature is 
moved. This helps prevent features from being accidentally moved small distances when 
they are clicked with the Edit tool.

9.1, 9.2

Customize the Editor toolbar to move the Start Editing, Stop Editing, and Save Edits 
commands onto the toolbar itself. Once moved, right-click each control and choose 
Image Only to show it as a button you can access with just one click.

9.1, 9.2
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