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Using 3D thematic symbology to display features in a scene   
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Time: 1 hour, 30 minutes  

Overview  

Working in 3D environments involves more than making features look realistic. It also involves precision, 

analysis, visual perspectives, and so on. Working in 3D requires new, accurate x, y, and z content, as well 

as modifying that content, especially when working with real-life scenarios. These aspects are always 

changing, so you must be able to modify them in a 3D scene environment. 

As an urban planner, you have been tasked with creating multipatch features and performing texture 

editing for an urban area. As part of the workflow, you will extrude, edit, and symbolize the building 

footprints. After converting building footprints to multipatch features, you will apply textures to the 

buildings to make them as realistic as possible. 

In this lesson, you will learn to do the following: 

• Extrude and edit the building footprints 

• Symbolize the building footprints  

• Add and configure preset trees 

• Set a constant elevation 

• Edit a 3D grid for a building workflow   

• Create a new feature from existing data  

• Create a multipatch feature 

• Perform textured editing 

Download the data 

First, download the data. 

1. Download the Create-New-Content.zip compressed folder. 

2. Locate the downloaded file on your computer and extract it to a location you can easily find, 

such as your Documents folder. 

3. Open the Create New Content folder. 

https://downloads.esri.com/learnarcgis/3d/Create-New-Content.zip
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The study area is centered around Redlands, California.  

Open map package  

First, you need to create a project using the Blank project template. 

1. Start ArcGIS Pro and under New, click Local Scene. 

 

Note: If you don't have ArcGIS Pro or an ArcGIS account, you can sign up for an ArcGIS free 

trial. 

2. On the Quick Access toolbar, click Save  or press Ctrl+S to save your project. 

3. Name the project 3D-Editing and choose a suitable location. 

4. On the Insert tab, in the Project group, click Import Map . 

5. Browse to or search for Create_New_Content.mpkx to import this local scene. 

http://links.esri.com/arcgis-free-trial/
http://links.esri.com/arcgis-free-trial/
http://links.esri.com/arcgis-free-trial/
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6. Click OK. 

The Brookside Park scene opens.  

 

Extrude the building footprints to represent height 

Spend a few minutes familiarizing yourself with the scene content and the 2D and 3D layers organized 

in the scene contents layer. 
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1. On the Map tab, in the Navigate group, click Bookmarks and choose the Brookside 

Apartments bookmark. 
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2. In the Contents pane, click the Building Footprint Brookside layer to select and activate it. 

 

3. In the Appearance tab, Extrusion group, click the Type drop-down menu and click Base Height. 

 

4. Click the Field drop-down list and select the Building Height field to use this attribute field 

information. 
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5. Click the Unit drop-down list and select Feet. 

 

The building footprints display with extrusion representing their height. Currently all buildings have a 

default height of 10 feet. 
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6. Click the Extrusion Expression button to open the Expression Builder window. 

 

7. In the Expression Builder window, delete the current [BLDGHEIGHT] expression. 

 

8. Type 5 and click OK. 

 

The building footprints update showing an extrusion of 5 feet for all buildings. 
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9. Click on the Type drop-down arrow and select None to remove extrusion in preparation for the 

next step. 

 

Symbolize the building footprints using procedural symbols 

1. In the Contents pane, click the Building Footprint Brookside layer symbol icon to display 

the Symbology pane. 
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2. In the Format Polygon Symbol pane, click the Properties tab. 

 

3. In the Properties tab, click the Layers button. 

 

4. Click the Solid fill drop-down menu and select Procedural fill. 
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5. Click the Rule button to open the Select Rule Package browser window. 

6. Browse for Create New Content > Files > RPK and choose Int_City_2014.rpk. 

 

The Int_City_2014 properties pane updates. 
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7. In the Int_City_2014 properties pane, for Type, choose Apartment Building. 

8. For Building Shape, choose L-Shaped. 

 

9. For Total Height, click the database icon to open the Set Attribute Mapping window. 

10. From the drop-down menu, choose BLDGHEIGHT. 
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11. Click OK. 

 

Note: The database icon will be highlighted in blue to indicate that a field is being used. 

12. In the Symbology pane, click Apply to implement the rule package updates to the building 

footprints. 

 

The building footprints are now symbolized with models that have been derived from the rule package. 

Experiment with the updated scene and observe how the rule package has applied different roof types and 

additional parameters to the building footprints. Feel free to update and modify additional rule package 

settings such as facade texture. 
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13. Save the project. 

 

Add trees with preset configurations 

1. On the Map tab, in the Layer group, click Add Preset and click Realistic Trees. 

 

2. In the Add Data dialog box, browse for Create New Content, Brookside Park, and Redlands.gdb > 

Data and select the TreesA point feature class. 
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3. Click OK. 

 

The scene updates to display trees within the footprint of Brookside Park. However, the trees 

appear to be giant trees as the unit for their height is incorrectly set to meters. Let’s make some 

corrections to symbology to render the trees more realistically. 

4. In the Symbology pane for the TreesA layer, set the Unit to Feet. 
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The tree height is derived from an attribute named Crown Height and the values in the attribute field are 

in feet, but the default symbol unit is meters. You corrected this and the scene updates to display realistic 

3D trees that now render with the correct height for each tree. 

 

Set constant elevation 

A constant elevation plane is a level surface that can be used as a reference for the determination of 

the elevation of geographic features such as buildings and trees. In other words, it’s a baseline from 

which you can visually determine if a feature is elevated above or below the elevation of the constant 

plane. It is also useful in 3D editing as it serves as a constant for the defining the z-value of a feature. 

1. In the Brookside Park scene status bar located in the lower left of the scene, click the Dynamic 

Constraints button to enable this function. 
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2. On the Map tab, in the Navigate group, click Bookmarks and choose Community Center South 

View. 

3. Using the Navigator, explore the community center building and surrounding area. 

4. Click the Building Slab bookmark to display the community center building slab from above.  

 

You need to determine the elevation of the building slab to generate a constant elevation plane at 

the same height as the slab. 

5. On the Edit tab, in the Elevation group, click the Mode button to enable a constant Z mode. 
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6. In the Elevation group, click the Get Z from View button. 

 

7. In the scene, click the Building Slab polygon with the active Get Z from View button. 

 

The elevation derived from the slab polygon should be 1,327.6 feet. (Your elevation could vary.) 

8. Next, change the elevation units to meters (m). 

 

 The units in meters updates to 404.65 m. For our purposes, we need a constant plane generated 

at 395 meters.  

9. In the elevation dialog box, update the value to the exact value of 395, then press Enter. 
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The scene updates and now displays a constant elevation plane at an elevation of 395 meters. This is 

essentially a level surface taken as reference for the determination of elevations of other geographic 

features such as buildings and trees. 

The constant elevation plane displays in the scene as a transparent medium gray overlay. 

 

Notice how the constant plane extends north of the building slab, meaning that these areas are at 395 

meters, or lower than 395 meters, and that areas south of the slab are higher than 395 meters, as they are 

not covered by the plane. 

10. Using the explore tool, zoom out and tilt the scene to get a better perspective of the extent of the 

area covered by the constant elevation plane.  
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Working with the 3D grid 

Before editing and creating new 3D features, it is useful to generate a 3D grid that will serve as a 

reference and guide for the new or updated features. Next, you will setup a 3D grid. 

1. Click the Building Slab bookmark to display the community center building slab from above.  

2. In the Brookside Park scene status bar located in the lower left of the scene, click the Grid button 

to enable this function. 
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Note, a display 3D grid will show up in the scene.  

3. Hold the mouse pointer over the grid button to display the Grid properties pane. 

4. In the Grid properties pane, click the Set Origin and Rotation button. 

 

5. For Origin, snap to and click on the lower left corner of the Building Slab polygon feature. 

6. Once again, hold the mouse pointer over 

the grid button to display the Grid properties pane. 

7. In the Grid properties pane, update: 
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• Elevation to 395.25 meters. 

• Rotation to 90 degrees. 

• Spacing to 5 ft. 

 

Now your editing grid should be aligned to the Building Slab polygon feature. 

 

8. Save the project. 
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Draw an additional concrete step for the building slab 

In the following steps, you will create and design a rectangular concrete step north of the slab to provide 

an additional step down to a lower grass area. Remember, you have set a constant elevation value of 395 

meters. As a result, your newly constructed slab will be constructed at this elevation. 

 

1. If necessary, click the Building Slab bookmark to display the community center building slab from 

above. 

2. On the Edit tab, in the Features group, click Create to activate the Create Features pane. 

3. In the Create Features pane, expand the Building Slab feature template. 
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4. If the polygon construction tool is not active by default, click it to activate it. 

 

5. In the Brookside Park scene status bar in the lower left of the scene, click the snapping button to 

turn on snapping. 

 

6. Hold the mouse pointer over the snapping button to display the Snapping properties pane. 

In the Snapping properties pane, notice how you can modify the type of snapping from the default.  

7. Ensure that you have point snapping selected.  
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Next, you will start feature construction. 

8. For the start point, snap to a grid intersection to the lower left of the building slab with an offset 

and left-click to start the sketch. 

 

9. Move the pointer north along the grid, parallel with the existing slab to create the first segment. 

 

10. Make another left-click to add a vertex, offset from the existing corner. 
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Your first line segment should be created. 

11. For the second segment, move the pointer east along the grid, parallel with the existing slab.  

 

12. Left-click to create the vertex offset from the existing structure. 

 

The second line segment should be created. 
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13. For the remaining line segments, right-click to open the construction tool context menu. 

14. Click Square and Finish to complete the polygon. 

 

You should now have a new rectangular polygon feature that steps down to the grass area. 

 

15. On the Edit tab, in the Manage Edits group, click Save. 

16. Click Yes to commit your edits to the geodatabase. 

17. On the Edit tab in the Elevation group, click the Mode button to disable the constant elevation 

mode. 
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18. Save the project. 

Note: You can also repeat this entire section on feature creation, using dynamic constraints to enter the 

direction, offsets and distance, and so on for the polygon’s line segments. By pressing Tab you will be 

able to move from each input box to the next one. This workflow is recommended for high-precision 

workflows in which accuracy and attention to detail is of importance. 

Multipatch creation  

To complete this last step for this lesson we need to open another map package to the existing project.  

19. On the Insert tab, in the Project group, click Import Map. 

20. Browse in the same Create New Content lesson folder directory for ME2.mpkx to import this 

scene. 

 

21. Click OK. 
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A new scene is added to the project and displays world imagery and several 3D layers. 

22.  In Bookmarks for the new scene, select Second. 

 

The bookmark updates the extent to display a new retail development named the Packing House District. 

23. In the scene status bar in the lower left of the scene, click the Grid button to enable. 

24. In Bookmarks for the new scene, select Four. 
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25. Hold the mouse pointer over the Grid button to display the Grid properties pane. 

26. In the Grid properties pane, click the Set Origin and Rotation button. (Your elevation may vary.) 

 

27. For Origin, snap to and click the lower left corner of the building from the basemap imagery. 

 

28. Hold the mouse pointer over the Grid button to display the Grid properties pane. 
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29. In the Grid properties pane, update: 

• Elevation to 1,337 ft. 

• Rotation to 360 degrees.  

• Spacing to 8 ft. 

 

The editing grid should now be aligned to the basemap imagery building. 

 

30. In the scene status bar in the lower left of the scene, click both the Constraints and Snapping 

buttons to enable them. 
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31. On the Edit tab, in the Features group, click Create to activate the Create Features pane. 

32. In the Create Features pane, expand the New_Building feature template. 

 

33. Click the Create 3D geometry sketch tool. 

34. Construct the first vertex by snapping to the bottom left corner of the building. 

 

35. Next, create a vertex at the right corner of the building. 

 

36. Continue north and create a vertex at the upper right corner. 
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37. Add a vertex at the upper left corner.  

38. Right-click and select Finish. 

 

Your new building has been constructed. 
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39. Click the Third bookmark and zoom in to the newly created building. 

 

40. Move the pointer to the middle of the newly created multipatch face. 
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A green sphere should display in the middle of the feature. 

41. Place the pointer directly over the green sphere, which will turn red. 

42. Left-click and hold on the red sphere to interactively pull the face and press Tab. 

 

 

43. Type “20ft” and press Enter followed by the Finish button or press F2. 
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44. Turn off the Grid and Snapping from the status bar. 

45. On the Edit tab > Manage Edits group, click Save. 

46. Click Yes to commit your edits to the geodatabase. 

 

47. Save the project. 

Texture editing   

1. Make sure the newly created multipatch is still selected; if not, select the new multipatch. 
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2. Click the Modify button under the Edit tab to open the Modify Features pane. 

3. Select the Multipatch Texture tool. 

 

4. Click the Load Texture button. 
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5. Browse in the Create New Content lesson directory for a Textures folder. 

6. Select Roof.jpg and click Open. 

 

Wait until the preview image appears on the bottom part of the tool. 
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7. Place the pointer on the roof face and left-click to place it on that face. 
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8. Once the image is placed on the face, move the pointer back to the preview on the Modify 

Features pane. 

9. Move (pan), rotate or scale the preview as needed to fit it correctly on the roof of your new 

building. 

 

Hint: You could also use the three interactive mouse functions. Left-click hold pans, middle-click 

hold rotates, and right-click hold zoom. 

10. Add and place the other two textures to the sides by yourself. 
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11. When finished, click Apply on the tool. 

12. On the Edit tab > Manage Edits group, click Save. 

13. Click Yes to commit your edits to the geodatabase. 

14. In the Scene Contents pane, check the Other_Buildings layer. 

This will display all the additional buildings that were constructed using the same process that you just 

learned.  

 

 

 

15. Save your project and close ArcGIS Pro. 
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Summary 

In this lesson, you created a realistic building using multipatch editing tools and textures. In the real world, 

you could encounter simple to complex building geometry and roof forms. The above workflow can be 

used for different building types and shapes, with little more than a building footprint, height information, 

and images for texturing. 
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