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Importing and incorporating 3D models in a scene  

Time: 1 hour, 30 minutes  

Overview  

3D modeling, especially in urban environments, can significantly be improved by importing additional non-

GIS content, in different formats, derived using third-party tools. Using ArcGIS Pro, you can import several 

3D formats such as .3ds, .wrl, .skp, .flt, and .dae. ArcGIS Pro 2.2 includes support for Revit.rvt files as a data 

source.  

In some cases, 3D models may not be georeferenced, which can cause issues when integrating with GIS 

data that is projected and exists in coordinate space. However, ArcGIS Pro 2.2 has tools to update and fix 

unreferenced models using 3D georeferencing tools that make proper adjustments within the application. 

This lesson will guide you through the process of importing 3D content such as COLLADA.dae models into 

feature classes and placing them into a scene and importing Revit.rvt files into Pro as a data source and 

3D georeferencing them into 3D scenes. 

In this lesson, you will learn to do the following: 

• Import 3D models in various formats  

• Interact with imported 3D models 

• Add Revit.rvt project as a data source  

• Georeference a Revit.rvt model  

Open map package  

First, download the data.  

1. Download the Importing-Content.zip compressed folder.  

2. Locate the downloaded file on your computer and extract it to a location you can easily find, 

such as your Documents folder.  

3. Open the Importing-Content folder.  

The data for this lesson covers the Redlands Packinghouse District, Redlands, California. The data has 

been created by Esri, Inc. 

https://downloads.esri.com/LearnArcGIS/import-and-incorporate-3d-models-in-a-scene/importing-content.zip
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Next, create a project using the Blank Project template. 

1. Start ArcGIS Pro and click the Local Scene template to create an ArcGIS project. 

 

Note: If you don't have ArcGIS Pro or an ArcGIS account, you can sign up for an ArcGIS free trial. 

2. Name the project ImportModels, specify a suitable location, and click OK.  

3. On the Insert tab, in the Project group, click Import Map. 

4. Click, Import_Content.mpkx from the extract location. This will add a new local scene to your 

project. 

http://links.esri.com/arcgis-free-trial/
http://links.esri.com/arcgis-free-trial/
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5. Click OK. 

Adding, configuring, and placing a COLLADA.dae model   

3D scenes can be significantly enhanced and made more realistic with the addition of 3D symbols and real-

world models. Some of these models can be quite detailed or unique to a specific area or subject. As a result, 

many third-party model formats are supported in ArcGIS Pro.  

Next, you will explore the workflows and best practices for importing and using different formats and adding 

them to a 3D scene via a multipatch feature class.  

1. On the Edit tab > Features group, click the Create button. 
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The Create Features pane appears, displaying available template layers. 

 

You are able to edit and add new multipatch features to these layers. 

2. In the Contents pane, right-click Train and select Properties. 

3. In the Layer Properties window, click Source. 
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Note that the Train layer, Geometry Type is a Multipatch. This means that any new train feature created 

will be a 3D multipatch feature. Multipatch features consist of one or more faces that can be extruded to 

specify depth. In addition, faces can be split to create openings and edges dragged to complete features. 

4. Click Cancel to close the Layer Properties window. 

5. In the Create Features pane, click Train. 

 

The Create Features pane now displays the available Multipatch Construction tools. 
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6. Locate and click the Model File construction tool . 

7. Click the green plus to add one or more models. 

 

8. Browse to the Importing Content > Data Files > Collada folder and click Train.dae, then click OK. 

 

In the Create Features pane, notice that the Collada model has been added to the Active Template as a 

Multipatch feature. 
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9. If necessary, resize the pane to display the current model properties. 

 

At this point, you could change the Size, Rotation or Position of the Multipatch feature on the Active 

Template, if desired. 

10. Update the Angle (Z) to 90 dd. 
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In Scene 1, move the cursor and notice how you can add a new multipatch train feature derived from 

the COLLADA file.   

 

11. Using a simple click on the scene, add and place the 3D model of a train along the Southern 

California Regional rail line located to the south of the West Stuart Avenue. 
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12. On the Edit tab > Tools group, click the Move tool to update and move the newly placed train 

model. 

 

13. Explore the tool by moving and positioning the train model in x,y,z space. 

 

14. Explore with the Rotate tool. 
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15. Notice how you can flip the train upside down. 

 

16. Use the Scale tool. 

 

Notice how you can increase the width and height of the model as needed. 
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17. When you are done exploring, click Cancel to discard changes and exit the current operation. 

 

If you made any edits, click the Finish button on the mini-toolbar or press F2 to accept changes. 

18. On the Edit tab, in the Manage Edits group, and click Save. 

This will commit the newly created Train feature to the geodatabase feature class storing train features. 

 

19. Click Yes to save the project. 
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Adding, configuring, and placing an OBJ.obj model   

1. In the Create Features pane, click the Palms multipatch template. 

 

2. Locate and click the Model File construction tool. 

3. Click the green plus to add one or more models. 

4. Browse to the Importing Content > Data_Files > OBJ folder and select CA_Palm.obj, then click OK. 
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5. Move the pointer to the scene and notice the Palm multipatch feature generated from the Obj 

format. Do not click anywhere on the scene. 

 

6. In the Active Template properties pane, update the Height (Z) value from 119 to 10 ft. 
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Notice how it locks the aspect ratio by default; you can click on the three connecting bars to disable it. You 

can change the Size, Rotation, or Position of the Palm model. 

7. Place several palm trees with different sizes or configurations by modifying model properties in the 

Active Template. 

8. When finished, click the scene to place the 3D model. 

 

9. On the Edit tab > Manage Edits group, click Save.  

10. Click Yes to save edits. 

This will commit the newly created Palm feature to the geodatabase feature class storing train features. 

 

11. On the Edit tab > Selection group, click Clear to clear the selection. 

12. Close the Create Features pane. 
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13. Save the project. 

Reading and adding Revit.rvt (BIM) projects into ArcGIS Pro   

Revit is a design and documentation platform that supports the design, drawings, and schedules required 

for building information modeling (BIM). 

1. If necessary, on the View tab > Windows group, click the Catalog pane. 

2. In the Catalog pane, right-click the Folders section and click Add Folder Connection. 

 

3. Browse to or search for the Importing Content > Data_Files > Revit folder and click OK. 

 

4. Expand the Folders > Revit folder tree > COTTAGE_MODEL.rvt in the Catalog pane. 
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Notice how the entire COTTAGE_MODEL.rvt, Revit project is available directly as a data source 

without the need for conversion. 

5. Expand Structural under COTTAGE MODEL.rvt. 

 

Notice how the model consists of building elements organized into categories of element types. Structural 

contains structural elements of the building and includes the foundation, framing, and columns of the 

building. 

6. Expand Architectural. 

Note how this category includes doors, furniture, and other architectural elements of the building. 

7. When you are done exploring the model, collapse the open categories of elements. 
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8. In the Catalog pane, Folders > Revit, right-click COTTAGE_MODEL.rvt, then choose Add To Current 

Map. 

 

Note: You can also drag COTTAGE_MODEL.rvt onto the scene. 

Georeferencing a Revit.rvt (BIM) model 

When bringing 3D models from third-party applications into ArcGIS Pro, they are often not 

georeferenced, which means that they have no coordinate system.  This causes an issue when trying to 

place them in the correct coordinate space. You can use ArcGIS georeferencing tools to update and place 

the models in the correct coordinate space.  

After adding COTTAGE_MODEL.rvt to your scene, you will notice that it appears that nothing is displayed. 

The model has in fact been added to the scene but may have been added to a location in the middle or 

elsewhere in  the scene extent. This may be in the middle of the ocean, as the scene’s current coordinate 

system is set to WGS 1984 Web Mercator Auxiliary Sphere_1, which encompasses the extent of the world. 

1. In the Contents pane, right-click COTTAGE_MODEL and choose Zoom To Layer. 

Note: Depending on your settings, your model may be in a different location. Proceed to the next 

set of steps. 
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The scene updates and displays the COTTAGE_MODEL. 

 

2. Tilt the view or zoom out and notice how it was placed in the middle of the ocean. 



Importing and incorporating 3D models in a scene  

 

3. In the Contents pane, click COTTAGE_MODEL to select the layer. 

4. On the Manage tab > Alignment group, click Georeference. 

 

5. On the Georeference tab > Prepare group, click Locate. 



Importing and incorporating 3D models in a scene  

 

6. In the Locate pane, in the Search text box, type “Redlands” and press Enter. 

7. In the search results, choose Redlands, CA, USA. 

 

8. Zoom in close enough to view the Packing House buildings used in previous steps. 
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9. On the Georeference tab > Prepare group, click Move To Display. 

 

If needed, navigate around to notice how COTTAGE_MODEL.rvt displays on the relative location. Now you 

will move the cottage to a more suitable location. Next, you will tilt the view and zoom in on the cottage. 
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10. On the ribbon, Georeference tab > Prepare group, click Move. 

 

The cottage model is selected and displays navigation arrows to move the model in an x,y,z direction. 

Experiment and move the model to a suitable location opposite the train model added earlier. 
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11. On the ribbon, Georeference tab > Prepare group, click Scale. 

 

Experiment scaling the cottage model up by extending its length and width so that it may be used as a train 

depot. 
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12. On the ribbon, Georeference tab > Prepare group, click Rotate. 

 

Experiment rotating the cottage model to see if you can position it better within the space for use as a train 

depot. 

13. When you finish georeferencing and positioning and scaling the model, from the Georeference tab 

> Save group, click Save. 

This will create a 3D world file for the model. 

14. Click Yes. 

15.  Click the Close Georeference button to exit of the georeferencing process. 

16. Save the project and close ArcGIS Pro. 

 Summary  

When working with external or imported content, it is important to know the format of and software used 

to create the file. This will help determine the correct workflow needed to display and use the file in ArcGIS 

Pro. Workflows may include either creating a multipatch feature classes or a BIM composite layer from 
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the original content. Supporting, sharing and consuming external/imported content are particularly 

important for third parties and agencies working on site-specific projects and new proposed designs. 


	Overview
	In this lesson, you will learn to do the following:
	Open map package
	Adding, configuring, and placing a COLLADA.dae model
	Adding, configuring, and placing an OBJ.obj model
	Reading and adding Revit.rvt (BIM) projects into ArcGIS Pro
	Georeferencing a Revit.rvt (BIM) model
	Summary

