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Upgrading Geodatabase Raster 
Data From ArcGIS 8.3 to  
ArcGIS 9 
 

Introduction Many users have stored raster data in ESRI® ArcSDE® 8.3, and when they 
upgrade their system to ArcGIS® 9 or ArcSDE 9, there are concerns  
about how the data will behave in the new version and be upgraded.  This 
document describes the behavior of geodatabase raster data when the 
client and/or server are upgraded from 8.3 to 9.0 and the upgrading paths 
for various types of geodatabase raster data.  Since a few changes have 
been made to ArcGIS 9 and ArcSDE 9 software products, some steps may 
need to be taken to utilize the raster data previously stored in the 
geodatabase.  In most cases, the raster data does not need to be reloaded.  
For some types of raster data, no action needs to be taken at all; for others, 
a few simple procedures will make the data accessible in the new 
environment and take full advantage of the improved features.  For one 
rare case, reloading may need to be considered. 
 
The upgrading schedules for ArcGIS and ArcSDE may be different for some users or 
organizations.  It is desirable for users to upgrade both ArcGIS client and ArcSDE server 
at the same time; however, in some cases, upgrading ArcSDE server with production or 
live data on it may not be an easy and quick task.  Users should experiment with the new 
version before making any final moves; they may choose to upgrade only ArcGIS client 
to 9.0, leaving ArcSDE server and data untouched.  This will create the setting that 
consists of ArcGIS 9 client and ArcSDE 8.3 server.  Both client/server combination 
scenarios will be discussed in this document. 
 
The major upgrading paths that are covered in this document are 
 
! Upgrading the raster data set 
! Upgrading the embedded raster catalog 
! Upgrading the referenced raster catalog 
! Loading data with SDERaster 
 

Upgrading the 
Raster Data Set 

The raster data set concept and implementations have changed from 8.3 to 9.0.  The 
difference is the schema change at 9.0.  At ArcGIS 9, there is an additional geometry type  
column in the raster data set business table.  This column is added primarily for 
consistency with the raster catalog schema, but it is rarely used by ArcGIS functions. 
 
Upgrading the raster data set does not necessarily require users to do anything.  The raster 
data set works in both ArcGIS 9/ArcSDE 8.3 and ArcGIS 9/ArcSDE 9 environments.  If 
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the user wants to utilize the geometry column that is available in ArcGIS 9/ArcSDE 9, it 
is possible to write customized ArcObjects™ code to register the raster data set with the 
geodatabase.  This will add a geometry column to the raster data set business table and 
populate the raster extent to that column. 
 

Upgrading the 
Embedded Raster 

Catalog 

Embedded raster catalogs are a set of raster data sets organized through one business 
table in ArcSDE.  At ArcGIS 8.3, embedded raster catalogs are not geodatabase objects;  
they are plain tables in the geodatabase.  Only in the upper application level are they 
interpreted as raster catalogs based on the raster column and other characteristics stored 
in ArcSDE system tables.  At ArcGIS 9, raster catalogs are fully incorporated into the 
geodatabase model; the geodatabase is aware of this type of data.  The raster catalog 
schema also changed in ArcGIS 9 to include a geometry type column that stores the 
footprint of each raster data set in the raster catalog.  This addition makes spatial query 
more efficient for raster catalogs. 
 

Case 1:  ArcGIS 9/ 
ArcSDE 8.3 

In this setting, no action needs to be taken; the raster catalogs in ArcSDE 8.3 server 
behaves in ArcGIS 9 client exactly the same as in ArcGIS 8.3 client.  It still displays as a  
table icon and has the same functionalities; however, the new rendering and spatial search 
capabilities that are available in ArcGIS 9 cannot be applied to these raster catalogs. 
 

Case 2:  ArcGIS 9/ 
ArcSDE 9 

In this case, both client and server are upgraded to 9.0 versions, but the data in the 
ArcSDE server stays intact in the 8.3 schemas.  Without manipulating the raster data, the  
original raster catalog will behave as a table with a raster column.  In ArcGIS 9, a raster 
layer cannot be created from the table; therefore, no geography display is available 
(Figure 1). 
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Figure 1 
Raster Catalog With 8.3 Schema in ArcGIS 9/ArcSDE 9 
 

 
 
To make raster catalogs with 8.3 schema act as a raster catalog in 9.0, you must register 
the raster catalog with the geodatabase.  This command can be executed from the 
ArcCatalog™ user interface by right-clicking the raster catalog table and selecting 
Register with Geodatabase from the context menu (Figure 2).  This operation adds a 
geometry type column to the raster catalog business table and updates related 
geodatabase system tables.  A proper x,y domain is set for the geometry column in the 
raster catalog to cover the whole extent of the raster catalog.  In addition, the geometry 
column is populated with the extents of each individual raster data sets in the raster 
catalog.  Once the registration is complete and the raster catalog is in the new 9.0 schema, 
it can take full advantage of the improved rendering capabilities, spatial search, and the 
new raster catalog overview panels in ArcCatalog (Figure 3). 
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Figure 2 
Register with Geodatabase 

 

 
 

Figure 3 
Raster Catalog With 9.0 Schema in ArcGIS 9 
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Upgrading the 
Referenced Raster 

Catalog 

Referenced raster catalogs supported in ArcGIS 8.3 include file raster catalogs (image 
catalogs in ArcInfo® Workstation) and a Spatial Data Engine™ (SDE®) table that 
references raster files, raster data sets in ArcSDE, or raster data sets in embedded raster 
catalogs in ArcSDE.  One characteristic of referenced raster catalogs is that their 
catalog table schema has at least the following five columns:  IMAGE, XMIN, YMIN, 
XMAX, and YMAX. 
 

File-Based Raster 
Catalog 

The file-based raster catalog includes raster catalog tables in the format of .txt file, INFO 
table, .dbf table, and so forth.  These raster catalogs will continue to behave the same way  
in ArcGIS 9 as in ArcGIS 8.3.  Unless the user wants to move the data to ArcSDE, there 
is no need to take any action.  If the user wants to take advantage of the new rendering 
and spatial query capabilities that are available in ArcGIS 9, there are two possible 
options.  One is to create an unmanaged raster catalog in a personal geodatabase that 
references all the raster files in the original raster catalog.  In this case, no data loading or 
conversion is needed.  The other option is to create a new raster catalog in ArcSDE 9 
from the file raster catalog (refer to the sample on Developer Help > Samples > Raster > 
Converting Raster Data > Convert 8.3 Referenced Raster Catalog to 9.0 GDB Raster 
Catalog). 
 

SDE Table-Based 
Reference Raster 

Catalogs 

This type of referenced raster catalog has the raster catalog table stored in ArcSDE, but 
the rasters referenced can be on file or in ArcSDE.   

 
Case 1:  ArcGIS 9/ 

ArcSDE 8.3 
With the ArcSDE server in 8.3 version and client updated to 9.0, the raster catalogs 
behave the same way as the client in 8.3 when the referenced rasters in the SDE table are  
all stored in ArcSDE.  If any of the referenced rasters are in a file system, an error will 
occur when trying to draw that particular raster.  Ignore the error—the data frame will be 
displayed instead (Figures 4 and 5).  
 

Figure 4 
SDE Table-Based Referenced Raster Catalog 
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Figure 5 
SDE Table-Based Referenced Raster Catalog With File Rasters 

 

 
 

Case 2:  ArcGIS 9/ 
ArcSDE 9 

Once both ArcSDE and ArcGIS are upgraded to 9.0, the SDE table-based reference raster 
catalogs are no longer treated as raster catalogs; they are treated as plain tables instead.   
Only the rows in the table are maintained.  The reference or connection to the raster data 
is lost and no geography view is available.  For the data to be accessed as a geodatabase 
raster catalog in the 9.0 environment, two options are available for the SDE table-based 
referenced raster catalog if the catalog references files are on disk.  One option is to 
create an unmanaged, personal geodatabase raster catalog that points to the referenced 
files; the other option is to create an ArcSDE raster catalog and load the data into it.  For 
raster catalogs that reference rasters stored in the database, creating a new raster catalog 
and reloading the data have to be considered.  Refer to the sample in the Developer Help 
(Develop Help > Samples > Raster > Convert 8.3 Referenced Raster Catalog to 9.0 GDB 
Raster Catalog) for upgrading the referenced raster catalog to a 9.0 geodatabase raster 
catalog. 
 

Loading Data With 
SDERaster 

In the ArcGIS 9/ArcSDE 9 environment, it is recommended that you use ArcGIS 
Geoprocessing tools to load raster data to the geodatabase.  However, for certain cases,  
the user may want to use the SDERaster command to load the data (for example, when 
ArcSDE and data are all installed on a UNIX system and the user has compiled batch 
loading scripts with SDERaster that are well tuned for specific needs).  As long as 
SDERaster is being used to load data, the issues that might occur must be dealt with. 
 
At 9.0, both raster data set and raster catalog schemas contain a geometry type column, 
but SDERaster command is not aware of this column since the schemas are defined at the 
geodatabase level, which is on top of the SDE C application program interface.  
Basically, the SDERaster command loads data only to the raster column.  For raster data 
sets, the geometry column is not required for data access or display in ArcGIS; therefore, 
loading raster data sets with SDERaster command will create a raster data set that can be 
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directly used in ArcGIS 9.  If the geometry column is somehow needed for certain 
applications, the data set has to be registered with the geodatabase by using ArcObjects. 
 

Create a Raster 
Catalog and Insert 

With SDERaster  

Creating a raster catalog with the SDERaster command will result in a raster catalog in 
8.3 schema that does not have a geometry column in its business table.  It is interpreted as 
a table with a raster column in ArcGIS 9.  To make it a 9.0 geodatabase raster catalog, the  
user must register it with the geodatdabase after loading all the data (Figure 2).  
 

Create a Raster 
Catalog With the 

Geoprocessing Tool 
and Insert Rasters 

With SDERaster 

If the user creates a raster catalog with the Geoproecessing tool or ArcObjects, the raster 
catalog is in 9.0 schema, which includes both the raster column and geometry column.  
Once the raster catalog is created, SDERaster command is used to insert raster data.  The 
raster column is then populated with the rasters, and the geometry column remains empty 
since SDERaster does not utilize that column.  With an empty geometry column, a raster  
catalog cannot be previewed in ArcGIS.  Since there is not a Geoprocessing tool or 
context menu to update the geometry column for a raster catalog yet, it has to be done 
using ArcObjects.  The following sample Visual Basic code updates the geometry 
column in the raster catalog with the extent of the rasters in the catalog.  The code is also 
published on Developer Help > Raster > Converting Raster Data > Update Geometry 
Column In Raster Catalog. 
 

Sample Visual Basic 
Code for Updating the 

Geometry Column 

Sub UpdateGeometryInRasterCatalog(pSDEWs As IRasterWorkspaceEx, sCatalog As 
string) 
  
  ' Update the geometry column in a 9.0 raster catalog 
  Dim pCatalog As IRasterCatalog 
  Dim pCatalogHelper As IRasterCatalogHelper 
  
  'Open raster catalog 
  Set pCatalog = pSDEWs.OpenRasterCatalog(sCatalog) 
  
  'Initialize helper class 
  Set pCatalogHelper = New RasterCatalogHelper 
  
  'Update the geometry 
  pCatalogHelper.UpdateFootprint pCatalog 
     
  Set pCatalog = Nothing 
  Set pCatalogHelper = Nothing 
   
End Sub 
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